ace-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jean-Baptiste Onofré ...@nanthrax.net>
Subject Re: Supported maven version ?
Date Wed, 27 Apr 2011 12:37:26 GMT
Agree with Hadrian:

is there any reason to not use Maven 3 ?

I made all changes in the build to fully support Maven 3, so I think 
that we can use that for the first ACE release.

Regards
JB

On 04/27/2011 02:34 PM, Hadrian Zbarcea wrote:
> The minimum supported version should be at least 2.2.1. Maven 2.2.0 and prior have bugs
(iirc some related to artifact signing) and it shouldn't be used.
> In any case, I don't believe anybody is still using such older versions. I would also
be ok with requiring at least 3.x. It's a new project, I don't think many would object to
that and it has some nifty features (like better reporting, using multiple threads).
>
> My $0.02,
> Hadrian
>
>
> On Apr 27, 2011, at 4:15 AM, Jean-Baptiste Onofré wrote:
>
>> Hi all,
>>
>> I fixed ACE-127 to use the maven enforcer plugin for the maven and JDK version check.
>>
>> For now, I set maven 2.0.11 as the minimum version.
>>
>> Could we act that we *only* support maven 3 now ?
>>
>> If all are OK, I will update the enforcer configuration and the ACE build page:
>>
>> http://incubator.apache.org/ace/maven-build.html
>>
>> Thanks
>> Regards
>> JB
>

Mime
View raw message