ace-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Marcel Offermans (JIRA)" <j...@apache.org>
Subject [jira] Reopened: (ACE-94) Build requires maven version greater then 2.0.11 but this is not declared
Date Wed, 02 Mar 2011 00:22:36 GMT

     [ https://issues.apache.org/jira/browse/ACE-94?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Marcel Offermans reopened ACE-94:
---------------------------------

      Assignee: Marcel Offermans  (was: Jean-Baptiste Onofré)

Not fixed correctly. Suddenly Maven 3.0.2 is the minimum version needed to build ACE, which
is not something we should change without any form of discussion on the list. Reopening for
now and I'll commit some quick fixes to at least make the build work again.

> Build requires maven version greater then  2.0.11 but this is not declared
> --------------------------------------------------------------------------
>
>                 Key: ACE-94
>                 URL: https://issues.apache.org/jira/browse/ACE-94
>             Project: Ace
>          Issue Type: Improvement
>          Components: Maven Build
>         Environment: Apache Maven 2.0.11 (r909250; 2010-02-12 06:55:50+0100)
> Java version: 1.6.0_21
> Java home: C:\Program Files (x86)\Java\jdk1.6.0_21\jre
> Default locale: nl_NL, platform encoding: Cp1252
> OS name: "windows 7" version: "6.1" arch: "x86" Family: "windows"
>            Reporter: Bram de Kruijff
>            Assignee: Marcel Offermans
>            Priority: Minor
>             Fix For: 0.8.0
>
>         Attachments: ACE_maven2011_cleaninstall.txt
>
>
> When you try to build the trunk at r1022542 using Maven 2.0.11 you get the following
non-helpfull error right at the start of the build:
> [ERROR] BUILD ERROR
> [INFO] ------------------------------------------------------------------------
> [INFO] Unable to initialise extensions
> Component descriptor role: 'org.apache.maven.wagon.CommandExecutor', implementation:
'org.apache.maven.wagon.providers.ssh.external.ScpExternalCommandExecutor',
>  role hint: 'scpexe' has a hint, but there are other implementations that don't
> It seems the build requires a Maven version greater then 2.0.11 (not sure which one exactly)
but this message does not make that clear for the average Jonh Doe. Therefore I suggest adding
a small prerequisites section in the root pom that will make people happy. This will still
cause the build to fail, but this time with the nice and informative message:
> [ERROR] BUILD FAILURE
> [INFO] ------------------------------------------------------------------------
> [INFO] Unable to build project 'c:\bramk\amdatu\svn\ace-trunk\pom.xml; it requires Maven
version 2.2.1 
> The relevant snippet to add would (assuming 2.2.1) be:
>     <prerequisites>
>         <maven>2.2.1</maven>
>     </prerequisites>

-- 
This message is automatically generated by JIRA.
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

       

Mime
View raw message