ace-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Toni Menzel (JIRA)" <j...@apache.org>
Subject [jira] Commented: (ACE-94) Build requires maven version greater then 2.0.11 but this is not declared
Date Thu, 14 Oct 2010 14:36:34 GMT

    [ https://issues.apache.org/jira/browse/ACE-94?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12920975#action_12920975
] 

Toni Menzel commented on ACE-94:
--------------------------------

This is somwhat strange, can you give a hint: which goals do you run ? e.g. "clean install"
??
Also, can you provide a full log?
I am not fully aware that we do use 2.0.x incompatible plugins - but may be.

Besides that, i would rather recommend running with Maven 3, as i don't see the benefit of
using outdated Maven versions. Its a tool, its free and you get everything but old strange
issues with 2.0.x versions.

Its true, corporates cannot move with any Maven release cycle, but on the other hand, tools
get better over time, you lose less time running into corner-issues, get better error messages,
faster builds.

-> I know, you just point to adding the "prerequisites" configuration. Just wanted to get
behind the reason of keeping 2.0.x alive.

> Build requires maven version greater then  2.0.11 but this is not declared
> --------------------------------------------------------------------------
>
>                 Key: ACE-94
>                 URL: https://issues.apache.org/jira/browse/ACE-94
>             Project: Ace
>          Issue Type: Improvement
>          Components: Maven Build
>         Environment: Apache Maven 2.0.11 (r909250; 2010-02-12 06:55:50+0100)
> Java version: 1.6.0_21
> Java home: C:\Program Files (x86)\Java\jdk1.6.0_21\jre
> Default locale: nl_NL, platform encoding: Cp1252
> OS name: "windows 7" version: "6.1" arch: "x86" Family: "windows"
>            Reporter: Bram de Kruijff
>            Priority: Minor
>
> When you try to build the trunk at r1022542 using Maven 2.0.11 you get the following
non-helpfull error right at the start of the build:
> [ERROR] BUILD ERROR
> [INFO] ------------------------------------------------------------------------
> [INFO] Unable to initialise extensions
> Component descriptor role: 'org.apache.maven.wagon.CommandExecutor', implementation:
'org.apache.maven.wagon.providers.ssh.external.ScpExternalCommandExecutor',
>  role hint: 'scpexe' has a hint, but there are other implementations that don't
> It seems the build requires a Maven version greater then 2.0.11 (not sure which one exactly)
but this message does not make that clear for the average Jonh Doe. Therefore I suggest adding
a small prerequisites section in the root pom that will make people happy. This will still
cause the build to fail, but this time with the nice and informative message:
> [ERROR] BUILD FAILURE
> [INFO] ------------------------------------------------------------------------
> [INFO] Unable to build project 'c:\bramk\amdatu\svn\ace-trunk\pom.xml; it requires Maven
version 2.2.1 
> The relevant snippet to add would (assuming 2.2.1) be:
>     <prerequisites>
>         <maven>2.2.1</maven>
>     </prerequisites>

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message