ace-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From zoe slattery <zoe.slatt...@gmail.com>
Subject Re: Running Samples with the Maven Based Build
Date Wed, 06 Oct 2010 11:53:51 GMT
  On 06/10/2010 11:05, Toni Menzel wrote:
> Hi Zoe,
>
> glad to see you + aries people here on ace. ;)
I have an ulterior motive :-) I'm talking at ApacheCon - its a beginners 
OSGi talk on interesting OSGi projects and what they are good for. So 
I'm testing the 'getting started' instructions for a whole bunch of 
projects. I'd like to say a couple of things about ACE - but I feel I 
need to be able to do a very simple command line based deployment at the 
minimum.
> The log message "Highest remote: null / Highest local: null" was also
> a little confusing to me, but it just says, that there is nothing to
> be deployed on the managementagent (old speak: gateway) yet.
That's useful thanks. There are so many of those messages that I never 
actually get the console prompt. Is there a way to turn them off?
> About: "The WebUI is there but looks a little odd"
> Its a rush GWT port of a commercial UI that has not been open sourced
> by luminis. Currently, Marcel is doing a Vaadlin Version instead -
> heard its much more straightforward to develop such a ui than raw GWT.
> So, better we'll wait for him here. But i agree the current webUI is
> not the best thing since sliced bread.
> But it works, i believe there was a screencast on how to use it by
> Angelo ? Not sure.
I didn't find one - I agree it would be really helpful. Although - I'd 
be more than happy to see something working from a command line :-/
>   If not we should make one. Otherwise its quite hard
> to get started.
> As a quick hint: you need to add bundles the repository by copying
> them to the upload folder (not sure, its called repository i guess in
> the server folder). They should appear on the left column in the ui.
> Also, when running one or more gateways, they should appear in the UI, too.
> Now you can bring the "two" together by wiring them: create a group,
> drag the artifact (left) on the group, and so on. So its drag an drop
> based. Coloring indicate "wired" pieces.
I'll have more of a play this afternoon....will let you know where I get to.
> Bottomline:
> Your builds are fine, just the UI needs assistance and/or a replacement.
Right - they *look* fine as far as I can tell - but I do get an error 
from the server build:

"ERROR: The data file path must be relative, not absolute."

That may be OK but having something called 'ERROR' is always a bit 
disconcerting for a new user :-) Is it something I have done wrong?

Zoe
> Toni
>
>
> On Wed, Oct 6, 2010 at 11:31 AM, zoe slattery<zoe.slattery@gmail.com>  wrote:
>>   On 05/10/2010 22:59, Hiranya Jayathilaka wrote:
>>> Hi Devs,
>>>
>>> As I understand the two main tutorials available on the website
>>> (Getting started with file based server, Getting started with Web UI
>>> server) deal with the legacy module in the Ace trunk. So I guess I
>>> have to build the legacy module using Ant to follow these articles. Am
>>> I correct? Are there any similar documents for the Maven based build?
>>>
>>> Thanks
>> I have exactly the same problem. I followed the build instructions for the
>> maven build, got the server running and the gateway (albeit with a
>> distracting info message every second(?) "Highest remote: null / Highest
>> local: null") - did not get any further than this so far. The WebUI is there
>> but looks a little odd - I'd like to get the command line instructions
>> working, any pointers would be much appreciated.
>>
>> Zoė
>>
>
>


Mime
View raw message