ace-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Marcel Offermans <marcel.offerm...@luminis.nl>
Subject Re: ace-target-devgateway up and running!
Date Sat, 30 Jan 2010 23:57:26 GMT
Yes. I'm by no means a Maven expert either, but to solve this issue you can:

Checkout the deployment admin module from Felix:

svn co http://svn.apache.org/repos/asf/felix/trunk/deploymentadmin/

and then:

mvn install

That should get you going. In case that doesn't work (I did not actually try just checking
out one module in Felix) you might need to checkout everything starting one level up (in other
words the whole Felix source tree) and then do that build.

Greetings, Marcel


On Jan 31, 2010, at 0:45 , Christopher Brind wrote:

> By repository I presume you mean Maven?  Is there a quick way to do that?
> Apart from running the commands that people have told me, I've used Maven
> very little.
> 
> Thanks,
> Chris
> 
> 
> On 30 January 2010 23:41, Marcel Offermans <marcel.offermans@luminis.nl>wrote:
> 
>> Hello Chris,
>> 
>> Whoops, I completely forgot to mention that. We are at the moment relying
>> on a not-yet-released snapshot of DeploymentAdmin that is not yet in any
>> snapshot repository either.
>> 
>> That means for now you need to get it from Apache Felix, and install it in
>> your local repository. It's of course one of the things we need to fix, but
>> for now that should get you going.
>> 
>> Thanks for trying!
>> 
>> Greetings, Marcel
>> 
>> 
>> On Jan 31, 2010, at 0:15 , Christopher Brind wrote:
>> 
>>> Hi Marcel,
>>> 
>>> I get the following error when executing "mvn clean install -Ptargets"
>>> 
>>> Downloading:
>>> 
>> http://repository.apache.org/snapshots/org/apache/felix/org.apache.felix.deploymentadmin/0.9.0-SNAPSHOT/org.apache.felix.deploymentadmin-0.9.0-SNAPSHOT.jar
>>> [INFO] Unable to find resource
>>> 'org.apache.felix:org.apache.felix.deploymentadmin:jar:0.9.0-SNAPSHOT' in
>>> repository apache.snapshots (http://repository.apache.org/snapshots)
>>> [INFO]
>>> ------------------------------------------------------------------------
>>> [ERROR] BUILD ERROR
>>> [INFO]
>>> ------------------------------------------------------------------------
>>> [INFO] Failed to resolve artifact.
>>> 
>>> Missing:
>>> ----------
>>> 1) org.apache.felix:org.apache.felix.deploymentadmin:jar:0.9.0-SNAPSHOT
>>> 
>>> Try downloading the file manually from the project website.
>>> 
>>> Then, install it using the command:
>>>     mvn install:install-file -DgroupId=org.apache.felix
>>> -DartifactId=org.apache.felix.deploymentadmin -Dversion=0.9.0-SNAPSHOT
>>> -Dpackaging=jar -Dfile=/path/to/file
>>> 
>>> Alternatively, if you host your own repository you can deploy the file
>>> there:
>>>     mvn deploy:deploy-file -DgroupId=org.apache.felix
>>> -DartifactId=org.apache.felix.deploymentadmin -Dversion=0.9.0-SNAPSHOT
>>> -Dpackaging=jar -Dfile=/path/to/file -Durl=[url] -DrepositoryId=[id]
>>> 
>>> Path to dependency:
>>>  1) org.apache.ace:ace-target-devgateway:pom:0.8.0-SNAPSHOT
>>>  2) org.apache.felix:org.apache.felix.deploymentadmin:jar:0.9.0-SNAPSHOT
>>> 
>>> ----------
>>> 1 required artifact is missing.
>>> 
>>> for artifact:
>>> org.apache.ace:ace-target-devgateway:pom:0.8.0-SNAPSHOT
>>> 
>>> from the specified remote repositories:
>>> apache.snapshots (http://repository.apache.org/snapshots),
>>> central (http://repo1.maven.org/maven2)
>>> 
>>> 
>>> 
>>> [INFO]
>>> ------------------------------------------------------------------------
>>> [INFO] For more information, run Maven with the -e switch
>>> [INFO]
>>> ------------------------------------------------------------------------
>>> [INFO] Total time: 35 seconds
>>> [INFO] Finished at: Sat Jan 30 23:13:47 GMT 2010
>>> [INFO] Final Memory: 21M/79M
>>> [INFO]
>>> ------------------------------------------------------------------------
>>> 
>>> Cheers,
>>> Chris
>>> 
>>> 
>>> 
>>> On 30 January 2010 22:55, Marcel Offermans <marcel.offermans@luminis.nl
>>> wrote:
>>> 
>>>> After all the work that has already been done on the Mavenization, I
>> took
>>>> some time to get the ace-target-devgateway up and running. In the end,
>> two
>>>> minor fixes to the Bnd files were all it took.
>>>> 
>>>> I'm running this target against the dev-server-webui as created by the
>> Ant
>>>> build.
>>>> 
>>>> To do this yourself, in a shell (with a full checkout of the sources):
>>>> 
>>>> ant release (which basically runs the full ant build with all testing
>> and
>>>> packaging)
>>>> cd deploy/target/dev-server-webui
>>>> sh run.sh (now the server should be up and running, browse to
>>>> http://localhost:8080/webui/ to validate)
>>>> 
>>>> In a second shell (from the base checkout dir) as also explained at
>>>> http://incubator.apache.org/ace/maven-build.html:
>>>> 
>>>> mvn clean install
>>>> mvn clean install -Ptargets
>>>> cd
>>>> 
>> ace-target-devgateway/target/ace-target-devgateway-0.8.0-SNAPSHOT-distribution/ace-gateway/
>>>> sh run.sh
>>>> 
>>>> Now in the web UI you should see the gateway showing up in the last
>> column.
>>>> 
>>>> I would appreciate it if anybody could confirm they get this far. Next
>> up
>>>> will be a bigger task, getting all server side bundles working.
>>>> 
>>>> Greetings, Marcel
>>>> 
>>>> 
>> 
>> 


Mime
View raw message