ace-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Niels Schroeter (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (ACE-540) Cannot add Artifact
Date Thu, 21 Apr 2016 11:04:25 GMT

    [ https://issues.apache.org/jira/browse/ACE-540?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15251718#comment-15251718
] 

Niels Schroeter commented on ACE-540:
-------------------------------------

I can confirm it is a UI related bug, when i add the artifact in the gogo shell by executing

{quote}
g! w = (cw)  
g! $w ca org.apache.felix.deployment.rp.autoconf http://central.maven.org/maven2/org/apache/felix/org.apache.felix.deployment.rp.autoconf/0.1.8/org.apache.felix.deployment.rp.autoconf-0.1.8.jar
org.apache.felix.deployment.rp.autoconf 0.1.8
g! $w commit
{quote}

and login again, the artifact is correctly shown in the UI.

> Cannot add Artifact
> -------------------
>
>                 Key: ACE-540
>                 URL: https://issues.apache.org/jira/browse/ACE-540
>             Project: ACE
>          Issue Type: Bug
>          Components: UI
>    Affects Versions: 2.0.1
>            Reporter: Niels Schroeter
>
> When uploading an artifact, it does not show up in the artifacts column. When trying
to upload it again, an error message pops up: "All 1 artifacts failed! Failed to add new object:
entity already exists!"
> The artifact is org.apache.felix.deployment.rp.autoconf-0.1.8 (available via maven repo)
and its manifest looks (fine, i guess )like this:
> {quote}
> Manifest-Version: 1.0
> Bundle-Description: A customizer bundle that publishes a Resource Proc
>  essor service that processes configuration resources shipped in a Dep
>  loyment Package.
> Bundle-License: http://www.apache.org/licenses/LICENSE-2.0.txt
> DeploymentPackage-Customizer: true
> Bundle-SymbolicName: org.apache.felix.deployment.rp.autoconf
> Built-By: jawi
> Bundle-ManifestVersion: 2
> Bnd-LastModified: 1452955859778
> Bundle-DocURL: http://www.apache.org/
> Bundle-Vendor: The Apache Software Foundation
> Import-Package: org.apache.felix.dm;version="[4.1,5)",org.osgi.framewo
>  rk;version="[1.5,2)",org.osgi.service.cm;version="[1.3,2)",org.osgi.s
>  ervice.deploymentadmin;version="[1.0,2)",org.osgi.service.deploymenta
>  dmin.spi;version="[1.0,2)",org.osgi.service.event;version="[1.2,2)",o
>  rg.osgi.service.log;version="[1.3,2)",org.osgi.service.metatype;versi
>  on="[1.3,2)",org.osgi.util.tracker;version="[1.4,2)"
> Tool: Bnd-1.15.0
> Export-Package: org.osgi.service.deploymentadmin.spi;uses:="org.osgi.f
>  ramework,org.osgi.service.deploymentadmin";version="1.0",org.osgi.ser
>  vice.metatype;uses:="org.osgi.framework";version="1.2"
> Deployment-ProvidesResourceProcessor: org.osgi.deployment.rp.autoconf
> Bundle-Version: 0.1.8
> Bundle-Name: Apache Felix AutoConf Resource Processor
> Bundle-Activator: org.apache.felix.deployment.rp.autoconf.Activator
> Created-By: Apache Maven Bundle Plugin
> Build-Jdk: 1.8.0_45
> {quote}
> Note: this happens for many other artifacts aswell, i just picked this one since it is
an official felix bundle.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message