ace-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From j...@apache.org
Subject svn commit: r1727746 [2/3] - in /ace/trunk: cnf/releaserepo/ cnf/releaserepo/org.apache.ace.agent.launcher.base/ cnf/releaserepo/org.apache.ace.agent.launcher.felix/ cnf/releaserepo/org.apache.ace.agent/ cnf/releaserepo/org.apache.ace.ant.tasks/ cnf/re...
Date Sat, 30 Jan 2016 19:19:25 GMT

Modified: ace/trunk/cnf/releaserepo/index.xml
URL: http://svn.apache.org/viewvc/ace/trunk/cnf/releaserepo/index.xml?rev=1727746&r1=1727745&r2=1727746&view=diff
==============================================================================
--- ace/trunk/cnf/releaserepo/index.xml (original)
+++ ace/trunk/cnf/releaserepo/index.xml Sat Jan 30 19:19:22 2016
@@ -1,51 +1,54 @@
 <?xml version="1.0" encoding="utf-8"?>
-<repository increment="1400570501000" name="Release" xmlns="http://www.osgi.org/xmlns/repository/v1.0.0">
+<repository increment="1454180881000" name="Release" xmlns="http://www.osgi.org/xmlns/repository/v1.0.0">
   <resource>
     <capability namespace="osgi.identity">
       <attribute name="osgi.identity" value="org.apache.ace.agent.launcher.base"/>
       <attribute name="type" value="osgi.bundle"/>
-      <attribute name="version" type="Version" value="1.0.0"/>
+      <attribute name="version" type="Version" value="1.0.1"/>
     </capability>
     <capability namespace="osgi.content">
-      <attribute name="osgi.content" value="219e8a792f07ea531b2a2ee38262003a07799871cb1e9d6dc4b5510d887d6b53"/>
-      <attribute name="url" value="org.apache.ace.agent.launcher.base/org.apache.ace.agent.launcher.base-1.0.0.jar"/>
-      <attribute name="size" type="Long" value="266418"/>
+      <attribute name="osgi.content" value="b596315e694cecbac607a69d69c277fdfd870755aad01aa534f1a5bff8aa4449"/>
+      <attribute name="url" value="org.apache.ace.agent.launcher.base/org.apache.ace.agent.launcher.base-1.0.1.jar"/>
+      <attribute name="size" type="Long" value="618606"/>
       <attribute name="mime" value="application/vnd.osgi.bundle"/>
     </capability>
     <capability namespace="osgi.wiring.bundle">
       <attribute name="osgi.wiring.bundle" value="org.apache.ace.agent.launcher.base"/>
-      <attribute name="bundle-version" type="Version" value="1.0.0"/>
+      <attribute name="bundle-version" type="Version" value="1.0.1"/>
     </capability>
     <capability namespace="osgi.wiring.host">
       <attribute name="osgi.wiring.host" value="org.apache.ace.agent.launcher.base"/>
-      <attribute name="bundle-version" type="Version" value="1.0.0"/>
+      <attribute name="bundle-version" type="Version" value="1.0.1"/>
     </capability>
     <requirement namespace="osgi.wiring.package">
-      <directive name="filter" value="(&amp;(osgi.wiring.package=org.osgi.framework)(version&gt;=1.6.0)(!(version&gt;=2.0.0)))"/>
+      <directive name="filter" value="(&amp;(osgi.wiring.package=org.osgi.framework)(version&gt;=1.8.0)(!(version&gt;=2.0.0)))"/>
     </requirement>
     <requirement namespace="osgi.wiring.package">
-      <directive name="filter" value="(&amp;(osgi.wiring.package=org.osgi.framework.launch)(version&gt;=1.0.0)(!(version&gt;=2.0.0)))"/>
+      <directive name="filter" value="(&amp;(osgi.wiring.package=org.osgi.framework.launch)(version&gt;=1.2.0)(!(version&gt;=2.0.0)))"/>
+    </requirement>
+    <requirement namespace="osgi.ee">
+      <directive name="filter" value="(&amp;(osgi.ee=JavaSE)(version=1.7))"/>
     </requirement>
   </resource>
   <resource>
     <capability namespace="osgi.identity">
       <attribute name="osgi.identity" value="org.apache.ace.agent.launcher.felix"/>
       <attribute name="type" value="osgi.bundle"/>
-      <attribute name="version" type="Version" value="1.0.0"/>
+      <attribute name="version" type="Version" value="1.0.1"/>
     </capability>
     <capability namespace="osgi.content">
-      <attribute name="osgi.content" value="0b43efacbe8396134413ad2fe5b8e65595ef57257aee870d11b5277797f31dbd"/>
-      <attribute name="url" value="org.apache.ace.agent.launcher.felix/org.apache.ace.agent.launcher.felix-1.0.0.jar"/>
-      <attribute name="size" type="Long" value="775076"/>
+      <attribute name="osgi.content" value="6937d39dfa10791ac52a1186d50deb85c18cee82e6be0d5e8377a29fff18de3d"/>
+      <attribute name="url" value="org.apache.ace.agent.launcher.felix/org.apache.ace.agent.launcher.felix-1.0.1.jar"/>
+      <attribute name="size" type="Long" value="1533992"/>
       <attribute name="mime" value="application/vnd.osgi.bundle"/>
     </capability>
     <capability namespace="osgi.wiring.bundle">
       <attribute name="osgi.wiring.bundle" value="org.apache.ace.agent.launcher.felix"/>
-      <attribute name="bundle-version" type="Version" value="1.0.0"/>
+      <attribute name="bundle-version" type="Version" value="1.0.1"/>
     </capability>
     <capability namespace="osgi.wiring.host">
       <attribute name="osgi.wiring.host" value="org.apache.ace.agent.launcher.felix"/>
-      <attribute name="bundle-version" type="Version" value="1.0.0"/>
+      <attribute name="bundle-version" type="Version" value="1.0.1"/>
     </capability>
     <capability namespace="osgi.contract">
       <attribute name="osgi.contract" value="OSGiFramework"/>
@@ -54,46 +57,49 @@
     <requirement namespace="osgi.wiring.package">
       <directive name="filter" value="(osgi.wiring.package=javax.security.auth.x500)"/>
     </requirement>
+    <requirement namespace="osgi.ee">
+      <directive name="filter" value="(&amp;(osgi.ee=JavaSE)(version=1.7))"/>
+    </requirement>
   </resource>
   <resource>
     <capability namespace="osgi.identity">
       <attribute name="osgi.identity" value="org.apache.ace.agent"/>
       <attribute name="type" value="osgi.bundle"/>
-      <attribute name="version" type="Version" value="1.0.1"/>
+      <attribute name="version" type="Version" value="1.0.2"/>
     </capability>
     <capability namespace="osgi.content">
-      <attribute name="osgi.content" value="13fdb2eeda6275de967bf411334bc9d2452081610d70637208d4426fa3e7999d"/>
-      <attribute name="url" value="org.apache.ace.agent/org.apache.ace.agent-1.0.1.jar"/>
-      <attribute name="size" type="Long" value="249246"/>
+      <attribute name="osgi.content" value="d4912f560c20c77d372e846f7bb38fe46a572680cc0560dbc80305f33905bb5a"/>
+      <attribute name="url" value="org.apache.ace.agent/org.apache.ace.agent-1.0.2.jar"/>
+      <attribute name="size" type="Long" value="433669"/>
       <attribute name="mime" value="application/vnd.osgi.bundle"/>
     </capability>
     <capability namespace="osgi.wiring.bundle">
       <attribute name="osgi.wiring.bundle" value="org.apache.ace.agent"/>
-      <attribute name="bundle-version" type="Version" value="1.0.1"/>
+      <attribute name="bundle-version" type="Version" value="1.0.2"/>
     </capability>
     <capability namespace="osgi.wiring.host">
       <attribute name="osgi.wiring.host" value="org.apache.ace.agent"/>
-      <attribute name="bundle-version" type="Version" value="1.0.1"/>
+      <attribute name="bundle-version" type="Version" value="1.0.2"/>
     </capability>
     <capability namespace="osgi.wiring.package">
       <attribute name="osgi.wiring.package" value="org.apache.ace.agent"/>
       <attribute name="version" type="Version" value="2.0.0"/>
       <attribute name="bundle-symbolic-name" value="org.apache.ace.agent"/>
-      <attribute name="bundle-version" type="Version" value="1.0.1"/>
+      <attribute name="bundle-version" type="Version" value="1.0.2"/>
       <directive name="uses" value="org.osgi.framework,org.osgi.service.deploymentadmin"/>
     </capability>
     <capability namespace="osgi.wiring.package">
       <attribute name="osgi.wiring.package" value="org.osgi.service.deploymentadmin"/>
       <attribute name="version" type="Version" value="1.1.0"/>
       <attribute name="bundle-symbolic-name" value="org.apache.ace.agent"/>
-      <attribute name="bundle-version" type="Version" value="1.0.1"/>
+      <attribute name="bundle-version" type="Version" value="1.0.2"/>
       <directive name="uses" value="org.osgi.framework"/>
     </capability>
     <capability namespace="osgi.wiring.package">
       <attribute name="osgi.wiring.package" value="org.osgi.service.deploymentadmin.spi"/>
       <attribute name="version" type="Version" value="1.0.1"/>
       <attribute name="bundle-symbolic-name" value="org.apache.ace.agent"/>
-      <attribute name="bundle-version" type="Version" value="1.0.1"/>
+      <attribute name="bundle-version" type="Version" value="1.0.2"/>
       <directive name="uses" value="org.osgi.framework,org.osgi.service.deploymentadmin"/>
     </capability>
     <requirement namespace="osgi.wiring.package">
@@ -106,7 +112,7 @@
       <directive name="filter" value="(&amp;(osgi.wiring.package=org.apache.ace.agent)(version&gt;=2.0.0)(!(version&gt;=2.1.0)))"/>
     </requirement>
     <requirement namespace="osgi.wiring.package">
-      <directive name="filter" value="(&amp;(osgi.wiring.package=org.osgi.framework)(version&gt;=1.5.0)(!(version&gt;=2.0.0)))"/>
+      <directive name="filter" value="(&amp;(osgi.wiring.package=org.osgi.framework)(version&gt;=1.6.0)(!(version&gt;=2.0.0)))"/>
     </requirement>
     <requirement namespace="osgi.wiring.package">
       <directive name="filter" value="(&amp;(osgi.wiring.package=org.osgi.service.deploymentadmin)(version&gt;=1.1.0)(!(version&gt;=2.0.0)))"/>
@@ -117,103 +123,72 @@
     <requirement namespace="osgi.wiring.package">
       <directive name="filter" value="(&amp;(osgi.wiring.package=org.osgi.service.packageadmin)(version&gt;=1.2.0)(!(version&gt;=2.0.0)))"/>
     </requirement>
-  </resource>
-  <resource>
-    <capability namespace="osgi.identity">
-      <attribute name="osgi.identity" value="org.apache.ace.ant.tasks"/>
-      <attribute name="type" value="osgi.bundle"/>
-      <attribute name="version" type="Version" value="1.0.1"/>
-    </capability>
-    <capability namespace="osgi.content">
-      <attribute name="osgi.content" value="9b8a54e012f9549dac81b32a84e51adb7b00064b1de9225c03ebfb56e4c8986c"/>
-      <attribute name="url" value="org.apache.ace.ant.tasks/org.apache.ace.ant.tasks-1.0.1.jar"/>
-      <attribute name="size" type="Long" value="8079"/>
-      <attribute name="mime" value="application/vnd.osgi.bundle"/>
-    </capability>
-    <capability namespace="osgi.wiring.bundle">
-      <attribute name="osgi.wiring.bundle" value="org.apache.ace.ant.tasks"/>
-      <attribute name="bundle-version" type="Version" value="1.0.1"/>
-    </capability>
-    <capability namespace="osgi.wiring.host">
-      <attribute name="osgi.wiring.host" value="org.apache.ace.ant.tasks"/>
-      <attribute name="bundle-version" type="Version" value="1.0.1"/>
-    </capability>
-    <capability namespace="osgi.wiring.package">
-      <attribute name="osgi.wiring.package" value="org.apache.ace.ant.deploymentpackage"/>
-      <attribute name="version" type="Version" value="1.0.0"/>
-      <attribute name="bundle-symbolic-name" value="org.apache.ace.ant.tasks"/>
-      <attribute name="bundle-version" type="Version" value="1.0.1"/>
-      <directive name="uses" value="org.apache.tools.ant,org.apache.tools.ant.taskdefs"/>
-    </capability>
-    <requirement namespace="osgi.wiring.package">
-      <directive name="filter" value="(&amp;(osgi.wiring.package=org.apache.ace.builder)(version&gt;=2.0.0)(!(version&gt;=3.0.0)))"/>
-    </requirement>
-    <requirement namespace="osgi.wiring.package">
-      <directive name="filter" value="(osgi.wiring.package=org.apache.tools.ant)"/>
-    </requirement>
-    <requirement namespace="osgi.wiring.package">
-      <directive name="filter" value="(osgi.wiring.package=org.apache.tools.ant.taskdefs)"/>
+    <requirement namespace="osgi.ee">
+      <directive name="filter" value="(&amp;(osgi.ee=JavaSE)(version=1.7))"/>
     </requirement>
   </resource>
   <resource>
     <capability namespace="osgi.identity">
       <attribute name="osgi.identity" value="org.apache.ace.authentication.api"/>
       <attribute name="type" value="osgi.bundle"/>
-      <attribute name="version" type="Version" value="1.0.0"/>
+      <attribute name="version" type="Version" value="1.0.1"/>
     </capability>
     <capability namespace="osgi.content">
-      <attribute name="osgi.content" value="c84ac50c0c6209b869070e15e8b8223320b07a6da2994d18a2979f9977423f8c"/>
-      <attribute name="url" value="org.apache.ace.authentication.api/org.apache.ace.authentication.api-1.0.0.jar"/>
-      <attribute name="size" type="Long" value="6332"/>
+      <attribute name="osgi.content" value="5baa8554a2e966015c376f5b72b34866e29b9f8dada2a3bfc74415f9e916dde2"/>
+      <attribute name="url" value="org.apache.ace.authentication.api/org.apache.ace.authentication.api-1.0.1.jar"/>
+      <attribute name="size" type="Long" value="6313"/>
       <attribute name="mime" value="application/vnd.osgi.bundle"/>
     </capability>
     <capability namespace="osgi.wiring.bundle">
       <attribute name="osgi.wiring.bundle" value="org.apache.ace.authentication.api"/>
-      <attribute name="bundle-version" type="Version" value="1.0.0"/>
+      <attribute name="bundle-version" type="Version" value="1.0.1"/>
     </capability>
     <capability namespace="osgi.wiring.host">
       <attribute name="osgi.wiring.host" value="org.apache.ace.authentication.api"/>
-      <attribute name="bundle-version" type="Version" value="1.0.0"/>
+      <attribute name="bundle-version" type="Version" value="1.0.1"/>
     </capability>
     <capability namespace="osgi.wiring.package">
       <attribute name="osgi.wiring.package" value="org.apache.ace.authentication.api"/>
       <attribute name="version" type="Version" value="1.0.0"/>
       <attribute name="bundle-symbolic-name" value="org.apache.ace.authentication.api"/>
-      <attribute name="bundle-version" type="Version" value="1.0.0"/>
+      <attribute name="bundle-version" type="Version" value="1.0.1"/>
       <directive name="uses" value="org.osgi.service.useradmin"/>
     </capability>
     <requirement namespace="osgi.wiring.package">
       <directive name="filter" value="(&amp;(osgi.wiring.package=org.osgi.service.useradmin)(version&gt;=1.1.0)(!(version&gt;=2.0.0)))"/>
     </requirement>
+    <requirement namespace="osgi.ee">
+      <directive name="filter" value="(&amp;(osgi.ee=JavaSE)(version=1.7))"/>
+    </requirement>
   </resource>
   <resource>
     <capability namespace="osgi.identity">
       <attribute name="osgi.identity" value="org.apache.ace.authentication.impl"/>
       <attribute name="type" value="osgi.bundle"/>
-      <attribute name="version" type="Version" value="1.0.0"/>
+      <attribute name="version" type="Version" value="1.0.1"/>
     </capability>
     <capability namespace="osgi.content">
-      <attribute name="osgi.content" value="d3981484bf97f9c03f0f3ddb491702306d8c40f704da377faf6ff44cd5c26f59"/>
-      <attribute name="url" value="org.apache.ace.authentication.impl/org.apache.ace.authentication.impl-1.0.0.jar"/>
-      <attribute name="size" type="Long" value="9869"/>
+      <attribute name="osgi.content" value="935c8e7e0f9f3fbff2d838dca49abe18aec712ebc1946381dcd53919419fd85d"/>
+      <attribute name="url" value="org.apache.ace.authentication.impl/org.apache.ace.authentication.impl-1.0.1.jar"/>
+      <attribute name="size" type="Long" value="9921"/>
       <attribute name="mime" value="application/vnd.osgi.bundle"/>
     </capability>
     <capability namespace="osgi.wiring.bundle">
       <attribute name="osgi.wiring.bundle" value="org.apache.ace.authentication.impl"/>
-      <attribute name="bundle-version" type="Version" value="1.0.0"/>
+      <attribute name="bundle-version" type="Version" value="1.0.1"/>
     </capability>
     <capability namespace="osgi.wiring.host">
       <attribute name="osgi.wiring.host" value="org.apache.ace.authentication.impl"/>
-      <attribute name="bundle-version" type="Version" value="1.0.0"/>
+      <attribute name="bundle-version" type="Version" value="1.0.1"/>
     </capability>
     <requirement namespace="osgi.wiring.package">
       <directive name="filter" value="(&amp;(osgi.wiring.package=org.apache.ace.authentication.api)(version&gt;=1.0.0)(!(version&gt;=1.1.0)))"/>
     </requirement>
     <requirement namespace="osgi.wiring.package">
-      <directive name="filter" value="(&amp;(osgi.wiring.package=org.apache.felix.dm)(version&gt;=3.0.0)(!(version&gt;=4.0.0)))"/>
+      <directive name="filter" value="(&amp;(osgi.wiring.package=org.apache.felix.dm)(version&gt;=4.1.0)(!(version&gt;=5.0.0)))"/>
     </requirement>
     <requirement namespace="osgi.wiring.package">
-      <directive name="filter" value="(&amp;(osgi.wiring.package=org.osgi.framework)(version&gt;=1.5.0)(!(version&gt;=2.0.0)))"/>
+      <directive name="filter" value="(&amp;(osgi.wiring.package=org.osgi.framework)(version&gt;=1.8.0)(!(version&gt;=2.0.0)))"/>
     </requirement>
     <requirement namespace="osgi.wiring.package">
       <directive name="filter" value="(&amp;(osgi.wiring.package=org.osgi.service.log)(version&gt;=1.3.0)(!(version&gt;=2.0.0)))"/>
@@ -221,65 +196,71 @@
     <requirement namespace="osgi.wiring.package">
       <directive name="filter" value="(&amp;(osgi.wiring.package=org.osgi.service.useradmin)(version&gt;=1.1.0)(!(version&gt;=2.0.0)))"/>
     </requirement>
+    <requirement namespace="osgi.ee">
+      <directive name="filter" value="(&amp;(osgi.ee=JavaSE)(version=1.7))"/>
+    </requirement>
   </resource>
   <resource>
     <capability namespace="osgi.identity">
       <attribute name="osgi.identity" value="org.apache.ace.authentication.processor.basicauth"/>
       <attribute name="type" value="osgi.bundle"/>
-      <attribute name="version" type="Version" value="1.0.0"/>
+      <attribute name="version" type="Version" value="1.0.1"/>
     </capability>
     <capability namespace="osgi.content">
-      <attribute name="osgi.content" value="b74f7d333afe364d59d63af243990dd7236178ba76118ebcd4a25055dfec9721"/>
-      <attribute name="url" value="org.apache.ace.authentication.processor.basicauth/org.apache.ace.authentication.processor.basicauth-1.0.0.jar"/>
-      <attribute name="size" type="Long" value="28017"/>
+      <attribute name="osgi.content" value="df02d8ab5c98afeaa6e35099230cfec3520803d417bae7ef37bf2ddde3121ecf"/>
+      <attribute name="url" value="org.apache.ace.authentication.processor.basicauth/org.apache.ace.authentication.processor.basicauth-1.0.1.jar"/>
+      <attribute name="size" type="Long" value="28024"/>
       <attribute name="mime" value="application/vnd.osgi.bundle"/>
     </capability>
     <capability namespace="osgi.wiring.bundle">
       <attribute name="osgi.wiring.bundle" value="org.apache.ace.authentication.processor.basicauth"/>
-      <attribute name="bundle-version" type="Version" value="1.0.0"/>
+      <attribute name="bundle-version" type="Version" value="1.0.1"/>
     </capability>
     <capability namespace="osgi.wiring.host">
       <attribute name="osgi.wiring.host" value="org.apache.ace.authentication.processor.basicauth"/>
-      <attribute name="bundle-version" type="Version" value="1.0.0"/>
+      <attribute name="bundle-version" type="Version" value="1.0.1"/>
     </capability>
     <requirement namespace="osgi.wiring.package">
-      <directive name="filter" value="(&amp;(osgi.wiring.package=javax.servlet.http)(version&gt;=2.5.0)(!(version&gt;=3.0.0)))"/>
+      <directive name="filter" value="(&amp;(osgi.wiring.package=javax.servlet.http)(version&gt;=2.6.0)(!(version&gt;=3.0.0)))"/>
     </requirement>
     <requirement namespace="osgi.wiring.package">
       <directive name="filter" value="(&amp;(osgi.wiring.package=org.apache.ace.authentication.api)(version&gt;=1.0.0)(!(version&gt;=2.0.0)))"/>
     </requirement>
     <requirement namespace="osgi.wiring.package">
-      <directive name="filter" value="(&amp;(osgi.wiring.package=org.apache.felix.dm)(version&gt;=3.0.0)(!(version&gt;=4.0.0)))"/>
+      <directive name="filter" value="(&amp;(osgi.wiring.package=org.apache.felix.dm)(version&gt;=4.1.0)(!(version&gt;=5.0.0)))"/>
     </requirement>
     <requirement namespace="osgi.wiring.package">
-      <directive name="filter" value="(&amp;(osgi.wiring.package=org.osgi.framework)(version&gt;=1.5.0)(!(version&gt;=2.0.0)))"/>
+      <directive name="filter" value="(&amp;(osgi.wiring.package=org.osgi.framework)(version&gt;=1.8.0)(!(version&gt;=2.0.0)))"/>
     </requirement>
     <requirement namespace="osgi.wiring.package">
-      <directive name="filter" value="(&amp;(osgi.wiring.package=org.osgi.service.cm)(version&gt;=1.3.0)(!(version&gt;=2.0.0)))"/>
+      <directive name="filter" value="(&amp;(osgi.wiring.package=org.osgi.service.cm)(version&gt;=1.4.0)(!(version&gt;=2.0.0)))"/>
     </requirement>
     <requirement namespace="osgi.wiring.package">
       <directive name="filter" value="(&amp;(osgi.wiring.package=org.osgi.service.useradmin)(version&gt;=1.1.0)(!(version&gt;=2.0.0)))"/>
     </requirement>
+    <requirement namespace="osgi.ee">
+      <directive name="filter" value="(&amp;(osgi.ee=JavaSE)(version=1.7))"/>
+    </requirement>
   </resource>
   <resource>
     <capability namespace="osgi.identity">
       <attribute name="osgi.identity" value="org.apache.ace.authentication.processor.clientcert"/>
       <attribute name="type" value="osgi.bundle"/>
-      <attribute name="version" type="Version" value="1.0.0"/>
+      <attribute name="version" type="Version" value="1.0.1"/>
     </capability>
     <capability namespace="osgi.content">
-      <attribute name="osgi.content" value="9a3e6a899e9b228b57cf6740f2816586864ec6764963c08de6291f3ed4281d87"/>
-      <attribute name="url" value="org.apache.ace.authentication.processor.clientcert/org.apache.ace.authentication.processor.clientcert-1.0.0.jar"/>
-      <attribute name="size" type="Long" value="11572"/>
+      <attribute name="osgi.content" value="5ec917962fe22f639a1527e6b9928538d8a3e11b7d2ac4b93cfa48bd4b9f2ed7"/>
+      <attribute name="url" value="org.apache.ace.authentication.processor.clientcert/org.apache.ace.authentication.processor.clientcert-1.0.1.jar"/>
+      <attribute name="size" type="Long" value="11619"/>
       <attribute name="mime" value="application/vnd.osgi.bundle"/>
     </capability>
     <capability namespace="osgi.wiring.bundle">
       <attribute name="osgi.wiring.bundle" value="org.apache.ace.authentication.processor.clientcert"/>
-      <attribute name="bundle-version" type="Version" value="1.0.0"/>
+      <attribute name="bundle-version" type="Version" value="1.0.1"/>
     </capability>
     <capability namespace="osgi.wiring.host">
       <attribute name="osgi.wiring.host" value="org.apache.ace.authentication.processor.clientcert"/>
-      <attribute name="bundle-version" type="Version" value="1.0.0"/>
+      <attribute name="bundle-version" type="Version" value="1.0.1"/>
     </capability>
     <requirement namespace="osgi.wiring.package">
       <directive name="filter" value="(osgi.wiring.package=javax.naming)"/>
@@ -291,19 +272,19 @@
       <directive name="filter" value="(osgi.wiring.package=javax.security.auth.x500)"/>
     </requirement>
     <requirement namespace="osgi.wiring.package">
-      <directive name="filter" value="(&amp;(osgi.wiring.package=javax.servlet.http)(version&gt;=2.5.0)(!(version&gt;=3.0.0)))"/>
+      <directive name="filter" value="(&amp;(osgi.wiring.package=javax.servlet.http)(version&gt;=2.6.0)(!(version&gt;=3.0.0)))"/>
     </requirement>
     <requirement namespace="osgi.wiring.package">
       <directive name="filter" value="(&amp;(osgi.wiring.package=org.apache.ace.authentication.api)(version&gt;=1.0.0)(!(version&gt;=2.0.0)))"/>
     </requirement>
     <requirement namespace="osgi.wiring.package">
-      <directive name="filter" value="(&amp;(osgi.wiring.package=org.apache.felix.dm)(version&gt;=3.0.0)(!(version&gt;=4.0.0)))"/>
+      <directive name="filter" value="(&amp;(osgi.wiring.package=org.apache.felix.dm)(version&gt;=4.1.0)(!(version&gt;=5.0.0)))"/>
     </requirement>
     <requirement namespace="osgi.wiring.package">
-      <directive name="filter" value="(&amp;(osgi.wiring.package=org.osgi.framework)(version&gt;=1.5.0)(!(version&gt;=2.0.0)))"/>
+      <directive name="filter" value="(&amp;(osgi.wiring.package=org.osgi.framework)(version&gt;=1.8.0)(!(version&gt;=2.0.0)))"/>
     </requirement>
     <requirement namespace="osgi.wiring.package">
-      <directive name="filter" value="(&amp;(osgi.wiring.package=org.osgi.service.cm)(version&gt;=1.3.0)(!(version&gt;=2.0.0)))"/>
+      <directive name="filter" value="(&amp;(osgi.wiring.package=org.osgi.service.cm)(version&gt;=1.4.0)(!(version&gt;=2.0.0)))"/>
     </requirement>
     <requirement namespace="osgi.wiring.package">
       <directive name="filter" value="(&amp;(osgi.wiring.package=org.osgi.service.log)(version&gt;=1.3.0)(!(version&gt;=2.0.0)))"/>
@@ -311,68 +292,74 @@
     <requirement namespace="osgi.wiring.package">
       <directive name="filter" value="(&amp;(osgi.wiring.package=org.osgi.service.useradmin)(version&gt;=1.1.0)(!(version&gt;=2.0.0)))"/>
     </requirement>
+    <requirement namespace="osgi.ee">
+      <directive name="filter" value="(&amp;(osgi.ee=JavaSE)(version=1.7))"/>
+    </requirement>
   </resource>
   <resource>
     <capability namespace="osgi.identity">
       <attribute name="osgi.identity" value="org.apache.ace.authentication.processor.password"/>
       <attribute name="type" value="osgi.bundle"/>
-      <attribute name="version" type="Version" value="1.0.0"/>
+      <attribute name="version" type="Version" value="1.0.1"/>
     </capability>
     <capability namespace="osgi.content">
-      <attribute name="osgi.content" value="6e8e82ea961d9ced8648878a7eaf4a1859889095c143296a3ffe748e484451d9"/>
-      <attribute name="url" value="org.apache.ace.authentication.processor.password/org.apache.ace.authentication.processor.password-1.0.0.jar"/>
-      <attribute name="size" type="Long" value="29710"/>
+      <attribute name="osgi.content" value="8ae6e4aef9691c9048e7a9c6b1b2ac863f92ab74d78484259769d766d88c3184"/>
+      <attribute name="url" value="org.apache.ace.authentication.processor.password/org.apache.ace.authentication.processor.password-1.0.1.jar"/>
+      <attribute name="size" type="Long" value="29701"/>
       <attribute name="mime" value="application/vnd.osgi.bundle"/>
     </capability>
     <capability namespace="osgi.wiring.bundle">
       <attribute name="osgi.wiring.bundle" value="org.apache.ace.authentication.processor.password"/>
-      <attribute name="bundle-version" type="Version" value="1.0.0"/>
+      <attribute name="bundle-version" type="Version" value="1.0.1"/>
     </capability>
     <capability namespace="osgi.wiring.host">
       <attribute name="osgi.wiring.host" value="org.apache.ace.authentication.processor.password"/>
-      <attribute name="bundle-version" type="Version" value="1.0.0"/>
+      <attribute name="bundle-version" type="Version" value="1.0.1"/>
     </capability>
     <requirement namespace="osgi.wiring.package">
       <directive name="filter" value="(&amp;(osgi.wiring.package=org.apache.ace.authentication.api)(version&gt;=1.0.0)(!(version&gt;=2.0.0)))"/>
     </requirement>
     <requirement namespace="osgi.wiring.package">
-      <directive name="filter" value="(&amp;(osgi.wiring.package=org.apache.felix.dm)(version&gt;=3.0.0)(!(version&gt;=4.0.0)))"/>
+      <directive name="filter" value="(&amp;(osgi.wiring.package=org.apache.felix.dm)(version&gt;=4.1.0)(!(version&gt;=5.0.0)))"/>
     </requirement>
     <requirement namespace="osgi.wiring.package">
-      <directive name="filter" value="(&amp;(osgi.wiring.package=org.osgi.framework)(version&gt;=1.5.0)(!(version&gt;=2.0.0)))"/>
+      <directive name="filter" value="(&amp;(osgi.wiring.package=org.osgi.framework)(version&gt;=1.8.0)(!(version&gt;=2.0.0)))"/>
     </requirement>
     <requirement namespace="osgi.wiring.package">
-      <directive name="filter" value="(&amp;(osgi.wiring.package=org.osgi.service.cm)(version&gt;=1.3.0)(!(version&gt;=2.0.0)))"/>
+      <directive name="filter" value="(&amp;(osgi.wiring.package=org.osgi.service.cm)(version&gt;=1.4.0)(!(version&gt;=2.0.0)))"/>
     </requirement>
     <requirement namespace="osgi.wiring.package">
       <directive name="filter" value="(&amp;(osgi.wiring.package=org.osgi.service.useradmin)(version&gt;=1.1.0)(!(version&gt;=2.0.0)))"/>
     </requirement>
+    <requirement namespace="osgi.ee">
+      <directive name="filter" value="(&amp;(osgi.ee=JavaSE)(version=1.7))"/>
+    </requirement>
   </resource>
   <resource>
     <capability namespace="osgi.identity">
       <attribute name="osgi.identity" value="org.apache.ace.bnd.repository"/>
       <attribute name="type" value="osgi.bundle"/>
-      <attribute name="version" type="Version" value="1.0.0"/>
+      <attribute name="version" type="Version" value="1.0.1"/>
     </capability>
     <capability namespace="osgi.content">
-      <attribute name="osgi.content" value="8e8263b110de61c03290af3a99768472e433855cf5fb129741248a27afae6d7f"/>
-      <attribute name="url" value="org.apache.ace.bnd.repository/org.apache.ace.bnd.repository-1.0.0.jar"/>
-      <attribute name="size" type="Long" value="7510"/>
+      <attribute name="osgi.content" value="e787203488c5694aca5da0d2e6bb018f67b90e773db396c8df74d56c13c9a88f"/>
+      <attribute name="url" value="org.apache.ace.bnd.repository/org.apache.ace.bnd.repository-1.0.1.jar"/>
+      <attribute name="size" type="Long" value="7495"/>
       <attribute name="mime" value="application/vnd.osgi.bundle"/>
     </capability>
     <capability namespace="osgi.wiring.bundle">
       <attribute name="osgi.wiring.bundle" value="org.apache.ace.bnd.repository"/>
-      <attribute name="bundle-version" type="Version" value="1.0.0"/>
+      <attribute name="bundle-version" type="Version" value="1.0.1"/>
     </capability>
     <capability namespace="osgi.wiring.host">
       <attribute name="osgi.wiring.host" value="org.apache.ace.bnd.repository"/>
-      <attribute name="bundle-version" type="Version" value="1.0.0"/>
+      <attribute name="bundle-version" type="Version" value="1.0.1"/>
     </capability>
     <capability namespace="osgi.wiring.package">
       <attribute name="osgi.wiring.package" value="org.apache.ace.bnd.repository"/>
       <attribute name="version" type="Version" value="1.0.0"/>
       <attribute name="bundle-symbolic-name" value="org.apache.ace.bnd.repository"/>
-      <attribute name="bundle-version" type="Version" value="1.0.0"/>
+      <attribute name="bundle-version" type="Version" value="1.0.1"/>
       <directive name="uses" value="aQute.bnd.deployer.repository,aQute.bnd.service"/>
     </capability>
     <requirement namespace="osgi.wiring.package">
@@ -381,53 +368,59 @@
     <requirement namespace="osgi.wiring.package">
       <directive name="filter" value="(&amp;(osgi.wiring.package=aQute.bnd.service)(version&gt;=4.0.0)(!(version&gt;=5.0.0)))"/>
     </requirement>
+    <requirement namespace="osgi.ee">
+      <directive name="filter" value="(&amp;(osgi.ee=JavaSE)(version=1.7))"/>
+    </requirement>
   </resource>
   <resource>
     <capability namespace="osgi.identity">
       <attribute name="osgi.identity" value="org.apache.ace.builder"/>
       <attribute name="type" value="osgi.bundle"/>
-      <attribute name="version" type="Version" value="2.0.0"/>
+      <attribute name="version" type="Version" value="2.0.1"/>
     </capability>
     <capability namespace="osgi.content">
-      <attribute name="osgi.content" value="c2a93dc0f20231b3ac26dfedc02b2ec28467ca3ea9086c9e40eaf6dad2795bd7"/>
-      <attribute name="url" value="org.apache.ace.builder/org.apache.ace.builder-2.0.0.jar"/>
-      <attribute name="size" type="Long" value="12273"/>
+      <attribute name="osgi.content" value="c654242321b8426f3f16863c21bf85931ed1da6d08167782a55f08171bffd6d0"/>
+      <attribute name="url" value="org.apache.ace.builder/org.apache.ace.builder-2.0.1.jar"/>
+      <attribute name="size" type="Long" value="12254"/>
       <attribute name="mime" value="application/vnd.osgi.bundle"/>
     </capability>
     <capability namespace="osgi.wiring.bundle">
       <attribute name="osgi.wiring.bundle" value="org.apache.ace.builder"/>
-      <attribute name="bundle-version" type="Version" value="2.0.0"/>
+      <attribute name="bundle-version" type="Version" value="2.0.1"/>
     </capability>
     <capability namespace="osgi.wiring.host">
       <attribute name="osgi.wiring.host" value="org.apache.ace.builder"/>
-      <attribute name="bundle-version" type="Version" value="2.0.0"/>
+      <attribute name="bundle-version" type="Version" value="2.0.1"/>
     </capability>
     <capability namespace="osgi.wiring.package">
       <attribute name="osgi.wiring.package" value="org.apache.ace.builder"/>
       <attribute name="version" type="Version" value="2.0.0"/>
       <attribute name="bundle-symbolic-name" value="org.apache.ace.builder"/>
-      <attribute name="bundle-version" type="Version" value="2.0.0"/>
+      <attribute name="bundle-version" type="Version" value="2.0.1"/>
     </capability>
+    <requirement namespace="osgi.ee">
+      <directive name="filter" value="(&amp;(osgi.ee=JavaSE)(version=1.7))"/>
+    </requirement>
   </resource>
   <resource>
     <capability namespace="osgi.identity">
       <attribute name="osgi.identity" value="org.apache.ace.client.automation"/>
       <attribute name="type" value="osgi.bundle"/>
-      <attribute name="version" type="Version" value="1.0.1"/>
+      <attribute name="version" type="Version" value="1.0.2"/>
     </capability>
     <capability namespace="osgi.content">
-      <attribute name="osgi.content" value="9280ec7b35c8ce863efd144b80eb01441449a661ec4603db7545f5454b7ff492"/>
-      <attribute name="url" value="org.apache.ace.client.automation/org.apache.ace.client.automation-1.0.1.jar"/>
-      <attribute name="size" type="Long" value="14616"/>
+      <attribute name="osgi.content" value="f35e66877f021ea21ca86aad4989ec78974eaa410661519c2eb373c0558e4fef"/>
+      <attribute name="url" value="org.apache.ace.client.automation/org.apache.ace.client.automation-1.0.2.jar"/>
+      <attribute name="size" type="Long" value="14658"/>
       <attribute name="mime" value="application/vnd.osgi.bundle"/>
     </capability>
     <capability namespace="osgi.wiring.bundle">
       <attribute name="osgi.wiring.bundle" value="org.apache.ace.client.automation"/>
-      <attribute name="bundle-version" type="Version" value="1.0.1"/>
+      <attribute name="bundle-version" type="Version" value="1.0.2"/>
     </capability>
     <capability namespace="osgi.wiring.host">
       <attribute name="osgi.wiring.host" value="org.apache.ace.client.automation"/>
-      <attribute name="bundle-version" type="Version" value="1.0.1"/>
+      <attribute name="bundle-version" type="Version" value="1.0.2"/>
     </capability>
     <requirement namespace="osgi.wiring.package">
       <directive name="filter" value="(&amp;(osgi.wiring.package=org.apache.ace.client.repository)(version&gt;=2.0.0)(!(version&gt;=3.0.0)))"/>
@@ -439,13 +432,13 @@
       <directive name="filter" value="(&amp;(osgi.wiring.package=org.apache.ace.client.repository.stateful)(version&gt;=1.1.0)(!(version&gt;=2.0.0)))"/>
     </requirement>
     <requirement namespace="osgi.wiring.package">
-      <directive name="filter" value="(&amp;(osgi.wiring.package=org.apache.felix.dm)(version&gt;=3.0.0)(!(version&gt;=4.0.0)))"/>
+      <directive name="filter" value="(&amp;(osgi.wiring.package=org.apache.felix.dm)(version&gt;=4.1.0)(!(version&gt;=5.0.0)))"/>
     </requirement>
     <requirement namespace="osgi.wiring.package">
-      <directive name="filter" value="(&amp;(osgi.wiring.package=org.osgi.framework)(version&gt;=1.5.0)(!(version&gt;=2.0.0)))"/>
+      <directive name="filter" value="(&amp;(osgi.wiring.package=org.osgi.framework)(version&gt;=1.8.0)(!(version&gt;=2.0.0)))"/>
     </requirement>
     <requirement namespace="osgi.wiring.package">
-      <directive name="filter" value="(&amp;(osgi.wiring.package=org.osgi.service.cm)(version&gt;=1.3.0)(!(version&gt;=2.0.0)))"/>
+      <directive name="filter" value="(&amp;(osgi.wiring.package=org.osgi.service.cm)(version&gt;=1.4.0)(!(version&gt;=2.0.0)))"/>
     </requirement>
     <requirement namespace="osgi.wiring.package">
       <directive name="filter" value="(&amp;(osgi.wiring.package=org.osgi.service.log)(version&gt;=1.3.0)(!(version&gt;=2.0.0)))"/>
@@ -453,104 +446,119 @@
     <requirement namespace="osgi.wiring.package">
       <directive name="filter" value="(&amp;(osgi.wiring.package=org.osgi.service.useradmin)(version&gt;=1.1.0)(!(version&gt;=2.0.0)))"/>
     </requirement>
+    <requirement namespace="osgi.ee">
+      <directive name="filter" value="(&amp;(osgi.ee=JavaSE)(version=1.7))"/>
+    </requirement>
   </resource>
   <resource>
     <capability namespace="osgi.identity">
       <attribute name="osgi.identity" value="org.apache.ace.client.repository.api"/>
       <attribute name="type" value="osgi.bundle"/>
-      <attribute name="version" type="Version" value="2.0.0"/>
+      <attribute name="version" type="Version" value="2.0.1"/>
     </capability>
     <capability namespace="osgi.content">
-      <attribute name="osgi.content" value="3cc06b99e19c8d3c8e141d727469acdef1e57a3651353da3f4a837fda631ce82"/>
-      <attribute name="url" value="org.apache.ace.client.repository.api/org.apache.ace.client.repository.api-2.0.0.jar"/>
-      <attribute name="size" type="Long" value="93213"/>
+      <attribute name="osgi.content" value="bf44295e389444983aa0055cc4213dfe1a8db61c5abf8d452991a716ad5c1cf2"/>
+      <attribute name="url" value="org.apache.ace.client.repository.api/org.apache.ace.client.repository.api-2.0.1.jar"/>
+      <attribute name="size" type="Long" value="93217"/>
       <attribute name="mime" value="application/vnd.osgi.bundle"/>
     </capability>
     <capability namespace="osgi.wiring.bundle">
       <attribute name="osgi.wiring.bundle" value="org.apache.ace.client.repository.api"/>
-      <attribute name="bundle-version" type="Version" value="2.0.0"/>
+      <attribute name="bundle-version" type="Version" value="2.0.1"/>
     </capability>
     <capability namespace="osgi.wiring.host">
       <attribute name="osgi.wiring.host" value="org.apache.ace.client.repository.api"/>
-      <attribute name="bundle-version" type="Version" value="2.0.0"/>
+      <attribute name="bundle-version" type="Version" value="2.0.1"/>
     </capability>
     <capability namespace="osgi.wiring.package">
       <attribute name="osgi.wiring.package" value="org.apache.ace.client.repository"/>
       <attribute name="version" type="Version" value="2.0.0"/>
       <attribute name="bundle-symbolic-name" value="org.apache.ace.client.repository.api"/>
-      <attribute name="bundle-version" type="Version" value="2.0.0"/>
+      <attribute name="bundle-version" type="Version" value="2.0.1"/>
       <directive name="uses" value="org.osgi.framework,org.osgi.service.useradmin"/>
     </capability>
     <capability namespace="osgi.wiring.package">
       <attribute name="osgi.wiring.package" value="org.apache.ace.client.repository.helper"/>
       <attribute name="version" type="Version" value="1.1.0"/>
       <attribute name="bundle-symbolic-name" value="org.apache.ace.client.repository.api"/>
-      <attribute name="bundle-version" type="Version" value="2.0.0"/>
+      <attribute name="bundle-version" type="Version" value="2.0.1"/>
       <directive name="uses" value="org.apache.ace.client.repository.object"/>
     </capability>
     <capability namespace="osgi.wiring.package">
       <attribute name="osgi.wiring.package" value="org.apache.ace.client.repository.helper.bundle"/>
       <attribute name="version" type="Version" value="1.0.0"/>
       <attribute name="bundle-symbolic-name" value="org.apache.ace.client.repository.api"/>
-      <attribute name="bundle-version" type="Version" value="2.0.0"/>
+      <attribute name="bundle-version" type="Version" value="2.0.1"/>
       <directive name="uses" value="org.apache.ace.client.repository.helper,org.apache.ace.client.repository.object"/>
     </capability>
     <capability namespace="osgi.wiring.package">
       <attribute name="osgi.wiring.package" value="org.apache.ace.client.repository.object"/>
       <attribute name="version" type="Version" value="1.1.0"/>
       <attribute name="bundle-symbolic-name" value="org.apache.ace.client.repository.api"/>
-      <attribute name="bundle-version" type="Version" value="2.0.0"/>
+      <attribute name="bundle-version" type="Version" value="2.0.1"/>
       <directive name="uses" value="org.apache.ace.client.repository"/>
     </capability>
     <capability namespace="osgi.wiring.package">
       <attribute name="osgi.wiring.package" value="org.apache.ace.client.repository.repository"/>
       <attribute name="version" type="Version" value="2.0.0"/>
       <attribute name="bundle-symbolic-name" value="org.apache.ace.client.repository.api"/>
-      <attribute name="bundle-version" type="Version" value="2.0.0"/>
+      <attribute name="bundle-version" type="Version" value="2.0.1"/>
       <directive name="uses" value="org.apache.ace.client.repository,org.apache.ace.client.repository.object"/>
     </capability>
     <capability namespace="osgi.wiring.package">
       <attribute name="osgi.wiring.package" value="org.apache.ace.client.repository.stateful"/>
       <attribute name="version" type="Version" value="1.1.0"/>
       <attribute name="bundle-symbolic-name" value="org.apache.ace.client.repository.api"/>
-      <attribute name="bundle-version" type="Version" value="2.0.0"/>
+      <attribute name="bundle-version" type="Version" value="2.0.1"/>
       <directive name="uses" value="org.apache.ace.client.repository,org.apache.ace.client.repository.object,org.apache.ace.feedback"/>
     </capability>
     <requirement namespace="osgi.wiring.package">
-      <directive name="filter" value="(&amp;(osgi.wiring.package=org.apache.ace.feedback)(version&gt;=1.0.0)(!(version&gt;=2.0.0)))"/>
+      <directive name="filter" value="(&amp;(osgi.wiring.package=org.apache.ace.client.repository)(version&gt;=2.0.0)(!(version&gt;=2.1.0)))"/>
     </requirement>
     <requirement namespace="osgi.wiring.package">
-      <directive name="filter" value="(&amp;(osgi.wiring.package=org.osgi.framework)(version&gt;=1.5.0)(!(version&gt;=2.0.0)))"/>
+      <directive name="filter" value="(&amp;(osgi.wiring.package=org.apache.ace.client.repository.helper)(version&gt;=1.1.0)(!(version&gt;=2.0.0)))"/>
+    </requirement>
+    <requirement namespace="osgi.wiring.package">
+      <directive name="filter" value="(&amp;(osgi.wiring.package=org.apache.ace.client.repository.object)(version&gt;=1.1.0)(!(version&gt;=2.0.0)))"/>
+    </requirement>
+    <requirement namespace="osgi.wiring.package">
+      <directive name="filter" value="(&amp;(osgi.wiring.package=org.apache.ace.feedback)(version&gt;=1.1.0)(!(version&gt;=2.0.0)))"/>
+    </requirement>
+    <requirement namespace="osgi.wiring.package">
+      <directive name="filter" value="(&amp;(osgi.wiring.package=org.osgi.framework)(version&gt;=1.8.0)(!(version&gt;=2.0.0)))"/>
     </requirement>
     <requirement namespace="osgi.wiring.package">
       <directive name="filter" value="(&amp;(osgi.wiring.package=org.osgi.service.useradmin)(version&gt;=1.1.0)(!(version&gt;=2.0.0)))"/>
     </requirement>
+    <requirement namespace="osgi.ee">
+      <directive name="filter" value="(&amp;(osgi.ee=JavaSE)(version=1.7))"/>
+    </requirement>
   </resource>
   <resource>
     <capability namespace="osgi.identity">
       <attribute name="osgi.identity" value="org.apache.ace.client.repository.helper.base"/>
       <attribute name="type" value="osgi.bundle"/>
-      <attribute name="version" type="Version" value="1.0.1"/>
+      <attribute name="version" type="Version" value="1.0.2"/>
     </capability>
     <capability namespace="osgi.content">
-      <attribute name="osgi.content" value="222353bac2370ee5340f1d023ede9f0546cbbb5fade889fe33a18da6783f89d0"/>
-      <attribute name="url" value="org.apache.ace.client.repository.helper.base/org.apache.ace.client.repository.helper.base-1.0.1.jar"/>
-      <attribute name="size" type="Long" value="1380759"/>
+      <attribute name="osgi.content" value="0cf45746293e4fc439527461acb5509ddd4d6af5870dd8c903d392cb13eb094b"/>
+      <attribute name="url" value="org.apache.ace.client.repository.helper.base/org.apache.ace.client.repository.helper.base-1.0.2.jar"/>
+      <attribute name="size" type="Long" value="883139"/>
       <attribute name="mime" value="application/vnd.osgi.bundle"/>
     </capability>
     <capability namespace="osgi.wiring.bundle">
       <attribute name="osgi.wiring.bundle" value="org.apache.ace.client.repository.helper.base"/>
-      <attribute name="bundle-version" type="Version" value="1.0.1"/>
+      <attribute name="bundle-version" type="Version" value="1.0.2"/>
     </capability>
     <capability namespace="osgi.wiring.host">
       <attribute name="osgi.wiring.host" value="org.apache.ace.client.repository.helper.base"/>
-      <attribute name="bundle-version" type="Version" value="1.0.1"/>
+      <attribute name="bundle-version" type="Version" value="1.0.2"/>
     </capability>
     <capability namespace="osgi.wiring.package">
       <attribute name="osgi.wiring.package" value="org.apache.ace.client.repository.helper.base"/>
       <attribute name="version" type="Version" value="1.0.0"/>
       <attribute name="bundle-symbolic-name" value="org.apache.ace.client.repository.helper.base"/>
-      <attribute name="bundle-version" type="Version" value="1.0.1"/>
+      <attribute name="bundle-version" type="Version" value="1.0.2"/>
       <directive name="uses" value="org.apache.ace.client.repository.helper,org.apache.ace.connectionfactory"/>
     </capability>
     <requirement namespace="osgi.wiring.package">
@@ -559,26 +567,29 @@
     <requirement namespace="osgi.wiring.package">
       <directive name="filter" value="(&amp;(osgi.wiring.package=org.apache.ace.connectionfactory)(version&gt;=1.0.0)(!(version&gt;=2.0.0)))"/>
     </requirement>
+    <requirement namespace="osgi.ee">
+      <directive name="filter" value="(&amp;(osgi.ee=JavaSE)(version=1.7))"/>
+    </requirement>
   </resource>
   <resource>
     <capability namespace="osgi.identity">
       <attribute name="osgi.identity" value="org.apache.ace.client.repository.helper.bundle"/>
       <attribute name="type" value="osgi.bundle"/>
-      <attribute name="version" type="Version" value="1.0.1"/>
+      <attribute name="version" type="Version" value="1.0.2"/>
     </capability>
     <capability namespace="osgi.content">
-      <attribute name="osgi.content" value="d8ba0be6d313a19f6eaf4cae2a8281acf76d670a0379d5f8e7aded27009b1d70"/>
-      <attribute name="url" value="org.apache.ace.client.repository.helper.bundle/org.apache.ace.client.repository.helper.bundle-1.0.1.jar"/>
-      <attribute name="size" type="Long" value="19637"/>
+      <attribute name="osgi.content" value="d5651f92918ac3bfe6f93fa6d0f87cb81751f76097fc2ec1d3dccc18652521c6"/>
+      <attribute name="url" value="org.apache.ace.client.repository.helper.bundle/org.apache.ace.client.repository.helper.bundle-1.0.2.jar"/>
+      <attribute name="size" type="Long" value="19607"/>
       <attribute name="mime" value="application/vnd.osgi.bundle"/>
     </capability>
     <capability namespace="osgi.wiring.bundle">
       <attribute name="osgi.wiring.bundle" value="org.apache.ace.client.repository.helper.bundle"/>
-      <attribute name="bundle-version" type="Version" value="1.0.1"/>
+      <attribute name="bundle-version" type="Version" value="1.0.2"/>
     </capability>
     <capability namespace="osgi.wiring.host">
       <attribute name="osgi.wiring.host" value="org.apache.ace.client.repository.helper.bundle"/>
-      <attribute name="bundle-version" type="Version" value="1.0.1"/>
+      <attribute name="bundle-version" type="Version" value="1.0.2"/>
     </capability>
     <requirement namespace="osgi.wiring.package">
       <directive name="filter" value="(&amp;(osgi.wiring.package=org.apache.ace.client.repository)(version&gt;=2.0.0)(!(version&gt;=3.0.0)))"/>
@@ -593,37 +604,40 @@
       <directive name="filter" value="(&amp;(osgi.wiring.package=org.apache.ace.client.repository.object)(version&gt;=1.1.0)(!(version&gt;=2.0.0)))"/>
     </requirement>
     <requirement namespace="osgi.wiring.package">
-      <directive name="filter" value="(&amp;(osgi.wiring.package=org.apache.felix.dm)(version&gt;=3.0.0)(!(version&gt;=4.0.0)))"/>
+      <directive name="filter" value="(&amp;(osgi.wiring.package=org.apache.felix.dm)(version&gt;=4.1.0)(!(version&gt;=5.0.0)))"/>
     </requirement>
     <requirement namespace="osgi.wiring.package">
-      <directive name="filter" value="(&amp;(osgi.wiring.package=org.osgi.framework)(version&gt;=1.5.0)(!(version&gt;=2.0.0)))"/>
+      <directive name="filter" value="(&amp;(osgi.wiring.package=org.osgi.framework)(version&gt;=1.8.0)(!(version&gt;=2.0.0)))"/>
+    </requirement>
+    <requirement namespace="osgi.ee">
+      <directive name="filter" value="(&amp;(osgi.ee=JavaSE)(version=1.7))"/>
     </requirement>
   </resource>
   <resource>
     <capability namespace="osgi.identity">
       <attribute name="osgi.identity" value="org.apache.ace.client.repository.helper.configuration"/>
       <attribute name="type" value="osgi.bundle"/>
-      <attribute name="version" type="Version" value="1.0.1"/>
+      <attribute name="version" type="Version" value="1.0.2"/>
     </capability>
     <capability namespace="osgi.content">
-      <attribute name="osgi.content" value="fd85bd1fe9c11c8546a4a1ee85df82f0c6b4cdb9cefbb56063975b0aa24ea36c"/>
-      <attribute name="url" value="org.apache.ace.client.repository.helper.configuration/org.apache.ace.client.repository.helper.configuration-1.0.1.jar"/>
-      <attribute name="size" type="Long" value="17289"/>
+      <attribute name="osgi.content" value="36773e6cfc33ade56d93c722e6b4b0b5769907182c0a18f890915c4238454136"/>
+      <attribute name="url" value="org.apache.ace.client.repository.helper.configuration/org.apache.ace.client.repository.helper.configuration-1.0.2.jar"/>
+      <attribute name="size" type="Long" value="17274"/>
       <attribute name="mime" value="application/vnd.osgi.bundle"/>
     </capability>
     <capability namespace="osgi.wiring.bundle">
       <attribute name="osgi.wiring.bundle" value="org.apache.ace.client.repository.helper.configuration"/>
-      <attribute name="bundle-version" type="Version" value="1.0.1"/>
+      <attribute name="bundle-version" type="Version" value="1.0.2"/>
     </capability>
     <capability namespace="osgi.wiring.host">
       <attribute name="osgi.wiring.host" value="org.apache.ace.client.repository.helper.configuration"/>
-      <attribute name="bundle-version" type="Version" value="1.0.1"/>
+      <attribute name="bundle-version" type="Version" value="1.0.2"/>
     </capability>
     <capability namespace="osgi.wiring.package">
       <attribute name="osgi.wiring.package" value="org.apache.ace.client.repository.helper.configuration"/>
       <attribute name="version" type="Version" value="1.0.0"/>
       <attribute name="bundle-symbolic-name" value="org.apache.ace.client.repository.helper.configuration"/>
-      <attribute name="bundle-version" type="Version" value="1.0.1"/>
+      <attribute name="bundle-version" type="Version" value="1.0.2"/>
       <directive name="uses" value="org.apache.ace.client.repository.helper"/>
     </capability>
     <requirement namespace="osgi.wiring.package">
@@ -645,10 +659,10 @@
       <directive name="filter" value="(&amp;(osgi.wiring.package=org.apache.ace.connectionfactory)(version&gt;=1.0.0)(!(version&gt;=2.0.0)))"/>
     </requirement>
     <requirement namespace="osgi.wiring.package">
-      <directive name="filter" value="(&amp;(osgi.wiring.package=org.apache.felix.dm)(version&gt;=3.0.0)(!(version&gt;=4.0.0)))"/>
+      <directive name="filter" value="(&amp;(osgi.wiring.package=org.apache.felix.dm)(version&gt;=4.1.0)(!(version&gt;=5.0.0)))"/>
     </requirement>
     <requirement namespace="osgi.wiring.package">
-      <directive name="filter" value="(&amp;(osgi.wiring.package=org.osgi.framework)(version&gt;=1.5.0)(!(version&gt;=2.0.0)))"/>
+      <directive name="filter" value="(&amp;(osgi.wiring.package=org.osgi.framework)(version&gt;=1.8.0)(!(version&gt;=2.0.0)))"/>
     </requirement>
     <requirement namespace="osgi.wiring.package">
       <directive name="filter" value="(&amp;(osgi.wiring.package=org.osgi.service.log)(version&gt;=1.3.0)(!(version&gt;=2.0.0)))"/>
@@ -659,32 +673,35 @@
     <requirement namespace="osgi.wiring.package">
       <directive name="filter" value="(osgi.wiring.package=org.xml.sax.helpers)"/>
     </requirement>
+    <requirement namespace="osgi.ee">
+      <directive name="filter" value="(&amp;(osgi.ee=JavaSE)(version=1.7))"/>
+    </requirement>
   </resource>
   <resource>
     <capability namespace="osgi.identity">
       <attribute name="osgi.identity" value="org.apache.ace.client.repository.helper.user"/>
       <attribute name="type" value="osgi.bundle"/>
-      <attribute name="version" type="Version" value="1.0.1"/>
+      <attribute name="version" type="Version" value="1.0.2"/>
     </capability>
     <capability namespace="osgi.content">
-      <attribute name="osgi.content" value="5db2f64562e056e0ef46741aa3c5170a3679d8f73326c442b42581e8df4ed46f"/>
-      <attribute name="url" value="org.apache.ace.client.repository.helper.user/org.apache.ace.client.repository.helper.user-1.0.1.jar"/>
-      <attribute name="size" type="Long" value="16709"/>
+      <attribute name="osgi.content" value="a7522cedb019fe34683205369bc5449dbd77feb99b7dcc069e7c7f26462b5bfe"/>
+      <attribute name="url" value="org.apache.ace.client.repository.helper.user/org.apache.ace.client.repository.helper.user-1.0.2.jar"/>
+      <attribute name="size" type="Long" value="16694"/>
       <attribute name="mime" value="application/vnd.osgi.bundle"/>
     </capability>
     <capability namespace="osgi.wiring.bundle">
       <attribute name="osgi.wiring.bundle" value="org.apache.ace.client.repository.helper.user"/>
-      <attribute name="bundle-version" type="Version" value="1.0.1"/>
+      <attribute name="bundle-version" type="Version" value="1.0.2"/>
     </capability>
     <capability namespace="osgi.wiring.host">
       <attribute name="osgi.wiring.host" value="org.apache.ace.client.repository.helper.user"/>
-      <attribute name="bundle-version" type="Version" value="1.0.1"/>
+      <attribute name="bundle-version" type="Version" value="1.0.2"/>
     </capability>
     <capability namespace="osgi.wiring.package">
       <attribute name="osgi.wiring.package" value="org.apache.ace.client.repository.helper.user"/>
       <attribute name="version" type="Version" value="1.0.0"/>
       <attribute name="bundle-symbolic-name" value="org.apache.ace.client.repository.helper.user"/>
-      <attribute name="bundle-version" type="Version" value="1.0.1"/>
+      <attribute name="bundle-version" type="Version" value="1.0.2"/>
       <directive name="uses" value="org.apache.ace.client.repository.helper"/>
     </capability>
     <requirement namespace="osgi.wiring.package">
@@ -706,10 +723,10 @@
       <directive name="filter" value="(&amp;(osgi.wiring.package=org.apache.ace.connectionfactory)(version&gt;=1.0.0)(!(version&gt;=2.0.0)))"/>
     </requirement>
     <requirement namespace="osgi.wiring.package">
-      <directive name="filter" value="(&amp;(osgi.wiring.package=org.apache.felix.dm)(version&gt;=3.0.0)(!(version&gt;=4.0.0)))"/>
+      <directive name="filter" value="(&amp;(osgi.wiring.package=org.apache.felix.dm)(version&gt;=4.1.0)(!(version&gt;=5.0.0)))"/>
     </requirement>
     <requirement namespace="osgi.wiring.package">
-      <directive name="filter" value="(&amp;(osgi.wiring.package=org.osgi.framework)(version&gt;=1.5.0)(!(version&gt;=2.0.0)))"/>
+      <directive name="filter" value="(&amp;(osgi.wiring.package=org.osgi.framework)(version&gt;=1.8.0)(!(version&gt;=2.0.0)))"/>
     </requirement>
     <requirement namespace="osgi.wiring.package">
       <directive name="filter" value="(&amp;(osgi.wiring.package=org.osgi.service.log)(version&gt;=1.3.0)(!(version&gt;=2.0.0)))"/>
@@ -720,26 +737,29 @@
     <requirement namespace="osgi.wiring.package">
       <directive name="filter" value="(osgi.wiring.package=org.xml.sax.helpers)"/>
     </requirement>
+    <requirement namespace="osgi.ee">
+      <directive name="filter" value="(&amp;(osgi.ee=JavaSE)(version=1.7))"/>
+    </requirement>
   </resource>
   <resource>
     <capability namespace="osgi.identity">
       <attribute name="osgi.identity" value="org.apache.ace.client.repository.impl"/>
       <attribute name="type" value="osgi.bundle"/>
-      <attribute name="version" type="Version" value="1.0.1"/>
+      <attribute name="version" type="Version" value="1.0.2"/>
     </capability>
     <capability namespace="osgi.content">
-      <attribute name="osgi.content" value="007ef8566bd649062b58e7a239a846ba6519219101e118ef4a9ac8932e48561f"/>
-      <attribute name="url" value="org.apache.ace.client.repository.impl/org.apache.ace.client.repository.impl-1.0.1.jar"/>
-      <attribute name="size" type="Long" value="730724"/>
+      <attribute name="osgi.content" value="641ea48396e793ae4b56071140928d3cd615c4cea21e23b6683a368529443c17"/>
+      <attribute name="url" value="org.apache.ace.client.repository.impl/org.apache.ace.client.repository.impl-1.0.2.jar"/>
+      <attribute name="size" type="Long" value="731383"/>
       <attribute name="mime" value="application/vnd.osgi.bundle"/>
     </capability>
     <capability namespace="osgi.wiring.bundle">
       <attribute name="osgi.wiring.bundle" value="org.apache.ace.client.repository.impl"/>
-      <attribute name="bundle-version" type="Version" value="1.0.1"/>
+      <attribute name="bundle-version" type="Version" value="1.0.2"/>
     </capability>
     <capability namespace="osgi.wiring.host">
       <attribute name="osgi.wiring.host" value="org.apache.ace.client.repository.impl"/>
-      <attribute name="bundle-version" type="Version" value="1.0.1"/>
+      <attribute name="bundle-version" type="Version" value="1.0.2"/>
     </capability>
     <requirement namespace="osgi.wiring.package">
       <directive name="filter" value="(&amp;(osgi.wiring.package=org.apache.ace.client.repository)(version&gt;=2.0.0)(!(version&gt;=2.1.0)))"/>
@@ -763,10 +783,10 @@
       <directive name="filter" value="(&amp;(osgi.wiring.package=org.apache.ace.connectionfactory)(version&gt;=1.0.0)(!(version&gt;=2.0.0)))"/>
     </requirement>
     <requirement namespace="osgi.wiring.package">
-      <directive name="filter" value="(&amp;(osgi.wiring.package=org.apache.ace.feedback)(version&gt;=1.0.0)(!(version&gt;=2.0.0)))"/>
+      <directive name="filter" value="(&amp;(osgi.wiring.package=org.apache.ace.feedback)(version&gt;=1.1.0)(!(version&gt;=2.0.0)))"/>
     </requirement>
     <requirement namespace="osgi.wiring.package">
-      <directive name="filter" value="(&amp;(osgi.wiring.package=org.apache.ace.log.server.store)(version&gt;=2.0.0)(!(version&gt;=3.0.0)))"/>
+      <directive name="filter" value="(&amp;(osgi.wiring.package=org.apache.ace.log.server.store)(version&gt;=2.1.0)(!(version&gt;=3.0.0)))"/>
     </requirement>
     <requirement namespace="osgi.wiring.package">
       <directive name="filter" value="(&amp;(osgi.wiring.package=org.apache.ace.range)(version&gt;=1.1.0)(!(version&gt;=2.0.0)))"/>
@@ -775,16 +795,16 @@
       <directive name="filter" value="(&amp;(osgi.wiring.package=org.apache.ace.repository)(version&gt;=1.1.0)(!(version&gt;=1.2.0)))"/>
     </requirement>
     <requirement namespace="osgi.wiring.package">
-      <directive name="filter" value="(&amp;(osgi.wiring.package=org.apache.felix.dm)(version&gt;=3.0.0)(!(version&gt;=4.0.0)))"/>
+      <directive name="filter" value="(&amp;(osgi.wiring.package=org.apache.felix.dm)(version&gt;=4.1.0)(!(version&gt;=5.0.0)))"/>
     </requirement>
     <requirement namespace="osgi.wiring.package">
-      <directive name="filter" value="(&amp;(osgi.wiring.package=org.osgi.framework)(version&gt;=1.5.0)(!(version&gt;=2.0.0)))"/>
+      <directive name="filter" value="(&amp;(osgi.wiring.package=org.osgi.framework)(version&gt;=1.8.0)(!(version&gt;=2.0.0)))"/>
     </requirement>
     <requirement namespace="osgi.wiring.package">
-      <directive name="filter" value="(&amp;(osgi.wiring.package=org.osgi.service.cm)(version&gt;=1.3.0)(!(version&gt;=2.0.0)))"/>
+      <directive name="filter" value="(&amp;(osgi.wiring.package=org.osgi.service.cm)(version&gt;=1.4.0)(!(version&gt;=2.0.0)))"/>
     </requirement>
     <requirement namespace="osgi.wiring.package">
-      <directive name="filter" value="(&amp;(osgi.wiring.package=org.osgi.service.event)(version&gt;=1.2.0)(!(version&gt;=2.0.0)))"/>
+      <directive name="filter" value="(&amp;(osgi.wiring.package=org.osgi.service.event)(version&gt;=1.3.0)(!(version&gt;=2.0.0)))"/>
     </requirement>
     <requirement namespace="osgi.wiring.package">
       <directive name="filter" value="(&amp;(osgi.wiring.package=org.osgi.service.log)(version&gt;=1.3.0)(!(version&gt;=2.0.0)))"/>
@@ -795,32 +815,35 @@
     <requirement namespace="osgi.wiring.package">
       <directive name="filter" value="(&amp;(osgi.wiring.package=org.osgi.service.useradmin)(version&gt;=1.1.0)(!(version&gt;=2.0.0)))"/>
     </requirement>
+    <requirement namespace="osgi.ee">
+      <directive name="filter" value="(&amp;(osgi.ee=JavaSE)(version=1.7))"/>
+    </requirement>
   </resource>
   <resource>
     <capability namespace="osgi.identity">
       <attribute name="osgi.identity" value="org.apache.ace.client.rest"/>
       <attribute name="type" value="osgi.bundle"/>
-      <attribute name="version" type="Version" value="1.0.1"/>
+      <attribute name="version" type="Version" value="1.0.2"/>
     </capability>
     <capability namespace="osgi.content">
-      <attribute name="osgi.content" value="55e2ef2271fd6fd3a413dabb17181f751ad064d93e6e9672219bc0f1c093005c"/>
-      <attribute name="url" value="org.apache.ace.client.rest/org.apache.ace.client.rest-1.0.1.jar"/>
-      <attribute name="size" type="Long" value="205458"/>
+      <attribute name="osgi.content" value="4ba50e2473bdf4d49551b202ba94da37e0ade28d74c5dda6bb11ba98d77fc33a"/>
+      <attribute name="url" value="org.apache.ace.client.rest/org.apache.ace.client.rest-1.0.2.jar"/>
+      <attribute name="size" type="Long" value="219907"/>
       <attribute name="mime" value="application/vnd.osgi.bundle"/>
     </capability>
     <capability namespace="osgi.wiring.bundle">
       <attribute name="osgi.wiring.bundle" value="org.apache.ace.client.rest"/>
-      <attribute name="bundle-version" type="Version" value="1.0.1"/>
+      <attribute name="bundle-version" type="Version" value="1.0.2"/>
     </capability>
     <capability namespace="osgi.wiring.host">
       <attribute name="osgi.wiring.host" value="org.apache.ace.client.rest"/>
-      <attribute name="bundle-version" type="Version" value="1.0.1"/>
+      <attribute name="bundle-version" type="Version" value="1.0.2"/>
     </capability>
     <requirement namespace="osgi.wiring.package">
-      <directive name="filter" value="(&amp;(osgi.wiring.package=javax.servlet)(version&gt;=2.5.0)(!(version&gt;=3.0.0)))"/>
+      <directive name="filter" value="(&amp;(osgi.wiring.package=javax.servlet)(version&gt;=2.6.0)(!(version&gt;=3.0.0)))"/>
     </requirement>
     <requirement namespace="osgi.wiring.package">
-      <directive name="filter" value="(&amp;(osgi.wiring.package=javax.servlet.http)(version&gt;=2.5.0)(!(version&gt;=3.0.0)))"/>
+      <directive name="filter" value="(&amp;(osgi.wiring.package=javax.servlet.http)(version&gt;=2.6.0)(!(version&gt;=3.0.0)))"/>
     </requirement>
     <requirement namespace="osgi.wiring.package">
       <directive name="filter" value="(&amp;(osgi.wiring.package=org.apache.ace.client.repository)(version&gt;=2.0.0)(!(version&gt;=3.0.0)))"/>
@@ -832,49 +855,52 @@
       <directive name="filter" value="(&amp;(osgi.wiring.package=org.apache.ace.client.repository.stateful)(version&gt;=1.1.0)(!(version&gt;=2.0.0)))"/>
     </requirement>
     <requirement namespace="osgi.wiring.package">
-      <directive name="filter" value="(&amp;(osgi.wiring.package=org.apache.ace.client.workspace)(version&gt;=1.0.0)(!(version&gt;=2.0.0)))"/>
+      <directive name="filter" value="(&amp;(osgi.wiring.package=org.apache.ace.client.workspace)(version&gt;=2.0.0)(!(version&gt;=3.0.0)))"/>
     </requirement>
     <requirement namespace="osgi.wiring.package">
-      <directive name="filter" value="(&amp;(osgi.wiring.package=org.apache.ace.feedback)(version&gt;=1.0.0)(!(version&gt;=2.0.0)))"/>
+      <directive name="filter" value="(&amp;(osgi.wiring.package=org.apache.ace.feedback)(version&gt;=1.1.0)(!(version&gt;=2.0.0)))"/>
     </requirement>
     <requirement namespace="osgi.wiring.package">
-      <directive name="filter" value="(&amp;(osgi.wiring.package=org.apache.felix.dm)(version&gt;=3.0.0)(!(version&gt;=4.0.0)))"/>
+      <directive name="filter" value="(&amp;(osgi.wiring.package=org.apache.felix.dm)(version&gt;=4.1.0)(!(version&gt;=5.0.0)))"/>
     </requirement>
     <requirement namespace="osgi.wiring.package">
-      <directive name="filter" value="(&amp;(osgi.wiring.package=org.osgi.framework)(version&gt;=1.5.0)(!(version&gt;=2.0.0)))"/>
+      <directive name="filter" value="(&amp;(osgi.wiring.package=org.osgi.framework)(version&gt;=1.8.0)(!(version&gt;=2.0.0)))"/>
     </requirement>
     <requirement namespace="osgi.wiring.package">
-      <directive name="filter" value="(&amp;(osgi.wiring.package=org.osgi.service.cm)(version&gt;=1.3.0)(!(version&gt;=2.0.0)))"/>
+      <directive name="filter" value="(&amp;(osgi.wiring.package=org.osgi.service.cm)(version&gt;=1.4.0)(!(version&gt;=2.0.0)))"/>
     </requirement>
     <requirement namespace="osgi.wiring.package">
       <directive name="filter" value="(&amp;(osgi.wiring.package=org.osgi.service.log)(version&gt;=1.3.0)(!(version&gt;=2.0.0)))"/>
     </requirement>
+    <requirement namespace="osgi.ee">
+      <directive name="filter" value="(&amp;(osgi.ee=JavaSE)(version=1.7))"/>
+    </requirement>
   </resource>
   <resource>
     <capability namespace="osgi.identity">
       <attribute name="osgi.identity" value="org.apache.ace.client.workspace"/>
       <attribute name="type" value="osgi.bundle"/>
-      <attribute name="version" type="Version" value="1.0.0"/>
+      <attribute name="version" type="Version" value="2.0.0"/>
     </capability>
     <capability namespace="osgi.content">
-      <attribute name="osgi.content" value="7f295eaecb44876811a7b4911891629ec4eac90e963e44e3bfab8802cd8495ff"/>
-      <attribute name="url" value="org.apache.ace.client.workspace/org.apache.ace.client.workspace-1.0.0.jar"/>
-      <attribute name="size" type="Long" value="33605"/>
+      <attribute name="osgi.content" value="573c06d62f1892b3285870985e11a5519c206453a9467cf733fdfb4a940bf2a4"/>
+      <attribute name="url" value="org.apache.ace.client.workspace/org.apache.ace.client.workspace-2.0.0.jar"/>
+      <attribute name="size" type="Long" value="44571"/>
       <attribute name="mime" value="application/vnd.osgi.bundle"/>
     </capability>
     <capability namespace="osgi.wiring.bundle">
       <attribute name="osgi.wiring.bundle" value="org.apache.ace.client.workspace"/>
-      <attribute name="bundle-version" type="Version" value="1.0.0"/>
+      <attribute name="bundle-version" type="Version" value="2.0.0"/>
     </capability>
     <capability namespace="osgi.wiring.host">
       <attribute name="osgi.wiring.host" value="org.apache.ace.client.workspace"/>
-      <attribute name="bundle-version" type="Version" value="1.0.0"/>
+      <attribute name="bundle-version" type="Version" value="2.0.0"/>
     </capability>
     <capability namespace="osgi.wiring.package">
       <attribute name="osgi.wiring.package" value="org.apache.ace.client.workspace"/>
-      <attribute name="version" type="Version" value="1.0.0"/>
+      <attribute name="version" type="Version" value="2.0.0"/>
       <attribute name="bundle-symbolic-name" value="org.apache.ace.client.workspace"/>
-      <attribute name="bundle-version" type="Version" value="1.0.0"/>
+      <attribute name="bundle-version" type="Version" value="2.0.0"/>
       <directive name="uses" value="org.apache.ace.client.repository,org.apache.ace.client.repository.object,org.apache.ace.client.repository.stateful,org.osgi.service.useradmin"/>
     </capability>
     <requirement namespace="osgi.wiring.package">
@@ -893,16 +919,16 @@
       <directive name="filter" value="(&amp;(osgi.wiring.package=org.apache.ace.client.repository.stateful)(version&gt;=1.1.0)(!(version&gt;=2.0.0)))"/>
     </requirement>
     <requirement namespace="osgi.wiring.package">
-      <directive name="filter" value="(&amp;(osgi.wiring.package=org.apache.ace.client.workspace)(version&gt;=1.0.0)(!(version&gt;=2.0.0)))"/>
+      <directive name="filter" value="(&amp;(osgi.wiring.package=org.apache.ace.client.workspace)(version&gt;=2.0.0)(!(version&gt;=3.0.0)))"/>
     </requirement>
     <requirement namespace="osgi.wiring.package">
-      <directive name="filter" value="(&amp;(osgi.wiring.package=org.apache.felix.dm)(version&gt;=3.0.0)(!(version&gt;=4.0.0)))"/>
+      <directive name="filter" value="(&amp;(osgi.wiring.package=org.apache.felix.dm)(version&gt;=4.1.0)(!(version&gt;=5.0.0)))"/>
     </requirement>
     <requirement namespace="osgi.wiring.package">
-      <directive name="filter" value="(&amp;(osgi.wiring.package=org.osgi.framework)(version&gt;=1.5.0)(!(version&gt;=2.0.0)))"/>
+      <directive name="filter" value="(&amp;(osgi.wiring.package=org.osgi.framework)(version&gt;=1.8.0)(!(version&gt;=2.0.0)))"/>
     </requirement>
     <requirement namespace="osgi.wiring.package">
-      <directive name="filter" value="(&amp;(osgi.wiring.package=org.osgi.service.cm)(version&gt;=1.3.0)(!(version&gt;=2.0.0)))"/>
+      <directive name="filter" value="(&amp;(osgi.wiring.package=org.osgi.service.cm)(version&gt;=1.4.0)(!(version&gt;=2.0.0)))"/>
     </requirement>
     <requirement namespace="osgi.wiring.package">
       <directive name="filter" value="(&amp;(osgi.wiring.package=org.osgi.service.log)(version&gt;=1.3.0)(!(version&gt;=2.0.0)))"/>
@@ -910,59 +936,65 @@
     <requirement namespace="osgi.wiring.package">
       <directive name="filter" value="(&amp;(osgi.wiring.package=org.osgi.service.useradmin)(version&gt;=1.1.0)(!(version&gt;=2.0.0)))"/>
     </requirement>
+    <requirement namespace="osgi.ee">
+      <directive name="filter" value="(&amp;(osgi.ee=JavaSE)(version=1.7))"/>
+    </requirement>
   </resource>
   <resource>
     <capability namespace="osgi.identity">
       <attribute name="osgi.identity" value="org.apache.ace.configurator.impl"/>
       <attribute name="type" value="osgi.bundle"/>
-      <attribute name="version" type="Version" value="1.0.1"/>
+      <attribute name="version" type="Version" value="1.0.2"/>
     </capability>
     <capability namespace="osgi.content">
-      <attribute name="osgi.content" value="9a8a89b879b8075a8744e8546884892a444c77d4670ccdb1fb226ef217450ee3"/>
-      <attribute name="url" value="org.apache.ace.configurator.impl/org.apache.ace.configurator.impl-1.0.1.jar"/>
-      <attribute name="size" type="Long" value="15765"/>
+      <attribute name="osgi.content" value="d8b2b6b4265a2ed80cda215aac1285376d5c9cec29f3dbdc075bc4f5abb035fa"/>
+      <attribute name="url" value="org.apache.ace.configurator.impl/org.apache.ace.configurator.impl-1.0.2.jar"/>
+      <attribute name="size" type="Long" value="15833"/>
       <attribute name="mime" value="application/vnd.osgi.bundle"/>
     </capability>
     <capability namespace="osgi.wiring.bundle">
       <attribute name="osgi.wiring.bundle" value="org.apache.ace.configurator.impl"/>
-      <attribute name="bundle-version" type="Version" value="1.0.1"/>
+      <attribute name="bundle-version" type="Version" value="1.0.2"/>
     </capability>
     <capability namespace="osgi.wiring.host">
       <attribute name="osgi.wiring.host" value="org.apache.ace.configurator.impl"/>
-      <attribute name="bundle-version" type="Version" value="1.0.1"/>
+      <attribute name="bundle-version" type="Version" value="1.0.2"/>
     </capability>
     <requirement namespace="osgi.wiring.package">
-      <directive name="filter" value="(&amp;(osgi.wiring.package=org.apache.felix.dm)(version&gt;=3.0.0)(!(version&gt;=4.0.0)))"/>
+      <directive name="filter" value="(&amp;(osgi.wiring.package=org.apache.felix.dm)(version&gt;=4.1.0)(!(version&gt;=5.0.0)))"/>
     </requirement>
     <requirement namespace="osgi.wiring.package">
-      <directive name="filter" value="(&amp;(osgi.wiring.package=org.osgi.framework)(version&gt;=1.5.0)(!(version&gt;=2.0.0)))"/>
+      <directive name="filter" value="(&amp;(osgi.wiring.package=org.osgi.framework)(version&gt;=1.8.0)(!(version&gt;=2.0.0)))"/>
     </requirement>
     <requirement namespace="osgi.wiring.package">
-      <directive name="filter" value="(&amp;(osgi.wiring.package=org.osgi.service.cm)(version&gt;=1.3.0)(!(version&gt;=2.0.0)))"/>
+      <directive name="filter" value="(&amp;(osgi.wiring.package=org.osgi.service.cm)(version&gt;=1.4.0)(!(version&gt;=2.0.0)))"/>
     </requirement>
     <requirement namespace="osgi.wiring.package">
       <directive name="filter" value="(&amp;(osgi.wiring.package=org.osgi.service.log)(version&gt;=1.3.0)(!(version&gt;=2.0.0)))"/>
     </requirement>
+    <requirement namespace="osgi.ee">
+      <directive name="filter" value="(&amp;(osgi.ee=JavaSE)(version=1.7))"/>
+    </requirement>
   </resource>
   <resource>
     <capability namespace="osgi.identity">
       <attribute name="osgi.identity" value="org.apache.ace.configurator.useradmin.task"/>
       <attribute name="type" value="osgi.bundle"/>
-      <attribute name="version" type="Version" value="1.0.1"/>
+      <attribute name="version" type="Version" value="1.0.2"/>
     </capability>
     <capability namespace="osgi.content">
-      <attribute name="osgi.content" value="debde6f49336855a8e26e248897b2c0da5f76fb3ada96a3e88fe08e3ca25439a"/>
-      <attribute name="url" value="org.apache.ace.configurator.useradmin.task/org.apache.ace.configurator.useradmin.task-1.0.1.jar"/>
-      <attribute name="size" type="Long" value="31554"/>
+      <attribute name="osgi.content" value="cb22c79e0cff6d63ad43005ae8f78f61baa1e55bad85af66c4f9bb23599b6dee"/>
+      <attribute name="url" value="org.apache.ace.configurator.useradmin.task/org.apache.ace.configurator.useradmin.task-1.0.2.jar"/>
+      <attribute name="size" type="Long" value="31589"/>
       <attribute name="mime" value="application/vnd.osgi.bundle"/>
     </capability>
     <capability namespace="osgi.wiring.bundle">
       <attribute name="osgi.wiring.bundle" value="org.apache.ace.configurator.useradmin.task"/>
-      <attribute name="bundle-version" type="Version" value="1.0.1"/>
+      <attribute name="bundle-version" type="Version" value="1.0.2"/>
     </capability>
     <capability namespace="osgi.wiring.host">
       <attribute name="osgi.wiring.host" value="org.apache.ace.configurator.useradmin.task"/>
-      <attribute name="bundle-version" type="Version" value="1.0.1"/>
+      <attribute name="bundle-version" type="Version" value="1.0.2"/>
     </capability>
     <requirement namespace="osgi.wiring.package">
       <directive name="filter" value="(osgi.wiring.package=org.apache.ace.connectionfactory)"/>
@@ -977,43 +1009,46 @@
       <directive name="filter" value="(&amp;(osgi.wiring.package=org.apache.ace.resourceprocessor.useradmin)(version&gt;=2.0.0)(!(version&gt;=3.0.0)))"/>
     </requirement>
     <requirement namespace="osgi.wiring.package">
-      <directive name="filter" value="(&amp;(osgi.wiring.package=org.apache.felix.dm)(version&gt;=3.0.0)(!(version&gt;=4.0.0)))"/>
+      <directive name="filter" value="(&amp;(osgi.wiring.package=org.apache.felix.dm)(version&gt;=4.1.0)(!(version&gt;=5.0.0)))"/>
     </requirement>
     <requirement namespace="osgi.wiring.package">
-      <directive name="filter" value="(&amp;(osgi.wiring.package=org.osgi.framework)(version&gt;=1.5.0)(!(version&gt;=2.0.0)))"/>
+      <directive name="filter" value="(&amp;(osgi.wiring.package=org.osgi.framework)(version&gt;=1.8.0)(!(version&gt;=2.0.0)))"/>
     </requirement>
     <requirement namespace="osgi.wiring.package">
-      <directive name="filter" value="(&amp;(osgi.wiring.package=org.osgi.service.cm)(version&gt;=1.3.0)(!(version&gt;=2.0.0)))"/>
+      <directive name="filter" value="(&amp;(osgi.wiring.package=org.osgi.service.cm)(version&gt;=1.4.0)(!(version&gt;=2.0.0)))"/>
     </requirement>
     <requirement namespace="osgi.wiring.package">
       <directive name="filter" value="(&amp;(osgi.wiring.package=org.osgi.service.log)(version&gt;=1.3.0)(!(version&gt;=2.0.0)))"/>
     </requirement>
+    <requirement namespace="osgi.ee">
+      <directive name="filter" value="(&amp;(osgi.ee=JavaSE)(version=1.7))"/>
+    </requirement>
   </resource>
   <resource>
     <capability namespace="osgi.identity">
       <attribute name="osgi.identity" value="org.apache.ace.connectionfactory"/>
       <attribute name="type" value="osgi.bundle"/>
-      <attribute name="version" type="Version" value="1.0.0"/>
+      <attribute name="version" type="Version" value="1.0.1"/>
     </capability>
     <capability namespace="osgi.content">
-      <attribute name="osgi.content" value="7180ee0fa6f01cc32d80d3bba3a734a6d701e195469fcdac81fe7309f67fa4de"/>
-      <attribute name="url" value="org.apache.ace.connectionfactory/org.apache.ace.connectionfactory-1.0.0.jar"/>
-      <attribute name="size" type="Long" value="41576"/>
+      <attribute name="osgi.content" value="a5431df7c3653be4b5b809a71962ad53e6e87117c831143eefa5037009802e4d"/>
+      <attribute name="url" value="org.apache.ace.connectionfactory/org.apache.ace.connectionfactory-1.0.1.jar"/>
+      <attribute name="size" type="Long" value="41740"/>
       <attribute name="mime" value="application/vnd.osgi.bundle"/>
     </capability>
     <capability namespace="osgi.wiring.bundle">
       <attribute name="osgi.wiring.bundle" value="org.apache.ace.connectionfactory"/>
-      <attribute name="bundle-version" type="Version" value="1.0.0"/>
+      <attribute name="bundle-version" type="Version" value="1.0.1"/>
     </capability>
     <capability namespace="osgi.wiring.host">
       <attribute name="osgi.wiring.host" value="org.apache.ace.connectionfactory"/>
-      <attribute name="bundle-version" type="Version" value="1.0.0"/>
+      <attribute name="bundle-version" type="Version" value="1.0.1"/>
     </capability>
     <capability namespace="osgi.wiring.package">
       <attribute name="osgi.wiring.package" value="org.apache.ace.connectionfactory"/>
       <attribute name="version" type="Version" value="1.0.0"/>
       <attribute name="bundle-symbolic-name" value="org.apache.ace.connectionfactory"/>
-      <attribute name="bundle-version" type="Version" value="1.0.0"/>
+      <attribute name="bundle-version" type="Version" value="1.0.1"/>
       <directive name="uses" value="org.osgi.service.useradmin"/>
     </capability>
     <requirement namespace="osgi.wiring.package">
@@ -1023,104 +1058,113 @@
       <directive name="filter" value="(&amp;(osgi.wiring.package=org.apache.ace.connectionfactory)(version&gt;=1.0.0)(!(version&gt;=1.1.0)))"/>
     </requirement>
     <requirement namespace="osgi.wiring.package">
-      <directive name="filter" value="(&amp;(osgi.wiring.package=org.osgi.framework)(version&gt;=1.5.0)(!(version&gt;=2.0.0)))"/>
+      <directive name="filter" value="(&amp;(osgi.wiring.package=org.osgi.framework)(version&gt;=1.8.0)(!(version&gt;=2.0.0)))"/>
     </requirement>
     <requirement namespace="osgi.wiring.package">
-      <directive name="filter" value="(&amp;(osgi.wiring.package=org.osgi.service.cm)(version&gt;=1.3.0)(!(version&gt;=2.0.0)))"/>
+      <directive name="filter" value="(&amp;(osgi.wiring.package=org.osgi.service.cm)(version&gt;=1.4.0)(!(version&gt;=2.0.0)))"/>
     </requirement>
     <requirement namespace="osgi.wiring.package">
       <directive name="filter" value="(&amp;(osgi.wiring.package=org.osgi.service.useradmin)(version&gt;=1.1.0)(!(version&gt;=2.0.0)))"/>
     </requirement>
+    <requirement namespace="osgi.ee">
+      <directive name="filter" value="(&amp;(osgi.ee=JavaSE)(version=1.7))"/>
+    </requirement>
   </resource>
   <resource>
     <capability namespace="osgi.identity">
       <attribute name="osgi.identity" value="org.apache.ace.consolelogger"/>
       <attribute name="type" value="osgi.bundle"/>
-      <attribute name="version" type="Version" value="1.0.1"/>
+      <attribute name="version" type="Version" value="1.0.2"/>
     </capability>
     <capability namespace="osgi.content">
-      <attribute name="osgi.content" value="eab0046adaba80f7ad3c76e7565e1a98f436fbd2f69320ac4f2fef67999c350e"/>
-      <attribute name="url" value="org.apache.ace.consolelogger/org.apache.ace.consolelogger-1.0.1.jar"/>
-      <attribute name="size" type="Long" value="6525"/>
+      <attribute name="osgi.content" value="1723eef854ad300f8aaa73bf2d58c7ed29b3335f77fe10481eff9bd854c7cbf2"/>
+      <attribute name="url" value="org.apache.ace.consolelogger/org.apache.ace.consolelogger-1.0.2.jar"/>
+      <attribute name="size" type="Long" value="6494"/>
       <attribute name="mime" value="application/vnd.osgi.bundle"/>
     </capability>
     <capability namespace="osgi.wiring.bundle">
       <attribute name="osgi.wiring.bundle" value="org.apache.ace.consolelogger"/>
-      <attribute name="bundle-version" type="Version" value="1.0.1"/>
+      <attribute name="bundle-version" type="Version" value="1.0.2"/>
     </capability>
     <capability namespace="osgi.wiring.host">
       <attribute name="osgi.wiring.host" value="org.apache.ace.consolelogger"/>
-      <attribute name="bundle-version" type="Version" value="1.0.1"/>
+      <attribute name="bundle-version" type="Version" value="1.0.2"/>
     </capability>
     <requirement namespace="osgi.wiring.package">
-      <directive name="filter" value="(&amp;(osgi.wiring.package=org.apache.felix.dm)(version&gt;=3.0.0)(!(version&gt;=4.0.0)))"/>
+      <directive name="filter" value="(&amp;(osgi.wiring.package=org.apache.felix.dm)(version&gt;=4.1.0)(!(version&gt;=5.0.0)))"/>
     </requirement>
     <requirement namespace="osgi.wiring.package">
-      <directive name="filter" value="(&amp;(osgi.wiring.package=org.osgi.framework)(version&gt;=1.5.0)(!(version&gt;=2.0.0)))"/>
+      <directive name="filter" value="(&amp;(osgi.wiring.package=org.osgi.framework)(version&gt;=1.8.0)(!(version&gt;=2.0.0)))"/>
     </requirement>
     <requirement namespace="osgi.wiring.package">
       <directive name="filter" value="(&amp;(osgi.wiring.package=org.osgi.service.log)(version&gt;=1.3.0)(!(version&gt;=2.0.0)))"/>
     </requirement>
+    <requirement namespace="osgi.ee">
+      <directive name="filter" value="(&amp;(osgi.ee=JavaSE)(version=1.7))"/>
+    </requirement>
   </resource>
   <resource>
     <capability namespace="osgi.identity">
       <attribute name="osgi.identity" value="org.apache.ace.deployment.api"/>
       <attribute name="type" value="osgi.bundle"/>
-      <attribute name="version" type="Version" value="1.0.0"/>
+      <attribute name="version" type="Version" value="1.0.1"/>
     </capability>
     <capability namespace="osgi.content">
-      <attribute name="osgi.content" value="d63c1c17020a6a6fb26d00635d0d5b15f771bd649cc9eb1de81d469ed39154d3"/>
-      <attribute name="url" value="org.apache.ace.deployment.api/org.apache.ace.deployment.api-1.0.0.jar"/>
-      <attribute name="size" type="Long" value="4024"/>
+      <attribute name="osgi.content" value="97804847cdb0aaefc8b5950c0e78e0ff35634642acea83c1abd3ca512b4f4e36"/>
+      <attribute name="url" value="org.apache.ace.deployment.api/org.apache.ace.deployment.api-1.0.1.jar"/>
+      <attribute name="size" type="Long" value="4004"/>
       <attribute name="mime" value="application/vnd.osgi.bundle"/>
     </capability>
     <capability namespace="osgi.wiring.bundle">
       <attribute name="osgi.wiring.bundle" value="org.apache.ace.deployment.api"/>
-      <attribute name="bundle-version" type="Version" value="1.0.0"/>
+      <attribute name="bundle-version" type="Version" value="1.0.1"/>
     </capability>
     <capability namespace="osgi.wiring.host">
       <attribute name="osgi.wiring.host" value="org.apache.ace.deployment.api"/>
-      <attribute name="bundle-version" type="Version" value="1.0.0"/>
+      <attribute name="bundle-version" type="Version" value="1.0.1"/>
     </capability>
     <capability namespace="osgi.wiring.package">
       <attribute name="osgi.wiring.package" value="org.apache.ace.deployment"/>
       <attribute name="version" type="Version" value="1.0.0"/>
       <attribute name="bundle-symbolic-name" value="org.apache.ace.deployment.api"/>
-      <attribute name="bundle-version" type="Version" value="1.0.0"/>
+      <attribute name="bundle-version" type="Version" value="1.0.1"/>
       <directive name="uses" value="org.osgi.framework"/>
     </capability>
     <requirement namespace="osgi.wiring.package">
-      <directive name="filter" value="(&amp;(osgi.wiring.package=org.osgi.framework)(version&gt;=1.5.0)(!(version&gt;=2.0.0)))"/>
+      <directive name="filter" value="(&amp;(osgi.wiring.package=org.osgi.framework)(version&gt;=1.8.0)(!(version&gt;=2.0.0)))"/>
+    </requirement>
+    <requirement namespace="osgi.ee">
+      <directive name="filter" value="(&amp;(osgi.ee=JavaSE)(version=1.7))"/>
     </requirement>
   </resource>
   <resource>
     <capability namespace="osgi.identity">
       <attribute name="osgi.identity" value="org.apache.ace.deployment.deploymentadmin"/>
       <attribute name="type" value="osgi.bundle"/>
-      <attribute name="version" type="Version" value="1.0.0"/>
+      <attribute name="version" type="Version" value="1.0.1"/>
     </capability>
     <capability namespace="osgi.content">
-      <attribute name="osgi.content" value="e86336789bc549767f7ad62812b4a96ce342afabc452eb5a9a5b855c866a2d49"/>
-      <attribute name="url" value="org.apache.ace.deployment.deploymentadmin/org.apache.ace.deployment.deploymentadmin-1.0.0.jar"/>
-      <attribute name="size" type="Long" value="6645"/>
+      <attribute name="osgi.content" value="62c9fb1969c4d39ba2c312f8f05f4a04dbee83b76f508f58fc5040a92529cd76"/>
+      <attribute name="url" value="org.apache.ace.deployment.deploymentadmin/org.apache.ace.deployment.deploymentadmin-1.0.1.jar"/>
+      <attribute name="size" type="Long" value="6635"/>
       <attribute name="mime" value="application/vnd.osgi.bundle"/>
     </capability>
     <capability namespace="osgi.wiring.bundle">
       <attribute name="osgi.wiring.bundle" value="org.apache.ace.deployment.deploymentadmin"/>
-      <attribute name="bundle-version" type="Version" value="1.0.0"/>
+      <attribute name="bundle-version" type="Version" value="1.0.1"/>
     </capability>
     <capability namespace="osgi.wiring.host">
       <attribute name="osgi.wiring.host" value="org.apache.ace.deployment.deploymentadmin"/>
-      <attribute name="bundle-version" type="Version" value="1.0.0"/>
+      <attribute name="bundle-version" type="Version" value="1.0.1"/>
     </capability>
     <requirement namespace="osgi.wiring.package">
       <directive name="filter" value="(&amp;(osgi.wiring.package=org.apache.ace.deployment)(version&gt;=1.0.0)(!(version&gt;=1.1.0)))"/>
     </requirement>
     <requirement namespace="osgi.wiring.package">
-      <directive name="filter" value="(&amp;(osgi.wiring.package=org.apache.felix.dm)(version&gt;=3.0.0)(!(version&gt;=4.0.0)))"/>
+      <directive name="filter" value="(&amp;(osgi.wiring.package=org.apache.felix.dm)(version&gt;=4.1.0)(!(version&gt;=5.0.0)))"/>
     </requirement>
     <requirement namespace="osgi.wiring.package">
-      <directive name="filter" value="(&amp;(osgi.wiring.package=org.osgi.framework)(version&gt;=1.5.0)(!(version&gt;=2.0.0)))"/>
+      <directive name="filter" value="(&amp;(osgi.wiring.package=org.osgi.framework)(version&gt;=1.8.0)(!(version&gt;=2.0.0)))"/>
     </requirement>
     <requirement namespace="osgi.wiring.package">
       <directive name="filter" value="(&amp;(osgi.wiring.package=org.osgi.service.deploymentadmin)(version&gt;=1.1.0)(!(version&gt;=2.0.0)))"/>
@@ -1128,120 +1172,93 @@
     <requirement namespace="osgi.wiring.package">
       <directive name="filter" value="(&amp;(osgi.wiring.package=org.osgi.service.log)(version&gt;=1.3.0)(!(version&gt;=2.0.0)))"/>
     </requirement>
+    <requirement namespace="osgi.ee">
+      <directive name="filter" value="(&amp;(osgi.ee=JavaSE)(version=1.7))"/>
+    </requirement>
   </resource>
   <resource>
     <capability namespace="osgi.identity">
       <attribute name="osgi.identity" value="org.apache.ace.deployment.provider.api"/>
       <attribute name="type" value="osgi.bundle"/>
-      <attribute name="version" type="Version" value="1.1.0"/>
+      <attribute name="version" type="Version" value="1.1.1"/>
     </capability>
     <capability namespace="osgi.content">
-      <attribute name="osgi.content" value="47026c86d8a24b3c03fe0bcc1da9f727b05c6ca8e0508da593ec1ba82c589592"/>
-      <attribute name="url" value="org.apache.ace.deployment.provider.api/org.apache.ace.deployment.provider.api-1.1.0.jar"/>
-      <attribute name="size" type="Long" value="8333"/>
+      <attribute name="osgi.content" value="507e1c8154ceea4534223c778885aeb564b9b593a47e63b93807dfa59d1f7f63"/>
+      <attribute name="url" value="org.apache.ace.deployment.provider.api/org.apache.ace.deployment.provider.api-1.1.1.jar"/>
+      <attribute name="size" type="Long" value="8320"/>
       <attribute name="mime" value="application/vnd.osgi.bundle"/>
     </capability>

[... 2936 lines stripped ...]



Mime
View raw message