ace-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "J.W. Janssen (JIRA)" <>
Subject [jira] [Commented] (ACE-499) AceObrRepository doesn't work for repositories that require authentication
Date Thu, 04 Dec 2014 11:14:12 GMT


J.W. Janssen commented on ACE-499:

Ace ConnectionFactory:
* + Uses the existing Ace  connection factory configuration
* - Doesn't work when used in bnd(tools)
We could also embed the ConnectionFactory, if that would make things easier for standalone
deployment. Not sure yet what would be the consequences of that...

> AceObrRepository doesn't work for repositories that require authentication
> --------------------------------------------------------------------------
>                 Key: ACE-499
>                 URL:
>             Project: ACE
>          Issue Type: Bug
>    Affects Versions: 2.0.1
>            Reporter: Bram Pouwelse
> The AceObrRepository (at least in the way it's used in the gogo support functions) doesn't
support using a repository that requires authentication. 
> I've tried adding a Registry to the plugin to provide a "aQute.bnd.deployer.http.HttpBasicAuthURLConnector",
this resolves the issue for read actions but the upload method still doesn't work. The UrlConnector
interface currently only supports read actions so making this work would require a change
in bnd.
> Discussed this issue with [~marrs], he proposed to obtain a BundleContext using FrameworkUtil
to retrieve the Ace ConnectionFactory service. A possible drawback of this solution would
be that this doesn't work in case the AceObrRepository is used from bnd(tools)

This message was sent by Atlassian JIRA

View raw message