ace-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bram de Kruijff (JIRA)" <j...@apache.org>
Subject [jira] [Assigned] (ACE-289) before and after in IntegrationTestBase should have different names
Date Wed, 15 May 2013 20:17:17 GMT

     [ https://issues.apache.org/jira/browse/ACE-289?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Bram de Kruijff reassigned ACE-289:
-----------------------------------

    Assignee: Bram de Kruijff
    
> before and after in IntegrationTestBase should have different names
> -------------------------------------------------------------------
>
>                 Key: ACE-289
>                 URL: https://issues.apache.org/jira/browse/ACE-289
>             Project: ACE
>          Issue Type: Improvement
>          Components: Build
>    Affects Versions: 0.8.0-incubator
>            Reporter: J.W. Janssen
>            Assignee: Bram de Kruijff
>            Priority: Trivial
>         Attachments: issue-289.patch
>
>
> The IntegrationTestBase class form a base class for all integration tests. This class
defines two template methods, before() and after() that can be used to do something before
the dependencies are resolved and after the dependencies are resolved. The names of these
methods can be confused with the before/after annotations used by JUnit. We need to rethink
their names and adapt the existing tests (+ website!) accordingly...

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message