ace-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bram de Kruijff (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (ACE-301) Improve getting started html to avoid class/source incompatibilities with jdk7
Date Tue, 16 Apr 2013 13:19:16 GMT

    [ https://issues.apache.org/jira/browse/ACE-301?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13632825#comment-13632825
] 

Bram de Kruijff commented on ACE-301:
-------------------------------------

Is this still an issue? At present the build source/target is at 1.6 and I have no trouble
building with this setting or even 1.7 :)

My jdk:
{code}
"1.7.0_17"
Java(TM) SE Runtime Environment (build 1.7.0_17-b02)
Java HotSpot(TM) 64-Bit Server VM (build 23.7-b01, mixed mode)
{code}
                
> Improve getting started html to avoid class/source incompatibilities with jdk7
> ------------------------------------------------------------------------------
>
>                 Key: ACE-301
>                 URL: https://issues.apache.org/jira/browse/ACE-301
>             Project: ACE
>          Issue Type: Improvement
>          Components: Build
>         Environment: eclipse with jdk 1.7.0_07
> windows with jdk 1.6.0_33
> ant 1.8.x
>            Reporter: Tuomas Kiviaho
>            Assignee: Marcel Offermans
>            Priority: Minor
>
> I'm new to ACE and BndTools and found out that building of the project from trunk required
a bit more steps than what was documented on getting started.
> *Command line build*
> ANT build process goes as far as deployment verifier with the environment specified in
this issue. Then you start getting error like below.
> {code}
> [javac] warning: [options] bootstrap class path not set in conjunction with -source 1.5
> [javac] src\org\apache\ace\deployment\verifier\impl\VerifyEnvironmentImpl.java:125: error:
type ServiceReference does not take parameters
> [javac]         public ServiceReference<?>[] getRegisteredServices() {
> [javac]                                ^
> {code}
> osgi.core;version=4.3.0.201102171602 used in deployment verifier isn't compatible with
jdk7 (it's compiled with JSR14 flag). You might want to consider using 4.3.1.201210102023
from maven central which is intended to fix this.
> *Eclipse with Bndtools*
> Everything works fine until after you've created distributable archive and try to run
it using the provided shell script using the environment specified in this issue.
> {code}
>  java.lang.UnsupportedClassVersionError: org/apache/ace/configurator/Activator : Unsupported
major.minor version 51.0
> {code}
> I suggest that getting started guide would include steps for configuring JDT which I
believe was previously provided automatically by M2Eclipse. I also noticed that defaults.bnd
contains javac.source/target as 1.5 which I believe should be 1.6.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message