ace-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Christian Vogel (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (ACE-289) before and after in IntegrationTestBase should have different names
Date Tue, 23 Apr 2013 06:31:18 GMT

    [ https://issues.apache.org/jira/browse/ACE-289?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13638836#comment-13638836
] 

Christian Vogel commented on ACE-289:
-------------------------------------

what about "after->configureAdditionalServices" and "before->configureProvisionedServices"?
                
> before and after in IntegrationTestBase should have different names
> -------------------------------------------------------------------
>
>                 Key: ACE-289
>                 URL: https://issues.apache.org/jira/browse/ACE-289
>             Project: ACE
>          Issue Type: Improvement
>          Components: Build
>    Affects Versions: 0.8.0-incubator
>            Reporter: J.W. Janssen
>            Priority: Trivial
>
> The IntegrationTestBase class form a base class for all integration tests. This class
defines two template methods, before() and after() that can be used to do something before
the dependencies are resolved and after the dependencies are resolved. The names of these
methods can be confused with the before/after annotations used by JUnit. We need to rethink
their names and adapt the existing tests (+ website!) accordingly...

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message