ace-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Christian Vogel (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (ACE-335) Migrate from Bndtools1 to Bndtools2
Date Wed, 06 Feb 2013 13:59:13 GMT

    [ https://issues.apache.org/jira/browse/ACE-335?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13572407#comment-13572407
] 

Christian Vogel edited comment on ACE-335 at 2/6/13 1:57 PM:
-------------------------------------------------------------

I investigated the osgi.core problems and it seems that mostly ServiceReference#compareTo
is missing in previous version as 4.1.0! For the verifier bundle I had to just erase the timestamp
of osgi.core version 4.3.0.2011.....! 

For running the server: I managed it to run them by changing following lines:

* org.apache.felix.configadmin;version='[1.2.8,1.2.9)' -> org.apache.felix.configadmin;version=1.4.0
(just this version is available now)
* osgi.cmpn;version='[4.2.1,4.2.2)' -> osgi.cmpn;version=latest (latest version: 4.3.0.201111022214
and previous: 4.2.0.200908310645 are available)

I had to add a new option as well: -runrepos to make all bundles that are not in the "workspace
repo" (ace projects) visible for the run configuration.

After this changes I could run the server as well as the targets without problems. Next step
are the test!


                
      was (Author: christian.vogel):
    I investigated the osgi.core problems and it seems that mostly ServiceReference#compareTo
is missing in previous version as 4.1.0! For the verifier bundle I had to just erase the timestamp
of osgi.core version 4.3.0.2011.....! 

For running the server: I managed it to run them by changing following lines:

* org.apache.felix.configadmin;version='[1.2.8,1.2.9)' -> org.apache.felix.configadmin;version=1.4.0
(just this version is available now)
* osgi.cmpn;version='[4.2.1,4.2.2)' -> osgi.cmpn;version=latest (latest version: 4.3.0.201111022214
and previous: 4.2.0.200908310645 are available)

I had to add a new option as well: -runrepos to make all bundles that are not in the workspace
visible for the run configuration.

After this changes I could run the server as well as the targets without problems. Next step
are the test!


                  
> Migrate from Bndtools1 to Bndtools2
> -----------------------------------
>
>                 Key: ACE-335
>                 URL: https://issues.apache.org/jira/browse/ACE-335
>             Project: ACE
>          Issue Type: Task
>            Reporter: Christian Vogel
>              Labels: patch
>   Original Estimate: 24h
>  Remaining Estimate: 24h
>
> The current trunk version is not compatible to the new Bndtools version. Therefore, steps
should be executed to migrate the current 1.0.0.REL to 2.0.0.REL.
> Steps.:
> 1. make a backup copy of the current 'cnf' project folder
> 2. delete the old one and let the new Bndtools version create a new 'cnf' project for
you
> 3. add the Apache Ace additional repositories to 'cnf/ext/repositories.bnd'
> 4. copy the 'lib' folder of your backup 'cnf' to the new 'cnf' project
> 5. copy 'update-lib.sh' from your backup to the new 'cnf' project
> 6. copy 'cnf/src' from your backup to the new 'cnf' project
> 7. resolve all left project issues during different versionings of bundles in new 'cnf'
> 8. add additional targets from old ant build file to 'cnf/build.xml'
> 9. update  run configurations

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message