ace-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "J.W. Janssen (JIRA)" <j...@apache.org>
Subject [jira] [Created] (ACE-289) before and after in IntegrationTestBase should have different names
Date Wed, 15 Aug 2012 11:54:38 GMT
J.W. Janssen created ACE-289:
--------------------------------

             Summary: before and after in IntegrationTestBase should have different names
                 Key: ACE-289
                 URL: https://issues.apache.org/jira/browse/ACE-289
             Project: ACE
          Issue Type: Improvement
    Affects Versions: 0.8.0
            Reporter: J.W. Janssen
            Priority: Trivial


The IntegrationTestBase class form a base class for all integration tests. This class defines
two template methods, before() and after() that can be used to do something before the dependencies
are resolved and after the dependencies are resolved. The names of these methods can be confused
with the before/after annotations used by JUnit. We need to rethink their names and adapt
the existing tests (+ website!) accordingly...


--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message