ace-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bram de Kruijff (Created) (JIRA)" <j...@apache.org>
Subject [jira] [Created] (ACE-259) Support for metatype schema v1.1 (and beyond)
Date Thu, 12 Apr 2012 15:49:19 GMT
Support for metatype schema v1.1 (and beyond)
---------------------------------------------

                 Key: ACE-259
                 URL: https://issues.apache.org/jira/browse/ACE-259
             Project: ACE
          Issue Type: Improvement
            Reporter: Bram de Kruijff


The configuration helper implementation hardcodes a check for "http://www.osgi.org/xmlns/metatype/v1.0.0",
but v1.1 and v.1.2 are also valid schemas. AFAICS there is no regression risk in accepting
v1.1 and 1.2 as long as the provider autoconf rp can handle them. Unfortunatly, there is no
way to express version constraints on this level.

So..

1) Create seperate helpers for v1.1. & v1.2
2) Make this helper accept v1.1 & v.1.2
3) Rely on org.apache.felix.metatype.MetaDataReader to determine validity

IMHO option 1 is unnecessarily heavy, option 2 is the easiest fix and option 3 the most elegant
and robust solution. 

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message