accumulo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Josh Elser <els...@apache.org>
Subject Re: can't turn tracing on
Date Thu, 23 Aug 2018 18:35:05 GMT
Great, glad that was it.

What "custom ones" are you referring to? The shell commands you shared 
earlier or something else?

On 8/23/18 12:35 PM, Jonathan Yom-Tov wrote:
> Thanks!
> 
> You were right, the tracer process was misconfigured. Now I can see some 
> traces like major compactions but all my custom ones are not written to 
> the trace table. My user is root, table is trace and I have Table.READ, 
> Table.WRITE on the trace table. Any ideas on what could be causing this?
> 
> 
> 
> 
> On Thu, Aug 23, 2018 at 3:25 PM, Josh Elser <elserj@apache.org 
> <mailto:elserj@apache.org>> wrote:
> 
>     Ensure that the Tracer service is running on the node(s) specified
>     in ${ACCUMULO_CONF_DIR}/tracers
> 
>     Likely, this process died because it didn't have permission to
>     create and write to the trace table. To fix that, you need to grant
>     permissions to the trace user to create tables or create the table
>     by hand and then grant read/write permission to the trace user.
> 
> 
>     On 8/23/18 5:26 AM, Jonathan Yom-Tov wrote:
> 
>         hi,
> 
>         I'm trying to trace scans. So I issued the following commands:
>         createtable test
>         insert a b c d
>         trace on
>         scan
>         trace off
> 
>         And got: ERROR:
>         org.apache.accumulo.core.client.TableNotFoundException: Table
>         trace does not exist
> 
>         If I create the trace table manually I get "Waiting for trace
>         information" over and over.
> 
>         How can I make tracing work on my cluster?
> 
> 

Mime
View raw message