accumulo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Maria Krommyda <mariakr1...@yahoo.gr>
Subject Accumulo init.d script
Date Wed, 08 Aug 2018 07:32:47 GMT
Hello everyone, 
I have set up a VM, Ubuntu 16.04, where I run Zookeeper (3.4.6), Hadoop (2.2.0) and Accumulo
(1.7.3)I am trying to set up a script at init.d that would start all three services in case
of an unexpected reboot of the machine. 
I already have a start_me script that I use to start the services which works great, but making
it an init.d script has been proven a challenge.
I have set all the environmental variables in /etc/default/my_script, which I include at the
beginning of my script I run all the commands as su accumulo_user -c 'command', trying to
avoid permission errors.
When I reboot the machine, I see the three services running (using the top command), I can
access the Hadoop admin page but Accumulo gives as Error:"Connection refused at localhost:9000"
and the monitor system doesn't start. 
Any ideas of what might be the problem, where I should look for any other log that might help
will be highly appreciated. 
And if you have any thoughts about a relevant path that I might not have changed as fixed,
please do share.
Thank you in advance for your time.
Best regards, Maria. 

Mime
View raw message