accumulo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Maria Krommyda <mariakr1...@yahoo.gr>
Subject Σχετ: Accumulo init.d script
Date Thu, 09 Aug 2018 11:20:39 GMT
Hello Josh, 
Thank you for your time and suggestions.
I am setting the ACCUMULO_HOME variable and I see the logs in the proper directory being updated
on every reboot so this should not be the problem.
I do not get any error/warning is the syslog. Only the confirmation that the service was started.
If there is any other log that I can check please let me know.
What is leading me to believe that it is a path/permission/variable issue, is that the exact
same script runs without any problem from the home directory after the login.
Best regards, Maria. 


    Στις 6:06 μ.μ. Τετάρτη, 8 Αυγούστου 2018, ο/η Josh Elser <elserj@apache.org>
έγραψε:
 

 Every Accumulo service creates log files in the directory you specified 
via the ACCUMULO_LOG_DIR environment variable in accumulo-env.sh

If you didn't define this, it likely defaults to ACCUMULO_HOME/logs.

Have you looked at your syslog or similar to understand what your init.d 
script's output was? If Hadoop comes up correctly and you know your 
steps work otherwise, it sounds like it might be a typo in your script.

On 8/8/18 3:32 AM, Maria Krommyda wrote:
> Hello everyone,
> 
> I have set up a VM, Ubuntu 16.04, where I run Zookeeper (3.4.6), Hadoop 
> (2.2.0) and Accumulo (1.7.3)
> I am trying to set up a script at init.d that would start all three 
> services in case of an unexpected reboot of the machine.
> 
> I already have a start_me script that I use to start the services which 
> works great, but making it an init.d script has been proven a challenge.
> 
> I have set all the environmental variables in /etc/default/my_script, 
> which I include at the beginning of my script
> I run all the commands as su accumulo_user -c 'command', trying to avoid 
> permission errors.
> 
> When I reboot the machine, I see the three services running (using the 
> top command), I can access the Hadoop admin page but Accumulo gives as 
> Error:
> "Connection refused at localhost:9000" and the monitor system doesn't 
> start.
> 
> Any ideas of what might be the problem, where I should look for any 
> other log that might help will be highly appreciated.
> 
> And if you have any thoughts about a relevant path that I might not have 
> changed as fixed, please do share.
> 
> Thank you in advance for your time.
> 
> Best regards,
> Maria.
> 


   
Mime
View raw message