accumulo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From o haya <oh...@yahoo.com>
Subject Re: Modifying VisibilityEvaluator - Problem with Classpath for scanner
Date Mon, 31 Jul 2017 14:39:32 GMT
[Sorry for the re-send, but I think I mistakenly sent to only Ivan before.]

Hi Ivan,

My Accumulo configuration is with everything on a single machine.  Would that matter (would
I have more than one tserver?)?

My situation is like "whack-a-mole" (that's the game where you hit a mole with a hammer and
another one pops up).  What I mean is it seems like I restart Accumulo (bin/stop-all.sh then
bin/start-all.sh) and one time I get one class that is not found, then the next time it seems
like a different class is not found.  Really frustrating. 

So far, as I said, I have put the JARs in lib/ext AND added them to the accumulo-site.xml
:(...  I gave up last night and shut all down and will try again later today.

Thanks,
Jim


--------------------------------------------
On Mon, 7/31/17, ivan bella <ivan@ivan.bella.name> wrote:

 Subject: Re: Modifying VisibilityEvaluator - Problem with Classpath for scanner
 To: user@accumulo.apache.org, "o haya" <ohaya@yahoo.com>
 Date: Monday, July 31, 2017, 8:33 AM
 
 Jim,
    Putting the jars in the lib/ext directory is
 a perfectly acceptable mechanism.  Make sure your jars are
 in place on all of your tservers before you start them up. 
 Perhaps this class is being found but is failing to
 initialize itself which can lead to a ClassNoDefError.
 Ivan
 
 > On July
 31, 2017 at 2:39 AM o haya <ohaya@yahoo.com> wrote:
 > 
 > 
 > Hi,
 > 
 > I am trying to make some modifications to
 the Accumulo VisibilityModifier, but when I add my code, and
 try to run a scan on a table, I am getting ClassNoDefError
 for a class that my modified code uses.
 >
 
 > So far, what I have been trying to add
 my JARs to the classpath is to put the JARs in the Accumulo
 lib/ext directory AND also, editing the accumulo-site.xml
 and adding the same JARs to that file.  
 > 
 > Is there somewhere
 else I need to configure or do I need to put the JAR in
 somewhere other than the lib/ext directory?
 > 
 > Thanks,
 > Jim
 

Mime
View raw message