accumulo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Noe Detore <ndet...@minerkasch.com>
Subject Re: Lost tablet server lock..SESSION_EXPIRED
Date Thu, 13 Oct 2016 14:49:30 GMT
Yes, seeing a lot of DEBUG:Upsess. Also seeing
 [server.GarbageCollectionLogger] DEBUG: gc ParNew=64.69(+1.24) secs
ConcurrentMarkSweep=102.51(+0.06) secs
freemem=4,844,821,808(-20,292,780,896) totalmem=25,525,551,104
2016-10-13 11:22:17,963 [zookeeper.ZooLock] DEBUG: event null None
Disconnected

During hotspot seems like a java gc pause is causing zk heart beat to miss
and then expire. Are there recommend java gc configurations?  We are using
native memory. Would trying G1 gc be advised?

Thank you

On Fri, Oct 7, 2016 at 8:23 PM, Jeff Kubina <jeff.kubina@gmail.com> wrote:

> Noe,
>
> Do you have a lot (1000s) of "[tserver.TableServer] DEBUG: UpSess ..."
> messages in your tserver logs prior to the FATAL or "ERROR: Lost tablet
> server lock" error message?
>
> Jeff
>
>
> --
> Jeff Kubina
> 410-988-4436
>
>
> On Fri, Oct 7, 2016 at 10:34 AM, Noe Detore <ndetore@minerkasch.com>
> wrote:
>
>> Any updates on this issue https://issues.apache.org/jira
>> /browse/ACCUMULO-3336 ? I am seeing this behavior using 1.7.2 on one of
>> our clusters. Not seeing on other clusters, but what could be some causes?
>> Swap on server looks good as there is none. Are there particular
>> configurations to adjust?
>>
>> org.apache.zookeeper.KeeperException$SessionExpiredException:
>> KeeperErrorCode = Session expired ...
>> 2016-10-06 23:22:30,633 [zookeeper.DistributedWorkQueue] INFO : Got
>> unexpected zookeeper event: None for ...
>> 2016-10-06 23:22:30,679 [tserver.TabletServer] ERROR: Lost tablet server
>> lock (reason = SESSION_EXPIRED), exiting
>>
>> Thanks
>> Noe
>>
>
>

Mime
View raw message