accumulo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Josh Elser <josh.el...@gmail.com>
Subject Re: Installing 1.7.2 single standalone
Date Mon, 10 Oct 2016 16:16:36 GMT
Hi Scott,

The interfaces that Accumulo will bind to are based on the hostname/IP 
you provide in $ACCUMULO_CONF_DIR.

Specifically, if you use localhost or 127.0.0.1, Accumulo will only bind 
to the loopback, which you are observing.

Replace localhost with the FQDN of your system in 
${ACCUMULO_CONF_DIR}/{masters,monitor,slaves,gc,tracers} and then 
restart Accumulo.

Brown, Scott M (IS) wrote:
> One more bit of info.. netstat shows its bound to localhost only..
>
> [root@cmtest2 logs]# netstat -a | grep 500
>
> tcp 0 0 localhost:50091 *:* LISTEN
>
> tcp 0 0 localhost:50095 *:* LISTEN
>
> tcp 0 0 *:50070 *:* LISTEN
>
> tcp 0 0 *:50010 *:* LISTEN
>
> tcp 0 0 *:50075 *:* LISTEN
>
> tcp 0 0 *:50079 *:* LISTEN
>
> tcp 0 0 *:50020 *:* LISTEN
>
> tcp 0 0 *:50090 *:* LISTEN
>
> *From:*Brown, Scott M (IS) [mailto:Scott.Brown8@ngc.com]
> *Sent:* Monday, October 10, 2016 10:54 AM
> *To:* user@accumulo.apache.org
> *Subject:* EXT :Installing 1.7.2 single standalone
>
> Hello all!
>
> I’m installing the following products:
>
> Hadoop 2.6
>
> Zookeeper 3.4.5
>
> Solr 4.10
>
> With accumulo, it installs, and I can reach the service locally using
> ‘localhost’ but cannot reach the services externally.
>
> There are iterations of the below error which I believe is setting up
> the Master Server?
>
> 2016-10-10 10:06:55,250 [impl.MasterClient] DEBUG: Failed to connect to
> master=localhost:9999, will retry...
>
> org.apache.thrift.transport.TTransportException:
> java.net.ConnectException: Connection refused
>
> at org.apache.thrift.transport.TSocket.open(TSocket.java:185)
>
> at
> org.apache.accumulo.core.rpc.ThriftUtil.createClientTransport(ThriftUtil.java:320)
>
> at
> org.apache.accumulo.core.client.impl.ThriftTransportPool.createNewTransport(ThriftTransportPool.java:478)
>
> at
> org.apache.accumulo.core.client.impl.ThriftTransportPool.getTransport(ThriftTransportPool.java:410)
>
> at
> org.apache.accumulo.core.client.impl.ThriftTransportPool.getTransport(ThriftTransportPool.java:388)
>
> at org.apache.accumulo.core.rpc.ThriftUtil.getClient(ThriftUtil.java:139)
>
> at
> org.apache.accumulo.core.rpc.ThriftUtil.getClientNoTimeout(ThriftUtil.java:106)
>
> at
> org.apache.accumulo.core.client.impl.MasterClient.getConnection(MasterClient.java:69)
>
> at org.apache.accumulo.monitor.Monitor.fetchData(Monitor.java:277)
>
> at org.apache.accumulo.monitor.Monitor$2.run(Monitor.java:511)
>
> at
> org.apache.accumulo.fate.util.LoggingRunnable.run(LoggingRunnable.java:35)
>
> at java.lang.Thread.run(Thread.java:745)
>
> Caused by: java.net.ConnectException: Connection refused
>
> at java.net.PlainSocketImpl.socketConnect(Native Method)
>
> at
> java.net.AbstractPlainSocketImpl.doConnect(AbstractPlainSocketImpl.java:350)
>
> at
> java.net.AbstractPlainSocketImpl.connectToAddress(AbstractPlainSocketImpl.java:206)
>
> at
> java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:188)
>
> at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:392)
>
> at java.net.Socket.connect(Socket.java:589)
>
> at org.apache.thrift.transport.TSocket.open(TSocket.java:180)
>
> We have 1.6 running fine, I’m missing something under the 1.7.2
> configuration, but cannot seem to find it.
>
> If I need to provide more information, please let me know..
>
> Thank you!
>

Mime
View raw message