accumulo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Josh Elser <josh.el...@gmail.com>
Subject Re: Accumulo 1.7.1 on Docker
Date Mon, 14 Mar 2016 16:25:07 GMT
Ok! Thanks, I'll look for that init.sh script.

We're not too... docker-savvy here yet :), but we can definitely help 
out if we can find an automation script. Let me get back to you.

Sven Hodapp wrote:
> Hi Josh,
>
> thanks for your answer.
> Currently I haven't uploaded the Dockerfile... If you want I'll upload it!
> (But currently it only is an debian with ssh, rsync, jdk7, the unzipped distributions
of hadoop, zookeeper and accumulo, and the set of environment variables)
>
> Currently, and for testing, I start all things manually.
> The steps I do is documented in /init.sh within the docker container.
> I've enshured that dfs and zookeeper are up before starting accumulo.
>
> Regards,
> Sven
>
> ----- Ursprüngliche Mail -----
>> Von: "Josh Elser"<josh.elser@gmail.com>
>> An: "user"<user@accumulo.apache.org>
>> Gesendet: Montag, 14. März 2016 15:41:16
>> Betreff: Re: Accumulo 1.7.1 on Docker
>
>> Hi Sven,
>>
>> I can't seem to find the source for your Docker image (nor am smart
>> enough to figure out how to extract it). Any chance you can point us to
>> that?
>>
>> That said, I did run your image, and it looks like you didn't actually
>> start Hadoop, ZooKeeper, or Accumulo.
>>
>> Our documentation treats Hadoop and ZooKeeper primarily as
>> prerequisites, so check their docs for good instructions.
>>
>> For Accumulo -
>>
>> Configuration:
>> http://accumulo.apache.org/1.7/accumulo_user_manual.html#_installation
>> Initialization:
>> http://accumulo.apache.org/1.7/accumulo_user_manual.html#_initialization
>> Starting:
>> http://accumulo.apache.org/1.7/accumulo_user_manual.html#_starting_accumulo
>>
>> Sven Hodapp wrote:
>>> Dear reader,
>>>
>>> I'd like to create a docker image with accumulo 1.7.1.
>>> I've install it from scratch with hadoop-2.7.2, zookeeper-3.4.8 and
>>> accumulo-1.7.1.
>>> I'm going though the installation and every time I'll end up like that:
>>>
>>> root@deebd8e29683:/# accumulo shell -u root
>>> Password: ******
>>> 2016-03-13 13:18:31,627 [trace.DistributedTrace] INFO : SpanReceiver
>>> org.apache.accumulo.tracer.ZooTraceClient was loaded successfully.
>>> 2016-03-13 13:20:31,955 [impl.ServerClient] WARN : There are no tablet servers:
>>> check that zookeeper and accumulo are running.
>>>
>>> Anybody got an idea whats wrong? I have no idea anymore...
>>>
>>> I'll currently share this docker image on docker hub.
>>> If you want to try it you can simply start:
>>>
>>>      docker run -it themerius/accumulo /bin/bash
>>>
>>> All binaries and configs are in there. In ./init.sh are my setup steps.
>>>
>>> Regards,
>>> Sven

Mime
View raw message