accumulo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sravankumar Reddy Javaji (BLOOMBERG/ 731 LEX)" <sjav...@bloomberg.net>
Subject Re: Class path for shell commands
Date Mon, 07 Mar 2016 21:31:49 GMT
Yes I am using 1.6.2 version. I am not sure if we can upgrade the version now. Could you please
let me know if there is any other way (temporary way) to fix that bug? Also how to ensure
that this error is coming because of  that bug?

From: user@accumulo.apache.org At: Mar  7 2016 16:28:15
To: Sravankumar Reddy Javaji (BLOOMBERG/ 731 LEX), user@accumulo.apache.org
Subject: Re: Class path for shell commands

Are you using a 1.6.x or earlier version? I think we fixed a bug in 1.7.0 where the user-specified
CLASSPATH was overridden.


On Mon, Mar 7, 2016 at 4:23 PM Sravankumar Reddy Javaji (BLOOMBERG/ 731 LEX) <sjavaji@bloomberg.net>
wrote:

Sorry that's typo. I used CLASSPATH, still not working. 

From: user@accumulo.apache.org At: Mar  7 2016 16:23:04
To: Sravankumar Reddy Javaji (BLOOMBERG/ 731 LEX), user@accumulo.apache.org
Subject: Re: Class path for shell commands

Try $CLASSPATH instead of $CLASS_PATH

On Mon, Mar 7, 2016 at 4:11 PM Sravankumar Reddy Javaji (BLOOMBERG/ 731 LEX) <sjavaji@bloomberg.net>
wrote:

Hello Everyone,

I built custom formatter by extending DefaultFormatter class. When I am trying to use DefaultFormatter,
I am getting "Class not found" exception. Below are the steps I followed:

From local machine:

$ export CLASS_PATH=$CLASS_PATH:<directory where jar exists>/*.jar

$ CONNECTED to accumulo shell server 

$ formatter -f fully_qualified_classname -t table_name

$ scan -t table
ERROR: Class not found 


Could someone please let me know any other way to set class path for shell? Also is there
anyway to debug this issue like checking current classpaths that shell is using?

Thanks for your time.

-
Regards,
Sravan


Mime
View raw message