accumulo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Medinets <david.medin...@gmail.com>
Subject Re: Different versions of accumulo libraries on client and server
Date Sat, 17 Oct 2015 14:19:16 GMT
Isn't OSGI (http://www.osgi.org/Main/HomePage) designed to allow using
different versions of client libraries?

On Sat, Oct 17, 2015 at 8:54 AM, Christopher <ctubbsii@apache.org> wrote:

> While not explicitly supported, using a newer client is probably
> acceptable. However, be aware that some features won't be supported, and
> others may behave differently.
>
> On the other hand, we do explicitly support compatibility between bugfix
> versions. So, if there's a problem with using 1.6.4 client against a 1.6.3
> server, that's be a big we'd be interested in fixing.
>
> Of course, please report any issues with 1.7.0 client against 1.6.3
> server. Just be aware there may be limited in our ability to address those
> issues.
>
> On Sat, Oct 17, 2015, 05:52 vaibhav thapliyal <
> vaibhav.thapliyal.91@gmail.com> wrote:
>
>> Hi Denis,
>> As far as my experience with working on accumulo, ideally you should use
>> the client libraries corresponding to your server version. But I have also
>> used the 1.7.0 libraries on my 1.6.3 accumulo cluster without ever facing a
>> problem.
>>
>> Vaibhav
>> On 17-Oct-2015 3:17 pm, "Denis" <denis@camfex.cz> wrote:
>>
>>> Hi.
>>>
>>> My client software needs to work with few accumulo clusters, some 1.6
>>> and some 1.7.
>>> Would it be correct to use 1.7 accumulo libraries on the client and
>>> 1.6.x on the server?
>>> Actually it works, I just want to be sure if I am right doing that.
>>>
>>

Mime
View raw message