accumulo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Scott <sct...@gmail.com>
Subject Re: Accumulo Monitor NullPointerException
Date Mon, 24 Aug 2015 18:24:26 GMT
Thank you Billie and Josh! We'll do some troubleshooting on zookeeper and
see if we can isolate it on that side.

Cheers,

 Scott

On Mon, Aug 24, 2015 at 1:18 PM, Billie Rinaldi <billie.rinaldi@gmail.com>
wrote:

> In the meantime, I think this NPE is caused by the monitor not being able
> to connect to zookeeper.  So check and make sure that your zookeeper
> instance is healthy and accessible by the monitor.
>
> On Mon, Aug 24, 2015 at 10:06 AM, Josh Elser <josh.elser@gmail.com> wrote:
>
>> Thanks to Billie who initially pointed it out, but I apparently stumbled
>> onto the same issue you reported a while back and forgot since.
>>
>> https://issues.apache.org/jira/browse/ACCUMULO-3958
>>
>> Should be fixed now. We'll probably have a 1.6.4 coming out in the near
>> future which will contain the fix.
>>
>> Thanks a bunch for taking the time to report it! That's very much
>> appreciated by all of us.
>>
>> Scott wrote:
>>
>>> Josh,
>>>
>>>    Yes, It's 1.6.3
>>>
>>> Cheers,
>>>
>>>   Scott
>>>
>>> On Fri, Aug 21, 2015 at 6:28 PM, Josh Elser <josh.elser@gmail.com
>>> <mailto:josh.elser@gmail.com>> wrote:
>>>
>>>     Hi Scott,
>>>
>>>     Are you sure you're running Accumulo 1.6.3? That line number seems
>>>     to imply that you're running into
>>>
>>>     https://issues.apache.org/jira/browse/ACCUMULO-3837
>>>
>>>     .. but that should be fixed in 1.6.3. Can you double-check please?
>>>
>>>     - Josh
>>>
>>>
>>>     Scott wrote:
>>>
>>>         Hello,
>>>
>>>             We have Accumulo 1.6.3 set up on the HortonWorks install
>>>         with a basic
>>>         cluster of one master and one tablet server. Initially
>>>         everything seemed
>>>         good but now I'm getting a NullPointerException when I go to the
>>>         monitor
>>>         web page. The logs also keep adding a message to that effect as
>>>         well. I
>>>         searched and couldn't find any posts with the same problem. I
>>>         went back
>>>         through all of the config files and made sure they conform to the
>>>         configuration instructions. I'm hoping someone can point me to
>>>         the right
>>>         place to look for troubleshooting.
>>>
>>>         http://<machine-name>:50095 responds with a page that has the
>>>         following:
>>>
>>>         <pre>
>>>         java.lang.NullPointerException
>>>         at
>>> org.apache.accumulo.monitor.Monitor.fetchData(Monitor.java:252)
>>>         at
>>>
>>> org.apache.accumulo.monitor.servlets.BasicServlet.doGet(BasicServlet.java:59)
>>>         at
>>>
>>> org.apache.accumulo.monitor.servlets.DefaultServlet.doGet(DefaultServlet.java:101)
>>>         at javax.servlet.http.HttpServlet.service(HttpServlet.java:668)
>>>         at javax.servlet.http.HttpServlet.service(HttpServlet.java:770)
>>>         at
>>>
>>> org.eclipse.jetty.servlet.ServletHolder.handle(ServletHolder.java:684)
>>>         at
>>>
>>> org.eclipse.jetty.servlet.ServletHandler.doHandle(ServletHandler.java:503)
>>>         at
>>>
>>> org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:137)
>>>         at
>>>
>>> org.eclipse.jetty.security.SecurityHandler.handle(SecurityHandler.java:557)
>>>         at
>>>
>>> org.eclipse.jetty.server.session.SessionHandler.doHandle(SessionHandler.java:231)
>>>         at
>>>
>>> org.eclipse.jetty.server.handler.ContextHandler.doHandle(ContextHandler.java:1086)
>>>         at
>>>
>>> org.eclipse.jetty.servlet.ServletHandler.doScope(ServletHandler.java:429)
>>>         at
>>>
>>> org.eclipse.jetty.server.session.SessionHandler.doScope(SessionHandler.java:193)
>>>         at
>>>
>>> org.eclipse.jetty.server.handler.ContextHandler.doScope(ContextHandler.java:1020)
>>>         at
>>>
>>> org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:135)
>>>         at
>>>
>>> org.eclipse.jetty.server.handler.HandlerWrapper.handle(HandlerWrapper.java:116)
>>>         at org.eclipse.jetty.server.Server.handle(Server.java:370)
>>>         at
>>>
>>> org.eclipse.jetty.server.AbstractHttpConnection.handleRequest(AbstractHttpConnection.java:494)
>>>         at
>>>
>>> org.eclipse.jetty.server.AbstractHttpConnection.headerComplete(AbstractHttpConnection.java:971)
>>>         at
>>>
>>> org.eclipse.jetty.server.AbstractHttpConnection$RequestHandler.headerComplete(AbstractHttpConnection.java:1033)
>>>         at
>>> org.eclipse.jetty.http.HttpParser.parseNext(HttpParser.java:644)
>>>         at
>>>
>>> org.eclipse.jetty.http.HttpParser.parseAvailable(HttpParser.java:235)
>>>         at
>>>
>>> org.eclipse.jetty.server.AsyncHttpConnection.handle(AsyncHttpConnection.java:82)
>>>         at
>>>
>>> org.eclipse.jetty.io.nio.SelectChannelEndPoint.handle(SelectChannelEndPoint.java:696)
>>>         at
>>>
>>> org.eclipse.jetty.io.nio.SelectChannelEndPoint$1.run(SelectChannelEndPoint.java:53)
>>>         at
>>>
>>> org.eclipse.jetty.util.thread.QueuedThreadPool.runJob(QueuedThreadPool.java:608)
>>>         at
>>>
>>> org.eclipse.jetty.util.thread.QueuedThreadPool$3.run(QueuedThreadPool.java:543)
>>>         at java.lang.Thread.run(Thread.java:745)
>>>         </pre>
>>>
>>>
>>>         The logs are recording the following error:
>>>
>>>         2015-08-21 16:37:21,152 [monitor.Monitor] WARN :
>>>         java.lang.NullPointerException
>>>                   at
>>>         org.apache.accumulo.monitor.Monitor.fetchData(Monitor.java:252)
>>>                   at
>>>         org.apache.accumulo.monitor.Monitor$2.run(Monitor.java:508)
>>>                   at
>>>
>>> org.apache.accumulo.core.util.LoggingRunnable.run(LoggingRunnable.java:34)
>>>                   at java.lang.Thread.run(Thread.java:745)
>>>
>>>         Thanks,
>>>
>>>            Scott
>>>
>>>
>>>
>

Mime
View raw message