accumulo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Josh Elser <josh.el...@gmail.com>
Subject Re: Accumulo starting up but NPE in logs and can't access monitor in browser
Date Tue, 07 Jul 2015 05:08:58 GMT
suave wrote:
>> Assuming that's the same exception you had the previous logs, the master
>> >  just hadn't started yet and the tracer tried to perform an RPC to it.
>> >  The last line of the tracer log implies that it successfully talked to
>> >  the master and registered itself in ZooKeeper. You should ignore this
>> >  exception in this case.
>
>> >  If you're seeing it repeatedly, that's a different issue (send more logs)
>
> Yes, I kind of saw it repeatedly in the logs.
> I attached the relevant logs (those that had an exception at least once) for
> 4 startup runs.

The exception in these logs are different than the last time, but the 
root cause is still the same. The Monitor, like the Tracer, will 
communicate with the Master. There's no guarantee that the Master will 
be up immediately when the Monitor or Tracer are started, and thus the 
Exception in the log. You can ignore the exception in the log -- each 
process will retry. This is built into all of Accumulo already.

Mime
View raw message