accumulo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Josh Elser <josh.el...@gmail.com>
Subject Re: Abnormal behaviour of custom iterator in getting entries
Date Wed, 17 Jun 2015 05:02:46 GMT
You put random values in the family and qualifier? Do I misunderstand you?

Also, if you can put up the full source for the iterator, that will be 
much easier if you need help debugging it. It's hard for us to guess at 
why your code might not be working as you expect.

madhvi wrote:
> Hi Josh,
>
> I have changed HashMap to TreeMap which sorts lexicographically and I
> have inserted random values in column family and qualifier.Value of
> TreeMap in value.
> Used scanner and batch scanner but getting results only with scanner.
>
> Thanks
> Madhvi
>
> On Tuesday 16 June 2015 08:42 PM, Josh Elser wrote:
>> Additionally, you're placing the Value into the ColumnQualifier and
>> dropping the ColumnFamily completely. Granted, that may not be a
>> problem for the specific data in your table, but it's not going to
>> work for any data.
>>
>> Christopher wrote:
>>> You're iterating over a HashMap. That's not sorted.
>>>
>>> --
>>> Christopher L Tubbs II
>>> http://gravatar.com/ctubbsii
>>>
>>>
>>> On Tue, Jun 16, 2015 at 1:58 AM, madhvi<madhvi.gupta@orkash.com> wrote:
>>>> Hi Josh,
>>>> Thanks for replying. I will enable remote debugger on my Accumulo
>>>> server.
>>>>
>>>> However I am slightly confused with your statement "you are not
>>>> returning
>>>> your data in sorted order". Can you point the part in my iterator
>>>> code which
>>>> seems innapropriate and any possible solution for that?
>>>>
>>>> Thanks
>>>> Madhvi
>>>>
>>>>
>>>> On Tuesday 16 June 2015 11:07 AM, Josh Elser wrote:
>>>>> //matched the condition and put values to holder map.
>>>>
>

Mime
View raw message