accumulo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sean Busbey <bus...@cloudera.com>
Subject Re: Issue launching accumulo proxy
Date Fri, 08 May 2015 19:23:54 GMT
On Thu, May 7, 2015 at 9:58 AM, Calvin Feder <calvin.feder@argyledata.com>
wrote:

>  Thank you Sean for your feedback.
>
>
>
> Do we need to have a gateway role defined?  What does this gateway role
> do?  Should it be defined on the cloudera manager server, or on the server
> which is running the proxy?  I didn’t have a gateway role defined before,
> but I have now defined a gateway role on the cloudera manager server node
> (which is also an accumulo node, as this is only a 3 node cluster).  The
> error still appears.  Do I need to restart accumulo for that change to take
> effect?
>
>
Gateway roles are for nodes that will be used to run any kind of client for
the cluster services. In your case, running the Accumulo Thrift Proxy has
the proxy acting as a client of the Accumulo configuration settings
(because it is not managed by CM).

Usually, I run a gateway role on any node that has been designated an "edge
node"--that is, it's meant to be a landing spot for people using the
cluster or for services that will be accessible outside of the cluster. The
one exception is if I'll be running a distributed client local to the
Tablet Servers (think YCSB as a stress test). In that case, I put a gateway
role on each cluster node.

You do not need to restart accumulo for adding gateway roles to take
effect. You do however need to go to the cluster in CM and select "deploy
client configuration files".



>
>
> We have tried with and without defining the ACCUMULO_HOME, and we have
> tried with the full path to the accumulo command and using the one in the
> path (which is actually just a sim link into the cloudera parcels).  The
> same error appears regardless.
>
>
>

Can you pastebin your /etc/accumulo/conf/ files? (after redacting any
sensitive host names or properties) If these are the original files
deployed by CM they won't contain your instance secret or any user/password
combos. However, you should verify that they haven't been altered to
include them.



>  For the zookeepers, we do not have a fully qualified domain name in this
> cluster.  There is actually no DNS server, and these names resolve because
> they are in the hosts file on each machine.  I could try using IP addresses
> instead, but I don’t think that is related to my problem.
>
>
>

Yep, that will work just fine. Without knowledge of your DNS operations
it's a red flag is all.


-- 
Sean

Mime
View raw message