accumulo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sean Busbey <bus...@cloudera.com>
Subject Re: VolumeUtil.removeTrailingSlash - NPE
Date Thu, 21 May 2015 17:13:45 GMT
If this is a new install you shouldn't need the instance.volumes.replacements
value.

Is this a CM managed Accumulo cluster?

Could you pastebin some of the master and tabletserver logs around the time
of the import and problems assigning?

On Thu, May 21, 2015 at 9:27 AM, firstie lastie <firstie.lastie@gmail.com>
wrote:

> I've seen a bunch of tickets and issues which look similar to this; I'll
> attempt to create a parcel using 1.6.2 and see if that resolves the issue.
>
> On Thu, May 21, 2015 at 9:08 AM, firstie lastie <firstie.lastie@gmail.com>
> wrote:
>
>> Hello,
>>
>> I'm using accumulo 1.6.0 (the cloudera [5.4.0] parcel), with multiple
>> namenodes (in HA).  This is a new install, and I was trying to import some
>> tables from another install.
>>
>> The import completed, but none of the tablets are assigned...
>>
>> I'm getting the exception when trying to assign a tablet...
>>
>> I've configured my volumes as such:
>> <property>
>> <name>instance.dfs.uri</name><value>hdfs://nameservice/accumulo</value>
>> </property>
>>
>> <property>
>> <name>instance.volumes</name><value>hdfs://nameservice/accumulo</value>
>> </property>
>>
>> <property>
>> <name>instance.volumes.replacements</name><value>hdfs://oldnnhost:8020/accumulo
>> hdfs://nameservice/accumulo</value>
>> </property>
>>
>> When I do this:
>> accumulo admin volumes
>> I get this:
>> ...
>>   Volume: hdfs://nameservice/accumulo
>> ...
>> ...
>> Listing volumes referenced in accumulo.metadata tablets section
>>   Volume: RELATIVE
>>   Volume: hdfs://nameservice/accumulo
>>
>> Can someone point me in the right direction?
>>
>
>


-- 
Sean

Mime
View raw message