accumulo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sean Busbey <bus...@cloudera.com>
Subject Re: Bad GC credentials after moving namenode
Date Fri, 06 Mar 2015 13:08:30 GMT
Are you sure you have the correct version number? the lines in your stack
trace don't line up with the Apache Accumulo 1.6.1 release. It looks like
they are from an HDP release of Accumulo, but we'll need to know which one
specifically.

Can you quickly confirm that the instance secret in the accumulo-site.xml
file used by the GC process is the same as your other roles?

Does this happen across GC instances, or just one in particular?

On Fri, Mar 6, 2015 at 12:35 AM, Russ Weeks <rweeks@newbrightidea.com>
wrote:

> Sorry, should've mentioned that I'm on 1.6.1.
>
> On Thu, Mar 5, 2015 at 10:33 PM, Russ Weeks <rweeks@newbrightidea.com>
> wrote:
>
>> Hi, folks,
>>
>> I just finished moving my namenode, following the instructions at [1]. I
>> think I got everything just about right but now I see these errors in the
>> monitor. They seem to be associated with the GC process.
>>
>> Unable to scan metadata table
>> 	java.lang.RuntimeException: org.apache.accumulo.core.client.AccumuloSecurityException:
Error BAD_CREDENTIALS for user !SYSTEM on table accumulo.root(ID:+r) - Username or Password
is Invalid
>> 	at org.apache.accumulo.core.client.impl.ScannerIterator.hasNext(ScannerIterator.java:187)
>> 	at org.apache.accumulo.server.util.MetadataTableUtil.getLogEntries(MetadataTableUtil.java:554)
>> 	at org.apache.accumulo.server.util.MetadataTableUtil$LogEntryIterator.<init>(MetadataTableUtil.java:622)
>> 	at org.apache.accumulo.server.util.MetadataTableUtil.getLogEntries(MetadataTableUtil.java:659)
>> 	at org.apache.accumulo.gc.GarbageCollectWriteAheadLogs.removeMetadataEntries(GarbageCollectWriteAheadLogs.java:321)
>> 	at org.apache.accumulo.gc.GarbageCollectWriteAheadLogs.collect(GarbageCollectWriteAheadLogs.java:151)
>> 	at org.apache.accumulo.gc.SimpleGarbageCollector.run(SimpleGarbageCollector.java:608)
>> 	at org.apache.accumulo.gc.SimpleGarbageCollector.main(SimpleGarbageCollector.java:159)
>> 	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
>> 	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
>> 	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
>> 	at java.lang.reflect.Method.invoke(Method.java:606)
>> 	at org.apache.accumulo.start.Main$1.run(Main.java:141)
>> 	at java.lang.Thread.run(Thread.java:745)
>> 	Caused by: org.apache.accumulo.core.client.AccumuloSecurityException: Error BAD_CREDENTIALS
for user !SYSTEM on table accumulo.root(ID:+r) - Username or Password is Invalid
>> 	at org.apache.accumulo.core.client.impl.ThriftScanner.scan(ThriftScanner.java:458)
>> 	at org.apache.accumulo.core.client.impl.ThriftScanner.scan(ThriftScanner.java:279)
>> 	at org.apache.accumulo.core.client.impl.ScannerIterator$Reader.run(ScannerIterator.java:84)
>> 	at org.apache.accumulo.core.client.impl.ScannerIterator.hasNext(ScannerIterator.java:177)
>> 		... 13 more
>> 	Caused by: ThriftSecurityException(user:!SYSTEM, code:BAD_CREDENTIALS)
>> 	at org.apache.accumulo.core.tabletserver.thrift.TabletClientService$startScan_result$startScan_resultStandardScheme.read(TabletClientService.java:6684)
>> 	at org.apache.accumulo.core.tabletserver.thrift.TabletClientService$startScan_result$startScan_resultStandardScheme.read(TabletClientService.java:6661)
>> 	at org.apache.accumulo.core.tabletserver.thrift.TabletClientService$startScan_result.read(TabletClientService.java:6584)
>> 	at org.apache.thrift.TServiceClient.receiveBase(TServiceClient.java:78)
>> 	at org.apache.accumulo.core.tabletserver.thrift.TabletClientService$Client.recv_startScan(TabletClientService.java:232)
>> 	at org.apache.accumulo.core.tabletserver.thrift.TabletClientService$Client.startScan(TabletClientService.java:208)
>> 	at org.apache.accumulo.core.client.impl.ThriftScanner.scan(ThriftScanner.java:403)
>> 		... 16 more
>>
>>
>> Any ideas? Everything seems to be working, eg. I can connect using the
>> shell and browse the contents of my tables.
>>
>> 1:
>> http://accumulo.apache.org/1.6/accumulo_user_manual.html#_instance_volumes_replacements
>>
>
>


-- 
Sean

Mime
View raw message