accumulo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "覃璐"<luq.j...@gmail.com>
Subject Re: why the table not balance when i start a new tablet server
Date Sat, 20 Dec 2014 08:34:23 GMT
i see the master debug log ,but i not found error log.
why a tablet offine not balancing?? the tablet 02 dead yet,and i restart it,but no table hosted
in it.




now i restart accumulo,i stop-all and start-all,why the tablet server not balance,the 04 no
table.




原始邮件
发件人:Eric Newtoneric.newton@gmail.com
收件人:user@accumulo.apache.orguser@accumulo.apache.org; vinesvines@apache.org
发送时间:2014年12月20日(周六) 01:36
主题:Re: why the table not balance when i start a new tablet server


If the master is not balancing, it will tell you why in the master debug log.


Some reasons for not balancing:


1) a tablet server is not responding to status requests

2) a balance plan is already being executed

3) a tablet is offline


-Eric



On Fri, Dec 19, 2014 at 9:43 AM, John Vines vines@apache.org wrote:
The default load balancer tries to balance each table, so if you have several small (single
tablet) tables, they will never be migrated since they're currently balanced.




On Fri, Dec 19, 2014 at 2:18 AM, 覃璐 luq.java@gmail.com wrote:


i have three tablet server,but one had falt yet.
then i re-start the tablet server,and i see it in the monitor page,but the table not balance,it
only has a table which i create now.
the document say that master will balance tables when tablet server falt,but why it not balance
tables when a servlet server add??
Mime
View raw message