accumulo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christopher <ctubb...@apache.org>
Subject Re: why i can't create a table in client
Date Thu, 04 Dec 2014 03:12:36 GMT
What kind of proxy? I know I've had problems trying to get Thrift to work
over a SOCKS5 proxy before. Perhaps the issue is related to that?


--
Christopher L Tubbs II
http://gravatar.com/ctubbsii

On Wed, Dec 3, 2014 at 10:02 PM, 覃璐 <luq.java@gmail.com> wrote:

> i check log in monitor site,the recent log has nothing.
>
> i use accumulo 1.6.1,and zk  3.4.6,and hadoop 2.5.1
>
> i can run my code in my server ,and the table can create.
>
> my server in intranet,i connect server by a proxy,i can read ,write and
> check the table is exists  in my client,only can not create a new table .
>
> what is wrong?
>
>
>  原始邮件
> *发件人:* Josh Elser<josh.elser@gmail.com>
> *收件人:* user<user@accumulo.apache.org>
> *发送时间:* 2014年12月4日(周四) 10:23
> *主题:* Re: why i can't create a table in client
>
> You might want to check the master log too.
>
> Alternatively, look at the Monitor -- it likely has any error messages
> aggregated there for all processes.
> http://your_monitor_host:50095/log
>
>  > i can run the code in my server ,and it looks good
>
> Not sure what you mean by this.
>
> 覃璐 wrote:
> > thanks for replay
> >
> >
> > i sure the namespace named test is exists,and it not work to create test_ttt
> >
> > i check the tserver.log in every machine and not find error.
> >
> > i can run the code in my server ,and it looks good
> >
> >
> > 原始邮件
> > *发件人:* Eric Newton<eric.newton@gmail.com>
> > *收件人:* user@accumulo.apache.org<user@accumulo.apache.org>
> > *发送时间:* 2014年12月4日(周四) 00:33
> > *主题:* Re: why i can't create a table in client
> >
> > What version of Accumulo?
> >
> > Assuming accumulo-1.6.1:
> >
> > Does the namespace "test" exist?
> > Does it work if you try to create "test_ttt"?
> >
> > Check the tserver logs for any errors, too.
> >
> > -Eric
> >
> >
> > On Wed, Dec 3, 2014 at 7:56 AM, 覃璐 <luq.java@gmail.com
> > <mailto:luq.java@gmail.com>> wrote:
> >
> >     hi,all.
> >
> >     now ,i want create a not exists table in my code like this:
> >
> >     conn.tableOperations().create("test.ttt");
> >
> >     but it looks not work:
> >
> >     [main] DEBUG org.apache.accumulo.core.client.admin.TableOperations
> >       - Failed to call beginFateOperation(), retrying ...
> >     org.apache.thrift.transport.TTransportException
> >     at
> >     org.apache.thrift.transport.TIOStreamTransport.read(TIOStreamTransport.java:132)
> >     at org.apache.thrift.transport.TTransport.readAll(TTransport.java:84)
> >     at
> >     org.apache.thrift.transport.TFramedTransport.readFrame(TFramedTransport.java:141)
> >     at
> >     org.apache.thrift.transport.TFramedTransport.read(TFramedTransport.java:101)
> >     at org.apache.thrift.transport.TTransport.readAll(TTransport.java:84)
> >     at
> >     org.apache.accumulo.core.client.impl.ThriftTransportPool$CachedTTransport.readAll(ThriftTransportPool.java:275)
> >     at
> >     org.apache.thrift.protocol.TCompactProtocol.readByte(TCompactProtocol.java:601)
> >     at
> >     org.apache.thrift.protocol.TCompactProtocol.readMessageBegin(TCompactProtocol.java:470)
> >     at org.apache.thrift.TServiceClient.receiveBase(TServiceClient.java:69)
> >     at
> >     org.apache.accumulo.core.master.thrift.FateService$Client.recv_beginFateOperation(FateService.java:112)
> >     at
> >     org.apache.accumulo.core.master.thrift.FateService$Client.beginFateOperation(FateService.java:98)
> >     at
> >     org.apache.accumulo.core.client.impl.TableOperationsImpl.beginFateOperation(TableOperationsImpl.java:232)
> >     at
> >     org.apache.accumulo.core.client.impl.TableOperationsImpl.doFateOperation(TableOperationsImpl.java:301)
> >     at
> >     org.apache.accumulo.core.client.impl.TableOperationsImpl.doFateOperation(TableOperationsImpl.java:293)
> >     at
> >     org.apache.accumulo.core.client.impl.TableOperationsImpl.doTableFateOperation(TableOperationsImpl.java:1574)
> >     at
> >     org.apache.accumulo.core.client.impl.TableOperationsImpl.create(TableOperationsImpl.java:220)
> >     at
> >     org.apache.accumulo.core.client.impl.TableOperationsImpl.create(TableOperationsImpl.java:185)
> >     at test.secbase.AccumuloTest.ct(AccumuloTest.java:148)
> >     at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
> >     at
> >     sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
> >     at
> >     sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
> >     at java.lang.reflect.Method.invoke(Method.java:606)
> >     at
> >     org.junit.internal.runners.TestMethodRunner.executeMethodBody(TestMethodRunner.java:99)
> >     at
> >     org.junit.internal.runners.TestMethodRunner.runUnprotected(TestMethodRunner.java:81)
> >     at
> >     org.junit.internal.runners.BeforeAndAfterRunner.runProtected(BeforeAndAfterRunner.java:34)
> >     at
> >     org.junit.internal.runners.TestMethodRunner.runMethod(TestMethodRunner.java:75)
> >     at
> >     org.junit.internal.runners.TestMethodRunner.run(TestMethodRunner.java:45)
> >     at
> >     org.junit.internal.runners.TestClassMethodsRunner.invokeTestMethod(TestClassMethodsRunner.java:75)
> >     at
> >     org.junit.internal.runners.TestClassMethodsRunner.run(TestClassMethodsRunner.java:36)
> >     at
> >     org.junit.internal.runners.TestClassRunner$1.runUnprotected(TestClassRunner.java:42)
> >     at
> >     org.junit.internal.runners.BeforeAndAfterRunner.runProtected(BeforeAndAfterRunner.java:34)
> >     at
> >     org.junit.internal.runners.TestClassRunner.run(TestClassRunner.java:52)
> >     at org.junit.runner.JUnitCore.run(JUnitCore.java:130)
> >     at
> >     com.intellij.junit4.JUnit4IdeaTestRunner.startRunnerWithArgs(JUnit4IdeaTestRunner.java:74)
> >     at
> >     com.intellij.rt.execution.junit.JUnitStarter.prepareStreamsAndStart(JUnitStarter.java:211)
> >     at
> >     com.intellij.rt.execution.junit.JUnitStarter.main(JUnitStarter.java:67)
> >     at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
> >     at
> >     sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
> >     at
> >     sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
> >     at java.lang.reflect.Method.invoke(Method.java:606)
> >     at com.intellij.rt.execution.application.AppMain.main(AppMain.java:134)
> >
> >     but when i query and add mutation or check the table is exists,it
> >     works good.
> >
> >     what is wrong with it ?how can i solve the error?
> >     thanks
> >
> >
> >
> >
> >
>
>

Mime
View raw message