accumulo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Keith Turner <ke...@deenlo.com>
Subject Re: ClassNotFoundException: org.apache.commons.logging.LogFactory
Date Thu, 06 Nov 2014 02:56:36 GMT
On Wed, Nov 5, 2014 at 9:14 PM, David Medinets <david.medinets@gmail.com>
wrote:

> /usr/lib/hadoop/lib does contains the jar file:
>
> -bash-4.1# ls -l /usr/lib/hadoop/lib/commons-logging-1.1.3.jar
> -rw-r--r-- 1 root root 62050 Apr 16  2014
> /usr/lib/hadoop/lib/commons-logging-1.1.3.jar
>
> The image is using hadoop v2:
>
> -bash-4.1# hadoop version
> Hadoop 2.4.0.2.1.1.0-385
> Subversion git@github.com:hortonworks/hadoop.git -r
> 68ceccf06a4441273e81a5ec856d41fc7e11c792
> Compiled by jenkins on 2014-04-16T21:24Z
> Compiled with protoc 2.5.0
> From source with checksum 9e788148daa5dd7934eb468e57e037b5
> This command was run using
> /usr/lib/hadoop/hadoop-common-2.4.0.2.1.1.0-385.jar
>
> I want to get the Accumulo image running so that I can modify
> https://github.com/medined/mongo-itests to start an Accumulo image
> instead of a MongoDB image. Overcast
> (https://github.com/xebialabs/overcast) seems like an interesting
> approach to integration testing.
>
> I haven't worked with Hadoop v2 so any pointers would be appreciated.
>

I think Accumulo 1.5 defaults its config to work w/ hadoop 1.  Look in
accumulo-env.sh and accumulo-site.xml examples for hadoop2 stuff thats
commented out.


>
>
> On Wed, Nov 5, 2014 at 9:08 PM, Josh Elser <josh.elser@gmail.com> wrote:
> > Also, /usr/lib/hadoop/lib may not be the expected location for
> > commons-logging if you're using Hadoop 2.x.y.
> >
> > Christopher wrote:
> >>
> >> Does /usr/lib/hadoop/lib/ actually contain commons-logging? The config
> is
> >> probably assuming it's brought in by Hadoop and that may not be the
> case for
> >> your Hadoop version.
> >>
> >>
> >> --
> >> Christopher L Tubbs II
> >> http://gravatar.com/ctubbsii
> >>
> >> On Wed, Nov 5, 2014 at 8:08 PM, David Medinets <
> david.medinets@gmail.com
> >> <mailto:david.medinets@gmail.com>> wrote:
> >>
> >>     I'm working with the Docker image at
> >>     https://github.com/sroegner/docker-builds/tree/master/accumulo
> with I
> >>     only changed to pull Accumulo v1.5.2
> >>
> >>     When running the "accumulo init --instance-name accumulo --password
> >>     DEFAULT" command inside the Docker image, I am getting the
> >>     ClassNotFound exception.
> >>
> >>     The CLASSPATH being used inside the accumulo script is:
> >>
> >>
> >>
> /usr/lib/accumulo-1.5.2/conf:/usr/lib/accumulo/lib/accumulo-start.jar:/usr/lib/hadoop/lib/log4j-1.2.17.jar
> >>
> >>     It seems to be set using:
> >>
> >>     CLASSPATH="${XML_FILES}:${START_JAR}:${LOG4J_JAR}"
> >>
> >>     Before I go mucking about, trampling the roses, is there something
> >>     simple that is not configured?
> >>
> >>
> >
>

Mime
View raw message