accumulo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Josh Elser <josh.el...@gmail.com>
Subject Re: ClassNotFoundException: org.apache.commons.logging.LogFactory
Date Thu, 06 Nov 2014 02:08:18 GMT
Also, /usr/lib/hadoop/lib may not be the expected location for commons-logging if you're using
Hadoop 2.x.y.

Christopher wrote:
> Does /usr/lib/hadoop/lib/ actually contain commons-logging? The config 
> is probably assuming it's brought in by Hadoop and that may not be the 
> case for your Hadoop version.
>
>
> --
> Christopher L Tubbs II
> http://gravatar.com/ctubbsii
>
> On Wed, Nov 5, 2014 at 8:08 PM, David Medinets 
> <david.medinets@gmail.com <mailto:david.medinets@gmail.com>> wrote:
>
>     I'm working with the Docker image at
>     https://github.com/sroegner/docker-builds/tree/master/accumulo with I
>     only changed to pull Accumulo v1.5.2
>
>     When running the "accumulo init --instance-name accumulo --password
>     DEFAULT" command inside the Docker image, I am getting the
>     ClassNotFound exception.
>
>     The CLASSPATH being used inside the accumulo script is:
>
>     /usr/lib/accumulo-1.5.2/conf:/usr/lib/accumulo/lib/accumulo-start.jar:/usr/lib/hadoop/lib/log4j-1.2.17.jar
>
>     It seems to be set using:
>
>     CLASSPATH="${XML_FILES}:${START_JAR}:${LOG4J_JAR}"
>
>     Before I go mucking about, trampling the roses, is there something
>     simple that is not configured?
>
>

Mime
View raw message