accumulo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Josh Elser <josh.el...@gmail.com>
Subject Re: Import/Export problems from 1.5.1 -> 1.6.0?
Date Thu, 09 Oct 2014 20:09:40 GMT
(for archival purposes)

I (re)stumbled on this and, after digging some more, realized that there 
is bigger issue.

https://issues.apache.org/jira/browse/ACCUMULO-3215

Ultimately, the import process in 1.6.0 and 1.6.1 are incorrect and 
generate incorrect entries in the accumulo.metadata table which render 
the imported table unusable.

Tim Israel wrote:
> Billie,
>
> Thank you for the recommendation, I was hunting for deprecated
> properties that would point to /accumulo
>
> Your suggestion worked great and fixed the importtable function.
>
> I set the following properties in my appConfig.json and regenerated my
> client's accumulo-site.xml:
> instance.dfs.dir=/user/accumulo/.slider/cluster/slideraccumulo/database/data
> instance.dfs.uri=hdfs://cluster
>
> I'm currently using slider-0.50.2-incubating-rc0, so I'll have to give
> ${USER} and ${CLUSTER_NAME} a look at a later time.
>
> Thanks!
>
> Tim
>
> On Thu, Sep 18, 2014 at 10:17 AM, Billie Rinaldi
> <billie.rinaldi@gmail.com <mailto:billie.rinaldi@gmail.com>> wrote:
>
>     It looks like the import table operation is creating file entries
>     using relative paths in the metadata table, and their names are
>     being resolved using the deprecated instance.dfs.dir and
>     instance.dfs.uri properties.  This seems like a bug.  I think a
>     workaround for the problem would be to set those deprecated
>     properties to match your instance.volumes property.  I know slider
>     is setting instance.volumes for you, but if you want to verify this
>     fixes the problem, it would probably be enough to set
>     instance.dfs.dir to
>     /user/accumulo/.slider/cluster/slideraccumulo/database/data in your
>     app config (maybe
>     /user/${USER}/.slider/cluster/${CLUSTER_NAME}/database/data would
>     work if you're using the develop branch).
>
>
>     On Wed, Sep 17, 2014 at 12:57 PM, Tim Israel <tim@timisrael.com
>     <mailto:tim@timisrael.com>> wrote:
>
>         Hi all,
>
>         I posted something similar on the slider mailing list and was
>         directed here.  After debugging further, it doesn't seem like
>         this is a slider issue.
>
>         I have some tables that were exported from another cluster
>         running Accumulo 1.5.1 on hoya and I'm trying to import them in
>         Accumulo 1.6.0 on Slider 0.50.2.  This target cluster is
>         Kerberized but Accumulo is running in simple authentication mode.
>
>         The exported table was distcp'd to a cluster configured with
>         slider.
>
>         The table was imported via accumulo shell successfully.  The
>         files get moved to
>         /user/accumulo/.slider/cluster/slideraccumulo/database/data/tables/1
>
>         However, if I scan the imported table, accumulo complains with
>         the following exception:
>         Failed to open file
>         hdfs://cluster/accumulo/tables/1/b-000005c/I000005d.rf File does
>         not exist: /accumulo/tables/1/b-000005c/I000005d.rf
>
>         I can scan the table if I move the files from
>         /user/accumulo/.slider/cluster/slideraccumulo/database/data/tables/1
>         to /accumulo/tables/1
>
>         I pulled accumulo-site from the slider publisher and saw that
>         instance.volumes is set as follows:
>         hdfs://cluster/user/accumulo/.slider/cluster/slideraccumulo/database/data
>
>         Any suggestions would be greatly appreciated.
>
>         Thanks,
>
>         Tim
>
>
>

Mime
View raw message