accumulo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jianshi Huang <jianshi.hu...@gmail.com>
Subject Re: Forgot SECRET, how to delete zookeeper nodes?
Date Mon, 14 Jul 2014 04:28:26 GMT
Thanks for the help. I think I might better re-ingest the data I need. :(

Jianshi


On Mon, Jul 14, 2014 at 12:05 PM, Sean Busbey <busbey@cloudera.com> wrote:

> If you want to recover the data stored in tables from the old instance,
> it'll be more straightforward to follow the advanced troubleshooting
> section of the user manual.
>
> In there is a "what if zookeeper fails" section:
>
> http://accumulo.apache.org/1.6/accumulo_user_manual.html#zookeeper_failure
>
> Take note of the caveats in that section about potential data issues.
>
> --
> Sean
> On Jul 13, 2014 11:02 PM, "Vicky Kak" <vicky.kak@gmail.com> wrote:
>
>> Here is the example about the import/export
>> http://accumulo.apache.org/1.6/examples/export.html
>>
>>
>> On Mon, Jul 14, 2014 at 9:27 AM, William Slacum <
>> wilhelm.von.cloud@accumulo.net> wrote:
>>
>>> If the zookeeper data is gone, your best bet is try and identify which
>>> directories under /accumulo/tables points to which tables you had. You can
>>> then bulk import the files into a new instance's tables.
>>>
>>>
>>> On Sun, Jul 13, 2014 at 11:54 PM, Vicky Kak <vicky.kak@gmail.com> wrote:
>>>
>>>> I am not sure if the tables could be recovered seamlessly, the tables
>>>> are stored in undelying hdfs.
>>>> I was thinking of using
>>>> http://accumulo.apache.org/1.6/examples/bulkIngest.html to recover the
>>>> tables, the better would be if we could update the zookeeper data pointing
>>>> to the existing hdfs table data.
>>>> I don't have more information about it as of now, we need someone else
>>>> to help us here.
>>>>
>>>>
>>>> On Mon, Jul 14, 2014 at 9:06 AM, Jianshi Huang <jianshi.huang@gmail.com
>>>> > wrote:
>>>>
>>>>> It's too deleted... so the only option I have is to delete the
>>>>> zookeeper nodes and reinitialize accumulo.
>>>>>
>>>>> You're right, I deleted the zk nodes and now Accumulo complains nonode
>>>>> error.
>>>>>
>>>>> Can I recover the tables for a new instance?
>>>>>
>>>>> Jianshi
>>>>>
>>>>>
>>>>> On Mon, Jul 14, 2014 at 11:28 AM, Vicky Kak <vicky.kak@gmail.com>
>>>>> wrote:
>>>>>
>>>>>> Can't you get the secret from the corresponding accumulo-site.xml
or
>>>>>> this is too deleted?
>>>>>>
>>>>>> Deletion from the zookeeper should be done using the rmr /accumulo
>>>>>> command, you will have to use zkCli.sh to use zookeeper client. I
have been
>>>>>> doing this sometime back, have not used it recently.
>>>>>> I would not recommend to delete the information in zookeeper unless
>>>>>> there is not other option, you may loose the data IMO.
>>>>>>
>>>>>>
>>>>>>
>>>>>> On Mon, Jul 14, 2014 at 8:40 AM, Jianshi Huang <
>>>>>> jianshi.huang@gmail.com> wrote:
>>>>>>
>>>>>>> Clusters got updated and user home files lost... I tried to
>>>>>>> reinstall accumulo but I forgot the secret I put before.
>>>>>>>
>>>>>>> So how can I delete /accumulo in Zookeeper?
>>>>>>>
>>>>>>> Or is there a way to rename instance_id?
>>>>>>>
>>>>>>> --
>>>>>>> Jianshi Huang
>>>>>>>
>>>>>>> LinkedIn: jianshi
>>>>>>> Twitter: @jshuang
>>>>>>> Github & Blog: http://huangjs.github.com/
>>>>>>>
>>>>>>
>>>>>>
>>>>>
>>>>>
>>>>> --
>>>>> Jianshi Huang
>>>>>
>>>>> LinkedIn: jianshi
>>>>> Twitter: @jshuang
>>>>> Github & Blog: http://huangjs.github.com/
>>>>>
>>>>
>>>>
>>>
>>


-- 
Jianshi Huang

LinkedIn: jianshi
Twitter: @jshuang
Github & Blog: http://huangjs.github.com/

Mime
View raw message