accumulo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jianshi Huang <jianshi.hu...@gmail.com>
Subject Re: Forgot SECRET, how to delete zookeeper nodes?
Date Mon, 14 Jul 2014 03:36:43 GMT
It's too deleted... so the only option I have is to delete the zookeeper
nodes and reinitialize accumulo.

You're right, I deleted the zk nodes and now Accumulo complains nonode
error.

Can I recover the tables for a new instance?

Jianshi


On Mon, Jul 14, 2014 at 11:28 AM, Vicky Kak <vicky.kak@gmail.com> wrote:

> Can't you get the secret from the corresponding accumulo-site.xml or this
> is too deleted?
>
> Deletion from the zookeeper should be done using the rmr /accumulo
> command, you will have to use zkCli.sh to use zookeeper client. I have been
> doing this sometime back, have not used it recently.
> I would not recommend to delete the information in zookeeper unless there
> is not other option, you may loose the data IMO.
>
>
>
> On Mon, Jul 14, 2014 at 8:40 AM, Jianshi Huang <jianshi.huang@gmail.com>
> wrote:
>
>> Clusters got updated and user home files lost... I tried to reinstall
>> accumulo but I forgot the secret I put before.
>>
>> So how can I delete /accumulo in Zookeeper?
>>
>> Or is there a way to rename instance_id?
>>
>> --
>> Jianshi Huang
>>
>> LinkedIn: jianshi
>> Twitter: @jshuang
>> Github & Blog: http://huangjs.github.com/
>>
>
>


-- 
Jianshi Huang

LinkedIn: jianshi
Twitter: @jshuang
Github & Blog: http://huangjs.github.com/

Mime
View raw message