accumulo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Josh Elser <josh.el...@gmail.com>
Subject Re: Do Accumulo 1.5.1 and 1.4.4 work with ZooKeeper 3.4.5?
Date Thu, 31 Jul 2014 15:06:15 GMT
Yup, I'm not aware of any issues with 3.4.5 and any version (1.4, 1.5, 
or 1.6) of Accumulo, either.

On 7/31/14, 10:58 AM, Mike Drob wrote:
> I've seen several vendors offering newer versions of zookeeper with
> Accumulo without issue. Cloudera has tested versions not too far off
> from Accumulo 1.4.5 and Accumulo 1.6.0 with CDH4, which uses ZK 3.4.5.
> Similarly, I just checked Hortonworks' documents on HDP 2.1 and that
> includes both Accumulo 1.5.1 and ZK 3.4.5.
>
> I think the general answer is that yes, it will work. From what I've
> seen the ZK team does a good job of semantic versions, and minor
> releases should be backwards compatible. I've not seen any testing on ZK
> 3.5, but that will likely be fine too.
>
> Mike
>
>
> On Thu, Jul 31, 2014 at 9:42 AM, Hunter Provyn <fhp@ccri.com
> <mailto:fhp@ccri.com>> wrote:
>
>     We are contemplating upgrading to ZooKeeper 3.4.5 for a project that
>     depends on Accumulo 1.5.1 and 1.4.4.
>
>     In 1.5.1 pom there is the note:
>     <!-- ZooKeeper 3.4.x works also, but we're not using new features
>     yet; this ensures 3.3.x compatibility. -->
>
>     In the 1.4.4 pom there is the dependency on 3.3.1 with no note.
>
>     Are there are any known issues with using ZooKeeper 3.4.x with 1.4.4?
>     Is it known to work or not work given that no new ZK features are
>     being used?
>
>     Thanks!
>
>

Mime
View raw message