accumulo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sean Busbey <bus...@cloudera.com>
Subject Re: [DISCUSS] Should we support upgrading 1.4 -> 1.6 w/o going through 1.5?
Date Mon, 16 Jun 2014 21:43:52 GMT
On Mon, Jun 16, 2014 at 5:29 PM, John Vines <jvines@gmail.com> wrote:

> My comfort with this is based solely on the amount of effort and
> complexity involved. I have no direct qualms with providing that path, on
> the assumption we don't spend an exorbitant amount of hours developing it
> and end up with a ridiculous amount of code brought up to support this
> which we have to maintain.
>
> I would also be happier to have some sort of story involved for how to
> ensure the 1.4 users migrate to 1.6 in such a way we don't hit a similar
> race condition we found for if/when they jump to 1.7/2.0.
>
>
>
I think the only way to do this is to state that it's a one-off exception.

Presuming we don't want to change our supported upgrade plan to be "upgrade
from  any previous version to current."

-- 
Sean

Mime
View raw message