accumulo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christopher <ctubb...@apache.org>
Subject Re: "Unknown" Table state
Date Mon, 03 Mar 2014 04:35:27 GMT
Which version? And, does it stay Unknown, or does it switch to
something else after some time (perhaps after refreshing the page)?
Chances are (just speculating at this early point), the monitor has
not yet seen the table deletion/creation fully yet, and it just needs
some time for its cached view of zookeeper to update.

--
Christopher L Tubbs II
http://gravatar.com/ctubbsii


On Sun, Mar 2, 2014 at 10:33 PM, Kevin Cho <kchojhu@gmail.com> wrote:
>             Connector connector = instance.getConnector(principal, token);
>
>             String tableName = "myTable";
>             TableOperations ops = connector.tableOperations();
>             if (ops.exists(tableName)) {
>                 ops.delete(tableName);
>             }
>             ops.create(tableName);
>
>             Mutation m = new Mutation("rowId");
>             m.put("columnFamily0", "columnQualifer0", "some value");
>
>             BatchWriter bw = connector.createBatchWriter(tableName, new
> BatchWriterConfig());
>             bw.addMutation(m);
>             bw.close();
>
> I verified that I am able to connect to Accumulo server and that "myTable"
> has been created.  When I viewed from Accumul Monitor -> Tables, I see the
> State to be "Unknown".  What's weird is that I'm even able to add
> entries..so it looks normal... but why does it say "Unknown"? Thanks a
> bunch!

Mime
View raw message