accumulo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Anthony F <afc...@gmail.com>
Subject Re: Found two locations for the same extent
Date Sat, 25 Jan 2014 16:03:29 GMT
Yes, I tried killing one and waiting for the system to stabilize - nothing
changed.  Tried killing both, same deal.  I even tried bouncing the whole
system.  I found a previous message about how to grant write permissions on
!METADATA to root and was able to delete one of the offending entries.  At
that point, the system stabilized.  Any tips on avoiding getting into this
situation?


On Sat, Jan 25, 2014 at 10:51 AM, dlmarion <dlmarion@comcast.net> wrote:

> Have you tried killing one or both of the tservers?
>
>
> Sent via the Samsung GALAXY S®4, an AT&T 4G LTE smartphone
>
>
> -------- Original message --------
> From: Anthony F
> Date:01/25/2014 10:12 AM (GMT-05:00)
> To: user@accumulo.apache.org
> Subject: Found two locations for the same extent
>
> I have a table that appears to be in an inconsistent state.  The master
> keeps logging the following exception:
>
> java.lang.RuntimeException:
> org.apache.accumulo.server.master.state.TabletLocationState$BadLocationStateException:
> found two locations for the same extent
>
> and never balances/migrates or loads any tablets.  I've tried deleting one
> of the offending rows in the !METADATA table but, not surprisingly, root
> doesn't have proper permissions.
>
> Anyone know how Accumulo 1.5.0 can get in this state and what can be done
> to get out of it?
>
>

Mime
View raw message