accumulo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mike Drob <mad...@cloudera.com>
Subject Re: accumulo startup issue: Accumulo not initialized, there is no instance id at /accumulo/instance_id
Date Wed, 15 Jan 2014 19:48:28 GMT
What do you get when you try to run "accumulo init"?


On Wed, Jan 15, 2014 at 2:39 PM, Steve Kruse <skruse@adaptivemethods.com>wrote:

> Hello,
>
>
>
> I'm new to accumulo and I am trying to get it up and running.  I currently
> = have hadoop 2.2.0 and zookeeper 3.4.5 installed and running.  I have gone
> t= hrough the installation steps on the following page and I now am running
> in= to a problem when I try to start accumulo up.  The error I receive is
> the f=
>
> ollowing:
>
>
>
> Thread "org.apache.accumulo.server.master.state.SetGoalState" died null
> java.lang.reflect.InvocationTargetException
>
>                 at sun.reflect.NativeMethodAccessorImpl.invoke0(Native
> Meth=
>
> od)
>
>                 at
> sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethod=
>
> AccessorImpl.java:39)
>
>                 at
> sun.reflect.DelegatingMethodAccessorImpl.invoke(Delegati=
>
> ngMethodAccessorImpl.java:25)
>
>                 at java.lang.reflect.Method.invoke(Method.java:597)
>
>                 at org.apache.accumulo.start.Main$1.run(Main.java:101)
>
>                 at java.lang.Thread.run(Thread.java:619)
>
> Caused by: java.lang.RuntimeException: Accumulo not initialized, there is
> n= o instance id at /accumulo/instance_id
>
>                 at
> org.apache.accumulo.core.client.ZooKeeperInstance.getIns=
>
> tanceIDFromHdfs(ZooKeeperInstance.java:293)
>
>                 at
> org.apache.accumulo.server.client.HdfsZooInstance._getIn=
>
> stanceID(HdfsZooInstance.java:126)
>
>                 at
> org.apache.accumulo.server.client.HdfsZooInstance.getIns=
>
> tanceID(HdfsZooInstance.java:119)
>
>                 at
> org.apache.accumulo.core.zookeeper.ZooUtil.getRoot(ZooUt=
>
> il.java:24)
>
>                 at
> org.apache.accumulo.server.master.state.SetGoalState.mai=
>
> n(SetGoalState.java:46)
>
>                 ... 6 more
>
>
>
> I have tried to run accumulo init several times but I still get the same
> re= sult every single time.  Any help would be much appreciated.
>
>
>
> Thanks,
>
>
>
> Steve
>
>
>
> *H. Stephen Kruse*
>
> Software Engineer
>
> Adaptive Methods
>
> 5860 Trinity Parkway, Suite 200
>
> Centreville, VA 20121
>
> phone: (703) 968-6132
>
> email: skruse@adaptivemethods.com
>
>
>

Mime
View raw message