accumulo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Eric Newton <eric.new...@gmail.com>
Subject Re: accumulo startup issue: Accumulo not initialized, there is no instance id at /accumulo/instance_id
Date Wed, 15 Jan 2014 20:43:27 GMT
I'm sue you will get a bunch of people responding ... the email delays have
made that worse recently.  The key here is this:

 Hadoop Filesystem is file:///


The hadoop configuration directory (HADOOP_CONF_DIR) is not in your
classpath.

You can edit the classpath in conf/accumulo-site.xml, and you can check it
like this:

 $ ./bin/accumulo classpath

-Eric



On Wed, Jan 15, 2014 at 3:37 PM, Steve Kruse <skruse@adaptivemethods.com>wrote:

> Sean,
>
>
>
> The logging definitely helped.  I’m now getting the following but I’m not
> sure why.
>
>
>
> raduser@cvaraddemo04>./bin/accumulo init
>
> 2014-01-15 15:32:20,331 [util.NativeCodeLoader] WARN : Unable to load
> native-hadoop library for your platform... using builtin-java classes where
> applicable
>
> 2014-01-15 15:32:20,498 [util.Initialize] INFO : Hadoop Filesystem is
> file:///
>
> 2014-01-15 15:32:20,499 [util.Initialize] INFO : Accumulo data dir is
> /accumulo
>
> 2014-01-15 15:32:20,499 [util.Initialize] INFO : Zookeeper server is
> 172.17.9.151:2181,172.17.9.152:2181,172.17.9.153:2181,172.17.9.154:2181,
> 172.17.9.155:2181,172.17.9.156:2181
>
> 2014-01-15 15:32:20,499 [util.Initialize] INFO : Checking if Zookeeper is
> available. If this hangs, then you need to make sure zookeeper is running
>
>
>
>
>
> Warning!!! Your instance secret is still set to the default, this is not
> secure. We highly recommend you change it.
>
>
>
>
>
> You can change the instance secret in accumulo by using:
>
>    bin/accumulo org.apache.accumulo.server.util.ChangeSecret oldPassword
> newPassword.
>
> You will also need to edit your secret in your configuration file by
> adding the property instance.secret to your conf/accumulo-site.xml. Without
> this accumulo will not operate correctly
>
> Instance name : sis
>
> Instance name "sis" exists. Delete existing entry from zookeeper? [Y/N] : Y
>
> Enter initial password for root (this may not be applicable for your
> security setup): ********
>
> Confirm initial password for root: ********
>
> 2014-01-15 15:33:05,994 [util.Initialize] FATAL: Failed to initialize
> filesystem
>
> java.io.IOException: Mkdirs failed to create /accumulo/instance_id
>
>                 at
> org.apache.hadoop.fs.ChecksumFileSystem.create(ChecksumFileSystem.java:438)
>
>                 at
> org.apache.hadoop.fs.ChecksumFileSystem.create(ChecksumFileSystem.java:424)
>
>                 at
> org.apache.hadoop.fs.FileSystem.create(FileSystem.java:905)
>
>                 at
> org.apache.hadoop.fs.FileSystem.create(FileSystem.java:886)
>
>                 at
> org.apache.hadoop.fs.FileSystem.create(FileSystem.java:848)
>
>                 at
> org.apache.hadoop.fs.FileSystem.createNewFile(FileSystem.java:1148)
>
>                 at
> org.apache.accumulo.server.util.Initialize.initFileSystem(Initialize.java:220)
>
>                 at
> org.apache.accumulo.server.util.Initialize.initialize(Initialize.java:176)
>
>                 at
> org.apache.accumulo.server.util.Initialize.doInit(Initialize.java:162)
>
>                 at
> org.apache.accumulo.server.util.Initialize.main(Initialize.java:494)
>
>                 at sun.reflect.NativeMethodAccessorImpl.invoke0(Native
> Method)
>
>                 at
> sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
>
>                 at
> sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
>
>                 at java.lang.reflect.Method.invoke(Method.java:597)
>
>                 at org.apache.accumulo.start.Main$1.run(Main.java:101)
>
>                 at java.lang.Thread.run(Thread.java:619)
>
> raduser@cvaraddemo04>
>
>
>
> Does this mean my hadoop is not setup properly?  Everything seems to be
> running, I can get to all of the web admin pages and don’t seem to have any
> errors.  Any help would be great.
>
>
>
> Thanks,
>
> Steve
>
>
>
> *From:* Sean Busbey [mailto:busbey+lists@cloudera.com]
> *Sent:* Wednesday, January 15, 2014 3:19 PM
> *To:* Accumulo User List
>
> *Subject:* Re: accumulo startup issue: Accumulo not initialized, there is
> no instance id at /accumulo/instance_id
>
>
>
> Hi Steve!
>
>
>
> It looks like you don't have any log4j settings, so you may not get some
> error messages reported. You should copy the log4j.properties and
> *_logger.xml files from one of hte configuration examples into
> $ACCUMULO_CONF_DIR before running init.
>
>
>
> On Wed, Jan 15, 2014 at 2:07 PM, Steve Kruse <skruse@adaptivemethods.com>
> wrote:
>
> Arshak,
>
>
>
> When I do the following commands I get the following:
>
>
>
> raduser@cvaraddemo01>./hadoop fs -ls /accumulo/instance_id/
>
> 2014-01-15 15:05:05,220 WARN  [main] util.NativeCodeLoader
> (NativeCodeLoader.java:<clinit>(62)) - Unable to load native-hadoop library
> for your platform... using builtin-java classes where applicable
>
> ls: `/accumulo/instance_id/': No such file or directory
>
> raduser@cvaraddemo01>./hadoop fs -ls /accumulo/sis/
>
> 2014-01-15 15:05:18,974 WARN  [main] util.NativeCodeLoader
> (NativeCodeLoader.java:<clinit>(62)) - Unable to load native-hadoop library
> for your platform... using builtin-java classes where applicable
>
> ls: `/accumulo/sis/': No such file or directory
>
> raduser@cvaraddemo01>
>
>
>
> It doesn’t like it is initializing my instance name in HDFS from what I
> can tell but as I said I am new to this and I am not getting any errors in
> the accumulo init script output.
>
>
>
> Steve
>
>
>
> *From:* Arshak Navruzyan [mailto:arshakn@gmail.com]
> *Sent:* Wednesday, January 15, 2014 2:57 PM
>
>
> *To:* user@accumulo.apache.org
> *Subject:* Re: accumulo startup issue: Accumulo not initialized, there is
> no instance id at /accumulo/instance_id
>
>
>
> Steve,
>
>
>
> You can check to see if it's initialized correctly in HDFS with:
>
>
>
> hadoop fs -ls /accumulo/instance_id/
>
>
>
> If you run it as the user that is trying to start Accumulo, you should see
> something like this
>
>
>
> -rw-------   3 arshakn supergroup          0 2014-01-01 22:37
> /accumulo/instance_id/f269a1cd-1425-47fc-b80b-eecd2feeed9c
>
>
>
> Arshak
>
>
>
> On Wed, Jan 15, 2014 at 11:52 AM, Steve Kruse <skruse@adaptivemethods.com>
> wrote:
>
> Hi Mike,
>
>
>
> The init seems to work fine.  Here is the output:
>
>
>
> raduser@cvaraddemo01>./accumulo init
>
> log4j:WARN No appenders could be found for logger
> (org.apache.accumulo.start.classloader.AccumuloClassLoader).
>
> log4j:WARN Please initialize the log4j system properly.
>
> log4j:WARN See http://logging.apache.org/log4j/1.2/faq.html#noconfig for
> more info.
>
>
>
>
>
> Warning!!! Your instance secret is still set to the default, this is not
> secure. We highly recommend you change it.
>
>
>
>
>
> You can change the instance secret in accumulo by using:
>
>    bin/accumulo org.apache.accumulo.server.util.ChangeSecret oldPassword
> newPassword.
>
> You will also need to edit your secret in your configuration file by
> adding the property instance.secret to your conf/accumulo-site.xml. Without
> this accumulo will not operate correctly
>
> Instance name : sis
>
> Instance name "sis" exists. Delete existing entry from zookeeper? [Y/N] : Y
>
> Enter initial password for root (this may not be applicable for your
> security setup): ********
>
> Confirm initial password for root: ********
>
>
>
>
>
> If I go to zookeeper I can actually see my instance sis.
>
>
>
> Steve
>
>
>
> *From:* Mike Drob [mailto:madrob@cloudera.com]
> *Sent:* Wednesday, January 15, 2014 2:48 PM
> *To:* user@accumulo.apache.org
> *Subject:* Re: accumulo startup issue: Accumulo not initialized, there is
> no instance id at /accumulo/instance_id
>
>
>
> What do you get when you try to run "accumulo init"?
>
>
>
> On Wed, Jan 15, 2014 at 2:39 PM, Steve Kruse <skruse@adaptivemethods.com>
> wrote:
>
> Hello,
>
>
>
> I'm new to accumulo and I am trying to get it up and running.  I currently
> = have hadoop 2.2.0 and zookeeper 3.4.5 installed and running.  I have gone
> t= hrough the installation steps on the following page and I now am running
> in= to a problem when I try to start accumulo up.  The error I receive is
> the f=
>
> ollowing:
>
>
>
> Thread "org.apache.accumulo.server.master.state.SetGoalState" died null
> java.lang.reflect.InvocationTargetException
>
>                 at sun.reflect.NativeMethodAccessorImpl.invoke0(Native
> Meth=
>
> od)
>
>                 at
> sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethod=
>
> AccessorImpl.java:39)
>
>                 at
> sun.reflect.DelegatingMethodAccessorImpl.invoke(Delegati=
>
> ngMethodAccessorImpl.java:25)
>
>                 at java.lang.reflect.Method.invoke(Method.java:597)
>
>                 at org.apache.accumulo.start.Main$1.run(Main.java:101)
>
>                 at java.lang.Thread.run(Thread.java:619)
>
> Caused by: java.lang.RuntimeException: Accumulo not initialized, there is
> n= o instance id at /accumulo/instance_id
>
>                 at
> org.apache.accumulo.core.client.ZooKeeperInstance.getIns=
>
> tanceIDFromHdfs(ZooKeeperInstance.java:293)
>
>                 at
> org.apache.accumulo.server.client.HdfsZooInstance._getIn=
>
> stanceID(HdfsZooInstance.java:126)
>
>                 at
> org.apache.accumulo.server.client.HdfsZooInstance.getIns=
>
> tanceID(HdfsZooInstance.java:119)
>
>                 at
> org.apache.accumulo.core.zookeeper.ZooUtil.getRoot(ZooUt=
>
> il.java:24)
>
>                 at
> org.apache.accumulo.server.master.state.SetGoalState.mai=
>
> n(SetGoalState.java:46)
>
>                 ... 6 more
>
>
>
> I have tried to run accumulo init several times but I still get the same
> re= sult every single time.  Any help would be much appreciated.
>
>
>
> Thanks,
>
>
>
> Steve
>
>
>
> *H. Stephen Kruse*
>
> Software Engineer
>
> Adaptive Methods
>
> 5860 Trinity Parkway, Suite 200
>
> Centreville, VA 20121
>
> phone: (703) 968-6132
>
> email: skruse@adaptivemethods.com
>
>
>
>
>
>
> ------------------------------
>
>
> Spam<https://antispam.roaringpenguin.com/canit/b.php?i=0aLekk40K&m=c8be3454d43c&t=20140115&c=s>
> Not spam<https://antispam.roaringpenguin.com/canit/b.php?i=0aLekk40K&m=c8be3454d43c&t=20140115&c=n>
> Forget previous vote<https://antispam.roaringpenguin.com/canit/b.php?i=0aLekk40K&m=c8be3454d43c&t=20140115&c=f>
>

Mime
View raw message