accumulo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Steve Kruse <skr...@adaptivemethods.com>
Subject RE: accumulo startup issue: Accumulo not initialized, there is no instance id at /accumulo/instance_id
Date Fri, 17 Jan 2014 20:01:31 GMT
Thanks.  I took out the policy file and all started working…

From: Ott, Charles H. [mailto:CHARLES.H.OTT@leidos.com]
Sent: Friday, January 17, 2014 6:11 AM
To: user@accumulo.apache.org
Subject: RE: accumulo startup issue: Accumulo not initialized, there is no instance id at
/accumulo/instance_id

It sounds like it could be a permissions issue.

Two things to check:

Are you sure the monitor is running as the same user that you used when doing ‘accumulo
init’ ?

The reason I ask is because the exception show that access was denied attempting a read/write
operation.

Also it could be related to the accumulo.policy file.  If this file is not properly configured
the java security policy will prevent the services from running properly.

Perhaps try renameing your accumulo.policy to something like, accumulo.policy.bak and try
again.

From: user-return-3603-CHARLES.H.OTT=leidos.com@accumulo.apache.org<mailto:user-return-3603-CHARLES.H.OTT=leidos.com@accumulo.apache.org>
[mailto:user-return-3603-CHARLES.H.OTT=leidos.com@accumulo.apache.org] On Behalf Of Steve
Kruse
Sent: Thursday, January 16, 2014 4:00 PM
To: user@accumulo.apache.org<mailto:user@accumulo.apache.org>
Subject: RE: accumulo startup issue: Accumulo not initialized, there is no instance id at
/accumulo/instance_id

I’m trying to run accumulo and everything seems to start fine from the console print outs:

raduser@cvaraddemo01>./start-all.sh<mailto:raduser@cvaraddemo01%3e./start-all.sh>
Starting monitor on 172.17.9.151
Starting tablet servers .... done
Starting tablet server on 172.17.9.151
2014-01-16 15:19:28,900 [util.NativeCodeLoader] WARN : Unable to load native-hadoop library
for your platform... using builtin-java classes where applicable
2014-01-16 15:19:29,484 [server.Accumulo] INFO : Attempting to talk to zookeeper
2014-01-16 15:19:29,732 [server.Accumulo] INFO : Zookeeper connected and initialized, attemping
to talk to HDFS
2014-01-16 15:19:29,840 [server.Accumulo] INFO : Connected to HDFS
Starting master on 172.17.9.151
Starting garbage collector on 172.17.9.151
Starting tracer on 172.17.9.151
raduser@cvaraddemo01>ls -la ../logs/


I look at my processes running and only see gc and tracer running.  I look a the logs and
found the following exception in the monitor log:

Thread "monitor" died null
java.lang.reflect.InvocationTargetException
                at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
                at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
                at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
                at java.lang.reflect.Method.invoke(Method.java:597)
                at org.apache.accumulo.start.Main$1.run(Main.java:101)
                at java.lang.Thread.run(Thread.java:619)
Caused by: java.security.AccessControlException: access denied (java.util.PropertyPermission
* read,write)
                at java.security.AccessControlContext.checkPermission(AccessControlContext.java:323)
                at java.security.AccessController.checkPermission(AccessController.java:546)
                at java.lang.SecurityManager.checkPermission(SecurityManager.java:532)
                at java.lang.SecurityManager.checkPropertiesAccess(SecurityManager.java:1252)
                at java.lang.System.getProperties(System.java:580)
                at org.apache.commons.configuration.SystemConfiguration.<init>(SystemConfiguration.java:38)
                at org.apache.accumulo.core.conf.Property.getDefaultValue(Property.java:384)
                at org.apache.accumulo.core.conf.DefaultConfiguration.iterator(DefaultConfiguration.java:52)
                at org.apache.accumulo.core.conf.ConfigSanityCheck.validate(ConfigSanityCheck.java:29)
                at org.apache.accumulo.core.conf.DefaultConfiguration.getInstance(DefaultConfiguration.java:37)
                at org.apache.accumulo.core.conf.AccumuloConfiguration.getDefaultConfiguration(AccumuloConfiguration.java:153)
                at org.apache.accumulo.core.conf.AccumuloConfiguration.getSiteConfiguration(AccumuloConfiguration.java:163)
                at org.apache.accumulo.core.security.SecurityUtil.serverLogin(SecurityUtil.java:39)
                at org.apache.accumulo.server.monitor.Monitor.main(Monitor.java:451)
                ... 6 more

I’ve run through the steps I have taken and I believe I have done everything properly. 
Any help is much appreciated.

Thanks

From: Steve Kruse [mailto:skruse@adaptivemethods.com]
Sent: Thursday, January 16, 2014 2:08 PM
To: user@accumulo.apache.org<mailto:user@accumulo.apache.org>
Subject: RE: accumulo startup issue: Accumulo not initialized, there is no instance id at
/accumulo/instance_id

Sean,

Could that be causing the problems I’m having?  I’ll give it a try…

Thanks

From: Sean Busbey [mailto:busbey+lists@cloudera.com]
Sent: Thursday, January 16, 2014 2:04 PM
To: Accumulo User List
Subject: Re: accumulo startup issue: Accumulo not initialized, there is no instance id at
/accumulo/instance_id

On Thu, Jan 16, 2014 at 12:51 PM, Steve Kruse <skruse@adaptivemethods.com<mailto:skruse@adaptivemethods.com>>
wrote:
When I run ./start-all.sh I get the following:

raduser@cvaraddemo01>./bin/start-all.sh<mailto:raduser@cvaraddemo01%3e./bin/start-all.sh>
Starting monitor on localhost
WARN : Max files open on localhost is 1024, recommend 65536
Starting tablet servers .... done
2014-01-16 13:38:26,404 [util.NativeCodeLoader] WARN : Unable to load native-hadoop library
for your platform... using builtin-java classes where applicable
2014-01-16 13:38:26,980 [server.Accumulo] INFO : Attempting to talk to zookeeper
2014-01-16 13:38:27,228 [server.Accumulo] INFO : Zookeeper connected and initialized, attemping
to talk to HDFS
2014-01-16 13:38:27,321 [server.Accumulo] INFO : Connected to HDFS
Starting tablet server on localhost
WARN : Max files open on localhost is 1024, recommend 65536
Starting master on localhost
WARN : Max files open on localhost is 1024, recommend 65536
Starting garbage collector on localhost
WARN : Max files open on localhost is 1024, recommend 65536
Starting tracer on localhost
WARN : Max files open on localhost is 1024, recommend 65536



Hey Steve,

You should make sure to correct the maximum number of open files for the user that is running
Accumulo.
________________________________


________________________________




________________________________

Spam<https://antispam.roaringpenguin.com/canit/b.php?i=0aLeXbyaS&m=95c70fda195f&t=20140117&c=s>
Not spam<https://antispam.roaringpenguin.com/canit/b.php?i=0aLeXbyaS&m=95c70fda195f&t=20140117&c=n>
Forget previous vote<https://antispam.roaringpenguin.com/canit/b.php?i=0aLeXbyaS&m=95c70fda195f&t=20140117&c=f>
Mime
View raw message