accumulo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Steve Kruse <skr...@adaptivemethods.com>
Subject RE: accumulo startup issue: Accumulo not initialized, there is no instance id at /accumulo/instance_id
Date Thu, 16 Jan 2014 18:41:22 GMT
Straightened out HDFS, now having problem getting accumulo to start.  Get the following exception
in my tracer log repeatedly.

2014-01-16 13:06:49,131 [impl.ServerClient] DEBUG: ClientService request failed null, retrying
...
org.apache.thrift.transport.TTransportException: Failed to connect to a server
        at org.apache.accumulo.core.client.impl.ThriftTransportPool.getAnyTransport(ThriftTransportPool.java:437)
        at org.apache.accumulo.core.client.impl.ServerClient.getConnection(ServerClient.java:152)
        at org.apache.accumulo.core.client.impl.ServerClient.getConnection(ServerClient.java:128)
        at org.apache.accumulo.core.client.impl.ServerClient.getConnection(ServerClient.java:123)
        at org.apache.accumulo.core.client.impl.ServerClient.executeRaw(ServerClient.java:105)
        at org.apache.accumulo.core.client.impl.ServerClient.execute(ServerClient.java:71)
        at org.apache.accumulo.core.client.impl.ConnectorImpl.<init>(ConnectorImpl.java:64)
        at org.apache.accumulo.server.client.HdfsZooInstance.getConnector(HdfsZooInstance.java:154)
        at org.apache.accumulo.server.client.HdfsZooInstance.getConnector(HdfsZooInstance.java:149)
        at org.apache.accumulo.server.trace.TraceServer.<init>(TraceServer.java:185)
        at org.apache.accumulo.server.trace.TraceServer.main(TraceServer.java:260)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:597)
        at org.apache.accumulo.start.Main$1.run(Main.java:101)
        at java.lang.Thread.run(Thread.java:619)

When I look at my processes, I have a gc and tracer app running.  I also can’t seem to run
accumulo init again because it says that it’s already been initialized.

Steve

From: Sean Busbey [mailto:busbey+lists@cloudera.com]
Sent: Wednesday, January 15, 2014 4:43 PM
To: Accumulo User List
Subject: Re: accumulo startup issue: Accumulo not initialized, there is no instance id at
/accumulo/instance_id

On Wed, Jan 15, 2014 at 3:36 PM, Steve Kruse <skruse@adaptivemethods.com<mailto:skruse@adaptivemethods.com>>
wrote:
Sean,

The classpath for HDFS was incorrect and that definitely helped when I corrected it.  Now
it seems I’m having a hadoop issue where the datanodes are not running.  I’m going to
keep plugging away.



Glad to hear you made progress. Generally, I recommend people run through teragen / terasort
to validate their HDFS and MR set up before the move on to installing Accumulo.

Let us know when you get back to trying to get Accumulo going.
________________________________

Spam<https://antispam.roaringpenguin.com/canit/b.php?i=0aLelHuyF&m=25623c521f75&t=20140115&c=s>
Not spam<https://antispam.roaringpenguin.com/canit/b.php?i=0aLelHuyF&m=25623c521f75&t=20140115&c=n>
Forget previous vote<https://antispam.roaringpenguin.com/canit/b.php?i=0aLelHuyF&m=25623c521f75&t=20140115&c=f>
Mime
View raw message