accumulo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Steve Kruse <skr...@adaptivemethods.com>
Subject RE: accumulo startup issue: Accumulo not initialized, there is no instance id at /accumulo/instance_id
Date Wed, 15 Jan 2014 19:52:33 GMT
Hi Mike,

The init seems to work fine.  Here is the output:

raduser@cvaraddemo01>./accumulo init
log4j:WARN No appenders could be found for logger (org.apache.accumulo.start.classloader.AccumuloClassLoader).
log4j:WARN Please initialize the log4j system properly.
log4j:WARN See http://logging.apache.org/log4j/1.2/faq.html#noconfig for more info.


Warning!!! Your instance secret is still set to the default, this is not secure. We highly
recommend you change it.


You can change the instance secret in accumulo by using:
   bin/accumulo org.apache.accumulo.server.util.ChangeSecret oldPassword newPassword.
You will also need to edit your secret in your configuration file by adding the property instance.secret
to your conf/accumulo-site.xml. Without this accumulo will not operate correctly
Instance name : sis
Instance name "sis" exists. Delete existing entry from zookeeper? [Y/N] : Y
Enter initial password for root (this may not be applicable for your security setup): ********
Confirm initial password for root: ********


If I go to zookeeper I can actually see my instance sis.

Steve

From: Mike Drob [mailto:madrob@cloudera.com]
Sent: Wednesday, January 15, 2014 2:48 PM
To: user@accumulo.apache.org
Subject: Re: accumulo startup issue: Accumulo not initialized, there is no instance id at
/accumulo/instance_id

What do you get when you try to run "accumulo init"?

On Wed, Jan 15, 2014 at 2:39 PM, Steve Kruse <skruse@adaptivemethods.com<mailto:skruse@adaptivemethods.com>>
wrote:

Hello,



I'm new to accumulo and I am trying to get it up and running.  I currently = have hadoop 2.2.0
and zookeeper 3.4.5 installed and running.  I have gone t= hrough the installation steps on
the following page and I now am running in= to a problem when I try to start accumulo up.
 The error I receive is the f=

ollowing:



Thread "org.apache.accumulo.server.master.state.SetGoalState" died null java.lang.reflect.InvocationTargetException

                at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Meth=

od)

                at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethod=

AccessorImpl.java:39)

                at sun.reflect.DelegatingMethodAccessorImpl.invoke(Delegati=

ngMethodAccessorImpl.java:25)

                at java.lang.reflect.Method.invoke(Method.java:597)

                at org.apache.accumulo.start.Main$1.run(Main.java:101)

                at java.lang.Thread.run(Thread.java:619)

Caused by: java.lang.RuntimeException: Accumulo not initialized, there is n= o instance id
at /accumulo/instance_id

                at org.apache.accumulo.core.client.ZooKeeperInstance.getIns=

tanceIDFromHdfs(ZooKeeperInstance.java:293)

                at org.apache.accumulo.server.client.HdfsZooInstance._getIn=

stanceID(HdfsZooInstance.java:126)

                at org.apache.accumulo.server.client.HdfsZooInstance.getIns=

tanceID(HdfsZooInstance.java:119)

                at org.apache.accumulo.core.zookeeper.ZooUtil.getRoot(ZooUt=

il.java:24)

                at org.apache.accumulo.server.master.state.SetGoalState.mai=

n(SetGoalState.java:46)

                ... 6 more



I have tried to run accumulo init several times but I still get the same re= sult every single
time.  Any help would be much appreciated.

Thanks,

Steve

H. Stephen Kruse
Software Engineer
Adaptive Methods
5860 Trinity Parkway, Suite 200
Centreville, VA 20121
phone: (703) 968-6132<tel:%28703%29%20968-6132>
email: skruse@adaptivemethods.com<mailto:skruse@adaptivemethods.com>


________________________________

Spam<https://antispam.roaringpenguin.com/canit/b.php?i=0aLejNfDc&m=eceeee445a2d&t=20140115&c=s>
Not spam<https://antispam.roaringpenguin.com/canit/b.php?i=0aLejNfDc&m=eceeee445a2d&t=20140115&c=n>
Forget previous vote<https://antispam.roaringpenguin.com/canit/b.php?i=0aLejNfDc&m=eceeee445a2d&t=20140115&c=f>

Mime
View raw message