accumulo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Josh Elser <josh.el...@gmail.com>
Subject Re: clone, offline usage in map-reduce job - error in getSplits method.
Date Tue, 03 Dec 2013 18:41:47 GMT
I remember running into something like this recently. Tried to offline 
mapreduce, got an error that the table couldn't be cloned. Then, I tried 
to take the table offline and run the job, and got an error that the 
table was offline.

I don't think I tracked it down the whole way, but there might be a bug 
here.

On 12/3/13, 1:34 PM, David Medinets wrote:
> A few weeks ago there was a message or two about cloning a table then
> taking it offline before running a map-reduce job using
> AccumuloInputFormat. I'm trying to do this but have run into an issue.
> Here is the gist of my code:
>
> String table = "AA";
> String tableClone = "AA_clone";
>
> getTableOperations().clone(table, tableClone, true, new HashMap<String,
> String>(), new TreeSet<String>());
> getTableOperations().offline(tableClone);
>
> ### the rest is normal Hadoop Job setup using tableClone has the input
> table.
>
> When I run the job, I get this message:
>
> ...AA_clone is offline
> ...at ... InputFormatBase.getSplits(InputFormatBase.java:1366)
> ...<normal java stack>
>
> Did I missing something in my job setup?

Mime
View raw message