accumulo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Keith Turner <ke...@deenlo.com>
Subject Re: Accumulo init over existing instance
Date Tue, 08 Oct 2013 22:14:28 GMT
On Tue, Oct 8, 2013 at 6:07 PM, John Vines <vines@apache.org> wrote:

> Like Jared said, wiping /accumulo out of hdfs is all you need to do.
>
> But Accumulo still uses IP addresses internally, so I'm not quite certain
> you're going to achieve what you set out for.
>

Until 1.6.0 w/ ACCUMULO-1585


>
>
> On Tue, Oct 8, 2013 at 5:32 PM, Terry P. <texpilot@gmail.com> wrote:
>
>> So reverse DNS wasn't working when I deployed my new cluster, thus all my
>> Tablet Servers were showing up in the Monitor as IP addresses (even though
>> all configuration files had hostnames only).  Lesson learned: trust, but
>> verify (and ensure your hardened base servers still have nslookup and/or
>> dig on them).
>>
>> Now that DNS is fixed, I want to wipe everything clean and re-init
>> Accumulo to ensure everything is legit using hostnames to ensure the
>> cluster is not tied to IP addresses.
>>
>> I know I need to do a new 'accumulo init' -- I'll pass in the same
>> instance name, and my understanding is that will overwrite everything
>> currently in Zookeeper.
>>
>> My question is: is there anything else I could/should do first to "clean
>> up" from this botched instance?  E.g. should I delete all files in HDFS,
>> the write-ahead logs on the Tablet Servers, etc.?  I'm running Accumulo
>> 1.4.2.
>>
>> Thanks,
>> Terry
>>
>
>

Mime
View raw message