accumulo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dickson, Matt MR" <matt.dick...@defence.gov.au>
Subject RE: Assigned and hosted Error [SEC=UNOFFICIAL]
Date Tue, 01 Oct 2013 02:54:15 GMT
UNOFFICIAL

After running the following delete on the !METADATA table everything is running again as normal.

deletemany -b 3n;nnnnnnn -e 3n;nnnnnnnn -c future,loc

Thanks again for the quick responses to my questions.
________________________________
From: Eric Newton [mailto:eric.newton@gmail.com]
Sent: Tuesday, 1 October 2013 08:55
To: user@accumulo.apache.org
Subject: Re: Assigned and hosted Error [SEC=UNOFFICIAL]

That is the prompt from the shell: you only have to type "y".

-Eric



On Mon, Sep 30, 2013 at 6:45 PM, Dickson, Matt MR <matt.dickson@defence.gov.au<mailto:matt.dickson@defence.gov.au>>
wrote:

UNOFFICIAL

Thanks Eric,

Could you just confirm the syntax for
Delete { 3n; future:0 [] } ? y

________________________________
From: Eric Newton [mailto:eric.newton@gmail.com<mailto:eric.newton@gmail.com>]
Sent: Tuesday, 1 October 2013 08:26
To: user@accumulo.apache.org<mailto:user@accumulo.apache.org>

Subject: Re: Assigned and hosted Error [SEC=UNOFFICIAL]

To unstick your stuck tablet, do this:

1) bring up the accumulo shell as the root user

2) grant yourself write permissions to the !METADATA table


table !METADATA
grant -u root -t !METADATA Table.WRITE

3) remove the entry for the future location:

deletemany -b 3n; -e 3n; -c future
Delete { 3n; future:0 [] } ? y

4) Restart the server on 160.45.45.33


-Eric



On Mon, Sep 30, 2013 at 6:05 PM, Eric Newton <eric.newton@gmail.com<mailto:eric.newton@gmail.com>>
wrote:
Yes... ACCUMULO-7 is at least one instance of this problem.

But, I don't know if that's your problem.  The part that is "[0]" is very strange.

What version of accumulo and zookeeper?

-Eric



On Mon, Sep 30, 2013 at 5:53 PM, Dickson, Matt MR <matt.dickson@defence.gov.au<mailto:matt.dickson@defence.gov.au>>
wrote:

UNOFFICIAL

Hi,

I'm getting a BadLocationStateException stating '3n;nnnnnnn;nnnnnnn is both assigned and hosted,
which should never happen: 3n;nnnnnnn;nnnnnnn @(160.45.45.33:9997[2323423aeb], 160.45.45.33:9997[0],null)'

The Accumulo console is unable to display any table details.  I have tried restarting Accumulo
with no success and the logs contain an 'INFO : Failed to obtain problem reports' message.

Has anyone come across this?

Thanks in advance,
Matt Dickson




Mime
View raw message