accumulo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Benjamin Parrish <benjamin.d.parr...@gmail.com>
Subject Error running client code
Date Fri, 13 Sep 2013 16:16:49 GMT
I am having what seems to be a usual error people see, but I am not sure administratively what
to do to fix it.

This is my code:

public static void main(String[] args) throws TableNotFoundException, AccumuloException, AccumuloSecurityException
{
	String instanceName = "accumulo";
	String zooServers = "10.200.20.37";
	Instance inst = new ZooKeeperInstance(instanceName, zooServers);

	Connector conn = inst.getConnector("root", "secret");
		
	Text rowID = new Text("row1");
	Text colFam = new Text("myColFam");
	Text colQual = new Text("myColQual");
	ColumnVisibility colVis = new ColumnVisibility("public");
	long timestamp = System.currentTimeMillis();

	Value value = new Value("myValue".getBytes());

	Mutation mutation = new Mutation(rowID);
	mutation.put(colFam, colQual, colVis, timestamp, value);
		
	long memBuf = 1000000L; // bytes to store before sending a batch
	long timeout = 1000L; // milliseconds to wait before sending
	int numThreads = 10;

	BatchWriter writer = conn.createBatchWriter("table", memBuf, timeout, numThreads);

	writer.addMutation(mutation);

	writer.close();
}

This is the error I see in Eclipse:

13/09/13 12:10:22 WARN impl.ServerClient: Failed to find an available server in the list of
servers: [127.0.0.1:9997:9997 (120000)]

Everything is operational to the best of my knowledge.  I can run scans on tables in the terminal.
Mime
View raw message