accumulo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ray Pfaff <ray.pf...@apx-labs.com>
Subject Re: Communication issue between zookeeper and accumulo
Date Thu, 08 Aug 2013 13:07:29 GMT
I can see if I can do that.

From: Sean Busbey <busbey@cloudera.com<mailto:busbey@cloudera.com>>
Reply-To: "user@accumulo.apache.org<mailto:user@accumulo.apache.org>" <user@accumulo.apache.org<mailto:user@accumulo.apache.org>>
Date: Wednesday, August 7, 2013 7:25 PM
To: Accumulo User List <user@accumulo.apache.org<mailto:user@accumulo.apache.org>>
Subject: Re: Communication issue between zookeeper and accumulo

Can you post the full logs from the tablet servers somewhere and send a link?



On Tue, Aug 6, 2013 at 10:40 AM, Ray Pfaff <ray.pfaff@apx-labs.com<mailto:ray.pfaff@apx-labs.com>>
wrote:
It's from one of the tablet servers, but looking at one of the zookeeper servers, it's exactly
the same

From: Sean Busbey <busbey@cloudera.com<mailto:busbey@cloudera.com>>
Reply-To: "user@accumulo.apache.org<mailto:user@accumulo.apache.org>" <user@accumulo.apache.org<mailto:user@accumulo.apache.org>>
Date: Tuesday, August 6, 2013 1:35 PM

To: Accumulo User List <user@accumulo.apache.org<mailto:user@accumulo.apache.org>>
Subject: Re: Communication issue between zookeeper and accumulo

Is that on the ZK server or the TabletServer? Can we also see the other?


On Tue, Aug 6, 2013 at 10:33 AM, Ray Pfaff <ray.pfaff@apx-labs.com<mailto:ray.pfaff@apx-labs.com>>
wrote:
Chain INPUT (policy ACCEPT)
target     prot opt source               destination
ACCEPT     tcp  --  anywhere             anywhere            tcp dpt:ssh
ACCEPT     icmp --  anywhere             anywhere            icmp echo-reply
ACCEPT     icmp --  anywhere             anywhere            icmp echo-request
ACCEPT     tcp  --  anywhere             anywhere            tcp dpt:nrpe
ACCEPT     udp  --  anywhere             anywhere            udp dpt:domain

Chain FORWARD (policy DROP)
target     prot opt source               destination

Chain OUTPUT (policy ACCEPT)
target     prot opt source               destination

From: Brendan Heussler <bheussler@gmail.com<mailto:bheussler@gmail.com>>
Reply-To: "user@accumulo.apache.org<mailto:user@accumulo.apache.org>" <user@accumulo.apache.org<mailto:user@accumulo.apache.org>>
Date: Tuesday, August 6, 2013 1:27 PM
To: "user@accumulo.apache.org<mailto:user@accumulo.apache.org>" <user@accumulo.apache.org<mailto:user@accumulo.apache.org>>

Subject: Re: Communication issue between zookeeper and accumulo

What is the output of iptables --list?



Brendan


On Tue, Aug 6, 2013 at 1:25 PM, Ray Pfaff <ray.pfaff@apx-labs.com<mailto:ray.pfaff@apx-labs.com>>
wrote:
Not sure what you mean.  I get the error "Fatal ip6_tables not found."  I'm assuming that
means disabled?

From: <Ott>, "Charles H." <CHARLES.H.OTT@saic.com<mailto:CHARLES.H.OTT@saic.com>>
Reply-To: "user@accumulo.apache.org<mailto:user@accumulo.apache.org>" <user@accumulo.apache.org<mailto:user@accumulo.apache.org>>
Date: Tuesday, August 6, 2013 1:18 PM
To: "user@accumulo.apache.org<mailto:user@accumulo.apache.org>" <user@accumulo.apache.org<mailto:user@accumulo.apache.org>>
Subject: RE: Communication issue between zookeeper and accumulo

And iptables?

From: user-return-2837-CHARLES.H.OTT=saic.com@accumulo.apache.org<mailto:user-return-2837-CHARLES.H.OTT=saic.com@accumulo.apache.org>
[mailto:user-return-2837-CHARLES.H.OTT=saic.com@accumulo.apache.org] On Behalf Of Ray Pfaff
Sent: Tuesday, August 06, 2013 12:54 PM
To: user@accumulo.apache.org<mailto:user@accumulo.apache.org>
Subject: Re: Communication issue between zookeeper and accumulo

Yes, it is disabled, so that's not the problem.

From: Sean Busbey <busbey@cloudera.com<mailto:busbey@cloudera.com>>
Reply-To: "user@accumulo.apache.org<mailto:user@accumulo.apache.org>" <user@accumulo.apache.org<mailto:user@accumulo.apache.org>>
Date: Tuesday, August 6, 2013 12:48 PM
To: Accumulo User List <user@accumulo.apache.org<mailto:user@accumulo.apache.org>>
Subject: Re: Communication issue between zookeeper and accumulo

Hi Ray!

Can you confirm that IPv6 is disabled?

On Tue, Aug 6, 2013 at 9:19 AM, Ray Pfaff <ray.pfaff@apx-labs.com<mailto:ray.pfaff@apx-labs.com>>
wrote:
I'm not sure if I can provide those due to the contract I'm working.  I really don't want
to diverge this conversation from the original question I'm asking (which is a problem even
running one tablet server per machine) but are you saying that setting tserver.port.search
= true shouldn't be done?  I found this to be an undocumented way of running more than one
tablet server per system.  I'm still not convinced that this leads to stability issues on
tablet servers.  As I said, it's undocumented.

From: Eric Newton <eric.newton@gmail.com<mailto:eric.newton@gmail.com>>
Reply-To: "user@accumulo.apache.org<mailto:user@accumulo.apache.org>" <user@accumulo.apache.org<mailto:user@accumulo.apache.org>>
Date: Tuesday, August 6, 2013 11:12 AM

To: "user@accumulo.apache.org<mailto:user@accumulo.apache.org>" <user@accumulo.apache.org<mailto:user@accumulo.apache.org>>
Subject: Re: Communication issue between zookeeper and accumulo

Interesting.  You could not get similar performance improvements by increasing the size of
the JVM, the number of threads, or the number of tablets per server?

If you have details about what configurations you've tried and the performance numbers you
found, please open a ticket.  This would indicate that we have some unnecessary bottleneck
in the tserver.

-Eric


On Tue, Aug 6, 2013 at 11:00 AM, Ray Pfaff <ray.pfaff@apx-labs.com<mailto:ray.pfaff@apx-labs.com>>
wrote:
Because we found this to be the optimal number of tablet servers in our testing.  It performs
better than one per machine.  I'm not convinced that the stability issues make it worthwhile.
Doesn't affect my problem anyway.  I get this error whether I run one or four tablet servers.
 Running four just makes it a bigger issue to get back up after failure.

From: Eric Newton <eric.newton@gmail.com<mailto:eric.newton@gmail.com>>
Reply-To: "user@accumulo.apache.org<mailto:user@accumulo.apache.org>" <user@accumulo.apache.org<mailto:user@accumulo.apache.org>>
Date: Tuesday, August 6, 2013 10:56 AM
To: "user@accumulo.apache.org<mailto:user@accumulo.apache.org>" <user@accumulo.apache.org<mailto:user@accumulo.apache.org>>
Subject: Re: Communication issue between zookeeper and accumulo


I'm running 4 tservers per machine dedicated to the tablet servers

Why?





--
Sean

Mime
View raw message